$$INTRODUCTION$$ - %%projecttitle%%

Spring.Erlang
Introduction
Send Feedback
The class in this assembly make is easier to interact with Erlang processes and reduce the likelihood of common errors.
© 2010 All Rights Reserved.


%%phrase%%

Spring.Erlang
Spring.Erlang Assembly
See Also Send Feedback
The class in this assembly make is easier to interact with Erlang processes and reduce the likelihood of common errors.

Namespaces

Namespace | Description
Spring.Erlang | Common exceptions
Spring.Erlang.Connection | Utility classes for easy connection management
Spring.Erlang.Core | Provides the core of the Erlang framework, based on ErlangTemplate and its associated callback interface and helper objects.
Spring.Erlang.Support | Classes supporting the Spring.Erlang.Core namespace.
Spring.Erlang.Support.Converter | Provides a converter abstraction to convert between .NET and Erlang data types.


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Erlang
Getting Started
Send Feedback
Please read the reference documentation and look into the implementation of RabbitBroker admin for usage.


%%ItemTitle%%

Spring.Erlang
Spring.Erlang Namespace
See Also Inheritance Hierarchy Send Feedback
Common exceptions

Classes

 | Class | Description
Class | ErlangBadRpcException | Exception thrown when an 'badrpc' is received from an Erlang RPC call.
Class | ErlangErrorRpcException | Exception thrown when an 'error' is received from an Erlang RPC call.
Class | UncategorizedOtpException | A "catch-all" exception type within the OtpErlangException hierarchy when no more specific cause is known.

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangBadRpcException Class
Members See Also Send Feedback
Spring.Erlang Namespace : ErlangBadRpcException Class
Exception thrown when an 'badrpc' is received from an Erlang RPC call.

Syntax

C#
public class ErlangBadRpcException : OtpErlangException

Inheritance Hierarchy

System.Object
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.ErlangBadRpcException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangBadRpcException Members
Spring.Erlang Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangBadRpcException Class Members
See Also Properties Methods Send Feedback
Spring.Erlang Namespace : ErlangBadRpcException Class

The following tables list the members exposed by ErlangBadRpcException.

Public Constructors

 | Name | Description
Public Constructor | ErlangBadRpcException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | ReasonTuple |
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangBadRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangBadRpcException Constructor
See Also Send Feedback
Spring.Erlang Namespace > ErlangBadRpcException Class : ErlangBadRpcException Constructor

Overload List

Overload | Description
ErlangBadRpcException Constructor(OtpErlangTuple) |
ErlangBadRpcException Constructor(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangBadRpcException Class
ErlangBadRpcException Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangBadRpcException Constructor(OtpErlangTuple)
See Also Send Feedback
Spring.Erlang Namespace > ErlangBadRpcException Class > ErlangBadRpcException Constructor : ErlangBadRpcException Constructor(OtpErlangTuple)
tuple

Syntax

C#
public ErlangBadRpcException(
   OtpErlangTuple tuple
)

Parameters

tuple

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangBadRpcException Class
ErlangBadRpcException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangBadRpcException Constructor(String)
See Also Send Feedback
Spring.Erlang Namespace > ErlangBadRpcException Class > ErlangBadRpcException Constructor : ErlangBadRpcException Constructor(String)
reason

Syntax

C#
public ErlangBadRpcException(
   string reason
)

Parameters

reason

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangBadRpcException Class
ErlangBadRpcException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
ErlangBadRpcException Class Properties
See Also Send Feedback
Spring.Erlang Namespace : ErlangBadRpcException Class

For a list of all members of this type, see ErlangBadRpcException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | ReasonTuple |
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangBadRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ReasonTuple Property
See Also Send Feedback
Spring.Erlang Namespace > ErlangBadRpcException Class : ReasonTuple Property

Syntax

C#
public OtpErlangTuple ReasonTuple {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangBadRpcException Class
ErlangBadRpcException Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangErrorRpcException Class
Members See Also Send Feedback
Spring.Erlang Namespace : ErlangErrorRpcException Class
Exception thrown when an 'error' is received from an Erlang RPC call.

Syntax

C#
public class ErlangErrorRpcException : OtpErlangException

Inheritance Hierarchy

System.Object
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.ErlangErrorRpcException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangErrorRpcException Members
Spring.Erlang Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangErrorRpcException Class Members
See Also Properties Methods Send Feedback
Spring.Erlang Namespace : ErlangErrorRpcException Class

The following tables list the members exposed by ErlangErrorRpcException.

Public Constructors

 | Name | Description
Public Constructor | ErlangErrorRpcException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | ReasonTuple |
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangErrorRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangErrorRpcException Constructor
See Also Send Feedback
Spring.Erlang Namespace > ErlangErrorRpcException Class : ErlangErrorRpcException Constructor

Overload List

Overload | Description
ErlangErrorRpcException Constructor(OtpErlangTuple) |
ErlangErrorRpcException Constructor(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangErrorRpcException Class
ErlangErrorRpcException Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangErrorRpcException Constructor(OtpErlangTuple)
See Also Send Feedback
Spring.Erlang Namespace > ErlangErrorRpcException Class > ErlangErrorRpcException Constructor : ErlangErrorRpcException Constructor(OtpErlangTuple)
tuple

Syntax

C#
public ErlangErrorRpcException(
   OtpErlangTuple tuple
)

Parameters

tuple

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangErrorRpcException Class
ErlangErrorRpcException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangErrorRpcException Constructor(String)
See Also Send Feedback
Spring.Erlang Namespace > ErlangErrorRpcException Class > ErlangErrorRpcException Constructor : ErlangErrorRpcException Constructor(String)
reason

Syntax

C#
public ErlangErrorRpcException(
   string reason
)

Parameters

reason

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangErrorRpcException Class
ErlangErrorRpcException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
ErlangErrorRpcException Class Properties
See Also Send Feedback
Spring.Erlang Namespace : ErlangErrorRpcException Class

For a list of all members of this type, see ErlangErrorRpcException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | ReasonTuple |
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangErrorRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ReasonTuple Property
See Also Send Feedback
Spring.Erlang Namespace > ErlangErrorRpcException Class : ReasonTuple Property

Syntax

C#
public OtpErlangTuple ReasonTuple {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangErrorRpcException Class
ErlangErrorRpcException Members


%%PageItemTitle%%

[image]
Spring.Erlang
UncategorizedOtpException Class
Members See Also Send Feedback
Spring.Erlang Namespace : UncategorizedOtpException Class
A "catch-all" exception type within the OtpErlangException hierarchy when no more specific cause is known.

Syntax

C#
public class UncategorizedOtpException : OtpErlangException

Inheritance Hierarchy

System.Object
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.UncategorizedOtpException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UncategorizedOtpException Members
Spring.Erlang Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
UncategorizedOtpException Class Members
See Also Properties Methods Send Feedback
Spring.Erlang Namespace : UncategorizedOtpException Class

The following tables list the members exposed by UncategorizedOtpException.

Public Constructors

 | Name | Description
Public Constructor | UncategorizedOtpException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

UncategorizedOtpException Class
Spring.Erlang Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
UncategorizedOtpException Constructor
See Also Send Feedback
Spring.Erlang Namespace > UncategorizedOtpException Class : UncategorizedOtpException Constructor

Overload List

Overload | Description
UncategorizedOtpException Constructor() |
UncategorizedOtpException Constructor(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UncategorizedOtpException Class
UncategorizedOtpException Members


%%PageItemTitle%%

[image]
Spring.Erlang
UncategorizedOtpException Constructor()
See Also Send Feedback
Spring.Erlang Namespace > UncategorizedOtpException Class > UncategorizedOtpException Constructor : UncategorizedOtpException Constructor()

Syntax

C#
public UncategorizedOtpException()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UncategorizedOtpException Class
UncategorizedOtpException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
UncategorizedOtpException Constructor(String)
See Also Send Feedback
Spring.Erlang Namespace > UncategorizedOtpException Class > UncategorizedOtpException Constructor : UncategorizedOtpException Constructor(String)
msg

Syntax

C#
public UncategorizedOtpException(
   string msg
)

Parameters

msg

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UncategorizedOtpException Class
UncategorizedOtpException Members
Overload List


%%ItemTitle%%

Spring.Erlang
Spring.Erlang.Connection Namespace
See Also Inheritance Hierarchy Send Feedback
Utility classes for easy connection management

Classes

 | Class | Description
Class | ConnectionFactoryUtils |
Class | SimpleConnectionFactory |

Interfaces

 | Interface | Description
Interface | IConnectionFactory | An interface based ConnectionFactory for creating OtpConnections.

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%%

[image]
Spring.Erlang
ConnectionFactoryUtils Class
Members See Also Send Feedback
Spring.Erlang.Connection Namespace : ConnectionFactoryUtils Class

Syntax

C#
public class ConnectionFactoryUtils

Inheritance Hierarchy

System.Object
Spring.Erlang.Connection.ConnectionFactoryUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Members
Spring.Erlang.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ConnectionFactoryUtils Class Members
See Also Fields Methods Send Feedback
Spring.Erlang.Connection Namespace : ConnectionFactoryUtils Class

The following tables list the members exposed by ConnectionFactoryUtils.

Public Constructors

 | Name | Description
Public Constructor | ConnectionFactoryUtils Constructor |
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ConnectionFactoryUtils Class
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ConnectionFactoryUtils Constructor
See Also Send Feedback
Spring.Erlang.Connection Namespace > ConnectionFactoryUtils Class : ConnectionFactoryUtils Constructor

Syntax

C#
public ConnectionFactoryUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ConnectionFactoryUtils Class Methods
See Also Send Feedback
Spring.Erlang.Connection Namespace : ConnectionFactoryUtils Class

For a list of all members of this type, see ConnectionFactoryUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ConnectionFactoryUtils Class
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ReleaseConnection Method
See Also Send Feedback
Spring.Erlang.Connection Namespace > ConnectionFactoryUtils Class : ReleaseConnection Method
con
cf

Syntax

C#
public static void ReleaseConnection(
   OtpConnection con,
   IConnectionFactory cf
)

Parameters

con
cf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Erlang
ConnectionFactoryUtils Class Fields
See Also Send Feedback
Spring.Erlang.Connection Namespace : ConnectionFactoryUtils Class

For a list of all members of this type, see ConnectionFactoryUtils members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

See Also

Reference

ConnectionFactoryUtils Class
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
logger Field
See Also Send Feedback
Spring.Erlang.Connection Namespace > ConnectionFactoryUtils Class : logger Field

Syntax

C#
protected static readonly ILog logger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleConnectionFactory Class
Members See Also Send Feedback
Spring.Erlang.Connection Namespace : SimpleConnectionFactory Class

Syntax

C#
public class SimpleConnectionFactory : IConnectionFactory, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Erlang.Connection.SimpleConnectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Members
Spring.Erlang.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
SimpleConnectionFactory Class Members
See Also Methods Send Feedback
Spring.Erlang.Connection Namespace : SimpleConnectionFactory Class

The following tables list the members exposed by SimpleConnectionFactory.

Public Constructors

 | Name | Description
Public Constructor | SimpleConnectionFactory Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | CreateConnection |
Top

See Also

Reference

SimpleConnectionFactory Class
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleConnectionFactory Constructor
See Also Send Feedback
Spring.Erlang.Connection Namespace > SimpleConnectionFactory Class : SimpleConnectionFactory Constructor

Overload List

Overload | Description
SimpleConnectionFactory Constructor(String,String) |
SimpleConnectionFactory Constructor(String,String,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Class
SimpleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleConnectionFactory Constructor(String,String)
See Also Send Feedback
Spring.Erlang.Connection Namespace > SimpleConnectionFactory Class > SimpleConnectionFactory Constructor : SimpleConnectionFactory Constructor(String,String)
selfNodeName
peerNodeName

Syntax

C#
public SimpleConnectionFactory(
   string selfNodeName,
   string peerNodeName
)

Parameters

selfNodeName
peerNodeName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Class
SimpleConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleConnectionFactory Constructor(String,String,String)
See Also Send Feedback
Spring.Erlang.Connection Namespace > SimpleConnectionFactory Class > SimpleConnectionFactory Constructor : SimpleConnectionFactory Constructor(String,String,String)
selfNodeName
cookie
peerNodeName

Syntax

C#
public SimpleConnectionFactory(
   string selfNodeName,
   string cookie,
   string peerNodeName
)

Parameters

selfNodeName
cookie
peerNodeName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Class
SimpleConnectionFactory Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
SimpleConnectionFactory Class Methods
See Also Send Feedback
Spring.Erlang.Connection Namespace : SimpleConnectionFactory Class

For a list of all members of this type, see SimpleConnectionFactory members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | CreateConnection |
Top

See Also

Reference

SimpleConnectionFactory Class
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
AfterPropertiesSet Method
See Also Send Feedback
Spring.Erlang.Connection Namespace > SimpleConnectionFactory Class : AfterPropertiesSet Method

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Class
SimpleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Erlang
CreateConnection Method
See Also Send Feedback
Spring.Erlang.Connection Namespace > SimpleConnectionFactory Class : CreateConnection Method

Syntax

C#
public OtpConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleConnectionFactory Class
SimpleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Erlang
IConnectionFactory Interface
Members See Also Send Feedback
Spring.Erlang.Connection Namespace : IConnectionFactory Interface
An interface based ConnectionFactory for creating OtpConnections.

Syntax

C#
public interface IConnectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Members
Spring.Erlang.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
IConnectionFactory Interface Members
See Also Methods Send Feedback
Spring.Erlang.Connection Namespace : IConnectionFactory Interface

The following tables list the members exposed by IConnectionFactory.

Public Methods

 | Name | Description
Method | CreateConnection |
Top

See Also

Reference

IConnectionFactory Interface
Spring.Erlang.Connection Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
IConnectionFactory Interface Methods
See Also Send Feedback
Spring.Erlang.Connection Namespace : IConnectionFactory Interface

For a list of all members of this type, see IConnectionFactory members.

Public Methods

 | Name | Description
Method | CreateConnection |
Top

See Also

Reference

IConnectionFactory Interface
Spring.Erlang.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
CreateConnection Method
See Also Send Feedback
Spring.Erlang.Connection Namespace > IConnectionFactory Interface : CreateConnection Method

Syntax

C#
OtpConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Interface
IConnectionFactory Members


%%ItemTitle%%

Spring.Erlang
Spring.Erlang.Core Namespace
See Also Inheritance Hierarchy Send Feedback
Provides the core of the Erlang framework, based on ErlangTemplate and its associated callback interface and helper objects.

Classes

 | Class | Description
Class | Application | Describes an Erlang application. Only three fields are supported as that is the level of information that rabbitmq returns when performing a status request.
Class | ErlangAccessor |
Class | ErlangTemplate |
Class | Node | Simple description class for an Erlang node.

Interfaces

 | Interface | Description
Interface | IErlangOperations |

Delegates

 | Delegate | Description
Delegate | Generic ConnectionCallbackDelegate | Execute any number of operations against the supplied OTP connection, possibly returning a result.

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%%

[image]
Spring.Erlang
Application Class
Members See Also Send Feedback
Spring.Erlang.Core Namespace : Application Class
Describes an Erlang application. Only three fields are supported as that is the level of information that rabbitmq returns when performing a status request.

Syntax

C#
public class Application

Remarks

See http://www.erlang.org/doc/man/app.html for full details

Inheritance Hierarchy

System.Object
Spring.Erlang.Core.Application

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Members
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
Application Class Members
See Also Properties Methods Send Feedback
Spring.Erlang.Core Namespace : Application Class

The following tables list the members exposed by Application.

Public Constructors

 | Name | Description
Public Constructor | Application Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description |
Public Property | Id |
Public Property | Version |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Application Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
Application Constructor
See Also Send Feedback
Spring.Erlang.Core Namespace > Application Class : Application Constructor
description
id
version

Syntax

C#
public Application(
   string description,
   string id,
   string version
)

Parameters

description
id
version

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
Application Class Methods
See Also Send Feedback
Spring.Erlang.Core Namespace : Application Class

For a list of all members of this type, see Application members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Application Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ToString Method
See Also Send Feedback
Spring.Erlang.Core Namespace > Application Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
Application Class Properties
See Also Send Feedback
Spring.Erlang.Core Namespace : Application Class

For a list of all members of this type, see Application members.

Public Properties

 | Name | Description
Public Property | Description |
Public Property | Id |
Public Property | Version |
Top

See Also

Reference

Application Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
Description Property
See Also Send Feedback
Spring.Erlang.Core Namespace > Application Class : Description Property

Syntax

C#
public string Description {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


%%PageItemTitle%%

[image]
Spring.Erlang
Id Property
See Also Send Feedback
Spring.Erlang.Core Namespace > Application Class : Id Property

Syntax

C#
public string Id {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


%%PageItemTitle%%

[image]
Spring.Erlang
Version Property
See Also Send Feedback
Spring.Erlang.Core Namespace > Application Class : Version Property

Syntax

C#
public string Version {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangAccessor Class
Members See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangAccessor Class

Object Model

Syntax

C#
public abstract class ErlangAccessor : IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Erlang.Core.ErlangAccessor
Spring.Erlang.Core.ErlangTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangAccessor Members
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangAccessor Class Members
See Also Fields Properties Methods Send Feedback
Spring.Erlang.Core Namespace : ErlangAccessor Class

The following tables list the members exposed by ErlangAccessor.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

Public Properties

 | Name | Description
Public Property | ConnectionFactory |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | createConnection |
Top

See Also

Reference

ErlangAccessor Class
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangAccessor Class Methods
See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangAccessor Class

For a list of all members of this type, see ErlangAccessor members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | createConnection |
Top

See Also

Reference

ErlangAccessor Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
AfterPropertiesSet Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangAccessor Class : AfterPropertiesSet Method

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangAccessor Class
ErlangAccessor Members


%%PageItemTitle%%

[image]
Spring.Erlang
createConnection Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangAccessor Class : createConnection Method

Syntax

C#
protected OtpConnection createConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangAccessor Class
ErlangAccessor Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
ErlangAccessor Class Properties
See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangAccessor Class

For a list of all members of this type, see ErlangAccessor members.

Public Properties

 | Name | Description
Public Property | ConnectionFactory |
Top

See Also

Reference

ErlangAccessor Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ConnectionFactory Property
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangAccessor Class : ConnectionFactory Property

Syntax

C#
public IConnectionFactory ConnectionFactory {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangAccessor Class
ErlangAccessor Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Erlang
ErlangAccessor Class Fields
See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangAccessor Class

For a list of all members of this type, see ErlangAccessor members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

See Also

Reference

ErlangAccessor Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
logger Field
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangAccessor Class : logger Field

Syntax

C#
protected static readonly ILog logger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangAccessor Class
ErlangAccessor Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangTemplate Class
Members See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangTemplate Class

Object Model

Syntax

C#
public class ErlangTemplate : ErlangAccessor, IErlangOperations, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Erlang.Core.ErlangAccessor
Spring.Erlang.Core.ErlangTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Members
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangTemplate Class Members
See Also Properties Methods Send Feedback
Spring.Erlang.Core Namespace : ErlangTemplate Class

The following tables list the members exposed by ErlangTemplate.

Public Constructors

 | Name | Description
Public Constructor | ErlangTemplate Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectionFactory | (Inherited from ErlangAccessor)
Public Property | ErlangConverter |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from ErlangAccessor)
Public Method | Generic Execute |
Public Method | ExecuteAndConvertRpc | Overloaded.
Public Method | ExecuteErlangRpc | Overloaded.
Public Method | ExecuteRpc |
Public Method | HandleResponseError |
Top

Protected Methods

 | Name | Description
Protected Method | ConvertOtpAccessException |
Protected Method | createConnection | (Inherited from ErlangAccessor)
Top

See Also

Reference

ErlangTemplate Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangTemplate Constructor
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ErlangTemplate Constructor
connectionFactory

Syntax

C#
public ErlangTemplate(
   IConnectionFactory connectionFactory
)

Parameters

connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangTemplate Class Methods
See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangTemplate Class

For a list of all members of this type, see ErlangTemplate members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from ErlangAccessor)
Public Method | Generic Execute |
Public Method | ExecuteAndConvertRpc | Overloaded.
Public Method | ExecuteErlangRpc | Overloaded.
Public Method | ExecuteRpc |
Public Method | HandleResponseError |
Top

Protected Methods

 | Name | Description
Protected Method | ConvertOtpAccessException |
Protected Method | createConnection | (Inherited from ErlangAccessor)
Top

See Also

Reference

ErlangTemplate Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ConvertOtpAccessException Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ConvertOtpAccessException Method
ex

Syntax

C#
protected OtpException ConvertOtpAccessException(
   Exception ex
)

Parameters

ex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

T
[image]
Spring.Erlang
Generic Execute Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : Generic Execute Method
action

Syntax

C#
public T Execute<T>(
   ConnectionCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ExecuteAndConvertRpc Method

Overload List

Overload | Description
ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) |
ExecuteAndConvertRpc(String,String,Object[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class > ExecuteAndConvertRpc Method : ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) Method
module
function
converterToUse
args

Syntax

C#
public object ExecuteAndConvertRpc(
   string module,
   string function,
   IErlangConverter converterToUse,
   params object[] args
)

Parameters

module
function
converterToUse
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc(String,String,Object[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class > ExecuteAndConvertRpc Method : ExecuteAndConvertRpc(String,String,Object[]) Method
module
function
args

Syntax

C#
public object ExecuteAndConvertRpc(
   string module,
   string function,
   params object[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ExecuteErlangRpc Method

Overload List

Overload | Description
ExecuteErlangRpc(String,String,OtpErlangList) |
ExecuteErlangRpc(String,String,OtpErlangObject[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc(String,String,OtpErlangList) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class > ExecuteErlangRpc Method : ExecuteErlangRpc(String,String,OtpErlangList) Method
module
function
args

Syntax

C#
public OtpErlangObject ExecuteErlangRpc(
   string module,
   string function,
   OtpErlangList args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc(String,String,OtpErlangObject[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class > ExecuteErlangRpc Method : ExecuteErlangRpc(String,String,OtpErlangObject[]) Method
module
function
args

Syntax

C#
public OtpErlangObject ExecuteErlangRpc(
   string module,
   string function,
   params OtpErlangObject[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ExecuteRpc Method
module
function
args

Syntax

C#
public OtpErlangObject ExecuteRpc(
   string module,
   string function,
   params object[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

[image]
Spring.Erlang
HandleResponseError Method
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : HandleResponseError Method
module
function
result

Syntax

C#
public void HandleResponseError(
   string module,
   string function,
   OtpErlangObject result
)

Parameters

module
function
result

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
ErlangTemplate Class Properties
See Also Send Feedback
Spring.Erlang.Core Namespace : ErlangTemplate Class

For a list of all members of this type, see ErlangTemplate members.

Public Properties

 | Name | Description
Public Property | ConnectionFactory | (Inherited from ErlangAccessor)
Public Property | ErlangConverter |
Top

See Also

Reference

ErlangTemplate Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangConverter Property
See Also Send Feedback
Spring.Erlang.Core Namespace > ErlangTemplate Class : ErlangConverter Property

Syntax

C#
public IErlangConverter ErlangConverter {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangTemplate Class
ErlangTemplate Members


%%PageItemTitle%%

[image]
Spring.Erlang
Node Class
Members See Also Send Feedback
Spring.Erlang.Core Namespace : Node Class
Simple description class for an Erlang node.

Syntax

C#
public class Node

Inheritance Hierarchy

System.Object
Spring.Erlang.Core.Node

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Node Members
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
Node Class Members
See Also Properties Methods Send Feedback
Spring.Erlang.Core Namespace : Node Class

The following tables list the members exposed by Node.

Public Constructors

 | Name | Description
Public Constructor | Node Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Node Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
Node Constructor
See Also Send Feedback
Spring.Erlang.Core Namespace > Node Class : Node Constructor
name

Syntax

C#
public Node(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Node Class
Node Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
Node Class Methods
See Also Send Feedback
Spring.Erlang.Core Namespace : Node Class

For a list of all members of this type, see Node members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Node Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ToString Method
See Also Send Feedback
Spring.Erlang.Core Namespace > Node Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Node Class
Node Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
Node Class Properties
See Also Send Feedback
Spring.Erlang.Core Namespace : Node Class

For a list of all members of this type, see Node members.

Public Properties

 | Name | Description
Public Property | Name |
Top

See Also

Reference

Node Class
Spring.Erlang.Core Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
Name Property
See Also Send Feedback
Spring.Erlang.Core Namespace > Node Class : Name Property

Syntax

C#
public string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Node Class
Node Members


%%PageItemTitle%%

[image]
Spring.Erlang
IErlangOperations Interface
Members See Also Send Feedback
Spring.Erlang.Core Namespace : IErlangOperations Interface

Syntax

C#
public interface IErlangOperations

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Members
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
IErlangOperations Interface Members
See Also Methods Send Feedback
Spring.Erlang.Core Namespace : IErlangOperations Interface

The following tables list the members exposed by IErlangOperations.

Public Methods

 | Name | Description
Method | Generic Execute |
Method | ExecuteAndConvertRpc | Overloaded.
Method | ExecuteErlangRpc | Overloaded.
Method | ExecuteRpc |
Top

See Also

Reference

IErlangOperations Interface
Spring.Erlang.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
IErlangOperations Interface Methods
See Also Send Feedback
Spring.Erlang.Core Namespace : IErlangOperations Interface

For a list of all members of this type, see IErlangOperations members.

Public Methods

 | Name | Description
Method | Generic Execute |
Method | ExecuteAndConvertRpc | Overloaded.
Method | ExecuteErlangRpc | Overloaded.
Method | ExecuteRpc |
Top

See Also

Reference

IErlangOperations Interface
Spring.Erlang.Core Namespace


%%PageItemTitle%%

T
[image]
Spring.Erlang
Generic Execute Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface : Generic Execute Method
action

Syntax

C#
T Execute<T>(
   ConnectionCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface : ExecuteAndConvertRpc Method

Overload List

Overload | Description
ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) |
ExecuteAndConvertRpc(String,String,Object[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface > ExecuteAndConvertRpc Method : ExecuteAndConvertRpc(String,String,IErlangConverter,Object[]) Method
module
function
converterToUse
args

Syntax

C#
object ExecuteAndConvertRpc(
   string module,
   string function,
   IErlangConverter converterToUse,
   params object[] args
)

Parameters

module
function
converterToUse
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteAndConvertRpc(String,String,Object[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface > ExecuteAndConvertRpc Method : ExecuteAndConvertRpc(String,String,Object[]) Method
module
function
args

Syntax

C#
object ExecuteAndConvertRpc(
   string module,
   string function,
   params object[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface : ExecuteErlangRpc Method

Overload List

Overload | Description
ExecuteErlangRpc(String,String,OtpErlangList) |
ExecuteErlangRpc(String,String,OtpErlangObject[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc(String,String,OtpErlangList) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface > ExecuteErlangRpc Method : ExecuteErlangRpc(String,String,OtpErlangList) Method
module
function
args

Syntax

C#
OtpErlangObject ExecuteErlangRpc(
   string module,
   string function,
   OtpErlangList args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteErlangRpc(String,String,OtpErlangObject[]) Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface > ExecuteErlangRpc Method : ExecuteErlangRpc(String,String,OtpErlangObject[]) Method
module
function
args

Syntax

C#
OtpErlangObject ExecuteErlangRpc(
   string module,
   string function,
   params OtpErlangObject[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ExecuteRpc Method
See Also Send Feedback
Spring.Erlang.Core Namespace > IErlangOperations Interface : ExecuteRpc Method
module
function
args

Syntax

C#
OtpErlangObject ExecuteRpc(
   string module,
   string function,
   params object[] args
)

Parameters

module
function
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangOperations Interface
IErlangOperations Members


%%PageItemTitle%%

[image]
Spring.Erlang
Generic ConnectionCallbackDelegate Delegate
See Also Send Feedback
Spring.Erlang.Core Namespace : Generic ConnectionCallbackDelegate Delegate
channel
Execute any number of operations against the supplied OTP connection, possibly returning a result.

Syntax

C#
public delegate T ConnectionCallbackDelegate<T>(
   OtpConnection channel
)

Parameters

channel

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Erlang.Core Namespace


%%ItemTitle%%

Spring.Erlang
Spring.Erlang.Support Namespace
See Also Inheritance Hierarchy Send Feedback
Classes supporting the Spring.Erlang.Core namespace.

Classes

 | Class | Description
Class | ErlangUtils |

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangUtils Class
Members See Also Send Feedback
Spring.Erlang.Support Namespace : ErlangUtils Class

Syntax

C#
public class ErlangUtils

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.ErlangUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangUtils Members
Spring.Erlang.Support Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangUtils Class Members
See Also Methods Send Feedback
Spring.Erlang.Support Namespace : ErlangUtils Class

The following tables list the members exposed by ErlangUtils.

Public Constructors

 | Name | Description
Public Constructor | ErlangUtils Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertOtpAccessException |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ErlangUtils Class
Spring.Erlang.Support Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangUtils Constructor
See Also Send Feedback
Spring.Erlang.Support Namespace > ErlangUtils Class : ErlangUtils Constructor

Syntax

C#
public ErlangUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangUtils Class
ErlangUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangUtils Class Methods
See Also Send Feedback
Spring.Erlang.Support Namespace : ErlangUtils Class

For a list of all members of this type, see ErlangUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertOtpAccessException |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ErlangUtils Class
Spring.Erlang.Support Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ConvertOtpAccessException Method
See Also Send Feedback
Spring.Erlang.Support Namespace > ErlangUtils Class : ConvertOtpAccessException Method
ex

Syntax

C#
public static OtpException ConvertOtpAccessException(
   Exception ex
)

Parameters

ex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangUtils Class
ErlangUtils Members


%%PageItemTitle%%

[image]
Spring.Erlang
ReleaseConnection Method
See Also Send Feedback
Spring.Erlang.Support Namespace > ErlangUtils Class : ReleaseConnection Method
con

Syntax

C#
public static void ReleaseConnection(
   OtpConnection con
)

Parameters

con

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangUtils Class
ErlangUtils Members


%%ItemTitle%%

Spring.Erlang
Spring.Erlang.Support.Converter Namespace
See Also Inheritance Hierarchy Send Feedback
Provides a converter abstraction to convert between .NET and Erlang data types.

Classes

 | Class | Description
Class | ErlangConversionException |
Class | SimpleErlangConverter | Converter that supports the basic types.

Interfaces

 | Interface | Description
Interface | IErlangConverter | Converter between .NET and Erlang Types. Additional support for converting results from RPC calls.

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangConversionException Class
Members See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : ErlangConversionException Class

Syntax

C#
public class ErlangConversionException : OtpErlangException

Inheritance Hierarchy

System.Object
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.Support.Converter.ErlangConversionException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangConversionException Members
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
ErlangConversionException Class Members
See Also Properties Methods Send Feedback
Spring.Erlang.Support.Converter Namespace : ErlangConversionException Class

The following tables list the members exposed by ErlangConversionException.

Public Constructors

 | Name | Description
Public Constructor | ErlangConversionException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangConversionException Class
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangConversionException Constructor
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > ErlangConversionException Class : ErlangConversionException Constructor

Overload List

Overload | Description
ErlangConversionException Constructor() |
ErlangConversionException Constructor(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangConversionException Class
ErlangConversionException Members


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangConversionException Constructor()
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > ErlangConversionException Class > ErlangConversionException Constructor : ErlangConversionException Constructor()

Syntax

C#
public ErlangConversionException()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangConversionException Class
ErlangConversionException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
ErlangConversionException Constructor(String)
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > ErlangConversionException Class > ErlangConversionException Constructor : ErlangConversionException Constructor(String)
msg

Syntax

C#
public ErlangConversionException(
   string msg
)

Parameters

msg

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErlangConversionException Class
ErlangConversionException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleErlangConverter Class
Members See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : SimpleErlangConverter Class
Converter that supports the basic types.

Syntax

C#
public class SimpleErlangConverter : IErlangConverter

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.Converter.SimpleErlangConverter
Spring.Messaging.Amqp.Rabbit.Admin.RabbitControlErlangConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Members
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
SimpleErlangConverter Class Members
See Also Methods Send Feedback
Spring.Erlang.Support.Converter Namespace : SimpleErlangConverter Class

The following tables list the members exposed by SimpleErlangConverter.

Public Constructors

 | Name | Description
Public Constructor | SimpleErlangConverter Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ExtractBoolean |
static (Shared in Visual Basic) | ExtractLong |
static (Shared in Visual Basic) | ExtractPid |
Public Method | FromErlang | Convert from an Erlang data type to a .NET data type.
Public Method | FromErlangRpc | The return value from executing the Erlang RPC.
Public Method | ToErlang | Convert a .NET object to a Erlang data type.
Top

See Also

Reference

SimpleErlangConverter Class
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
SimpleErlangConverter Constructor
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : SimpleErlangConverter Constructor

Syntax

C#
public SimpleErlangConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
SimpleErlangConverter Class Methods
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : SimpleErlangConverter Class

For a list of all members of this type, see SimpleErlangConverter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ExtractBoolean |
static (Shared in Visual Basic) | ExtractLong |
static (Shared in Visual Basic) | ExtractPid |
Public Method | FromErlang | Convert from an Erlang data type to a .NET data type.
Public Method | FromErlangRpc | The return value from executing the Erlang RPC.
Public Method | ToErlang | Convert a .NET object to a Erlang data type.
Top

See Also

Reference

SimpleErlangConverter Class
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
ExtractBoolean Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : ExtractBoolean Method
erlangObject

Syntax

C#
public static bool ExtractBoolean(
   OtpErlangObject erlangObject
)

Parameters

erlangObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExtractLong Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : ExtractLong Method
value

Syntax

C#
public static long ExtractLong(
   OtpErlangObject value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
ExtractPid Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : ExtractPid Method
value

Syntax

C#
public static string ExtractPid(
   OtpErlangObject value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
FromErlang Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : FromErlang Method
erlangObject
The erlang object.
Convert from an Erlang data type to a .NET data type.

Syntax

C#
public object FromErlang(
   OtpErlangObject erlangObject
)

Parameters

erlangObject
The erlang object.

Return Value

The converted .NET object

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
FromErlangRpc Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : FromErlangRpc Method
module
The module to call
function
The function to invoke
erlangObject
The erlang object that is passed in as a parameter
The return value from executing the Erlang RPC.

Syntax

C#
public object FromErlangRpc(
   string module,
   string function,
   OtpErlangObject erlangObject
)

Parameters

module
The module to call
function
The function to invoke
erlangObject
The erlang object that is passed in as a parameter

Return Value

The converted .NET object return value from the RPC call.

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
ToErlang Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > SimpleErlangConverter Class : ToErlang Method
objectToConvert
The object to convert.
Convert a .NET object to a Erlang data type.

Syntax

C#
public OtpErlangObject ToErlang(
   object objectToConvert
)

Parameters

objectToConvert
The object to convert.

Return Value

the Erlang data type

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleErlangConverter Class
SimpleErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
IErlangConverter Interface
Members See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : IErlangConverter Interface
Converter between .NET and Erlang Types. Additional support for converting results from RPC calls.

Syntax

C#
public interface IErlangConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangConverter Members
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Erlang
IErlangConverter Interface Members
See Also Methods Send Feedback
Spring.Erlang.Support.Converter Namespace : IErlangConverter Interface

The following tables list the members exposed by IErlangConverter.

Public Methods

 | Name | Description
Method | FromErlang | Convert from an Erlang data type to a .NET data type.
Method | FromErlangRpc | The return value from executing the Erlang RPC.
Method | ToErlang | Convert a .NET object to a Erlang data type.
Top

See Also

Reference

IErlangConverter Interface
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
IErlangConverter Interface Methods
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : IErlangConverter Interface

For a list of all members of this type, see IErlangConverter members.

Public Methods

 | Name | Description
Method | FromErlang | Convert from an Erlang data type to a .NET data type.
Method | FromErlangRpc | The return value from executing the Erlang RPC.
Method | ToErlang | Convert a .NET object to a Erlang data type.
Top

See Also

Reference

IErlangConverter Interface
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Erlang
FromErlang Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > IErlangConverter Interface : FromErlang Method
erlangObject
The erlang object.
Convert from an Erlang data type to a .NET data type.

Syntax

C#
object FromErlang(
   OtpErlangObject erlangObject
)

Parameters

erlangObject
The erlang object.

Return Value

The converted .NET object

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangConverter Interface
IErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
FromErlangRpc Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > IErlangConverter Interface : FromErlangRpc Method
module
The module to call
function
The function to invoke
erlangObject
The erlang object that is passed in as a parameter
The return value from executing the Erlang RPC.

Syntax

C#
object FromErlangRpc(
   string module,
   string function,
   OtpErlangObject erlangObject
)

Parameters

module
The module to call
function
The function to invoke
erlangObject
The erlang object that is passed in as a parameter

Return Value

The converted .NET object return value from the RPC call.

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangConverter Interface
IErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Erlang
ToErlang Method
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace > IErlangConverter Interface : ToErlang Method
objectToConvert
The object to convert.
Convert a .NET object to a Erlang data type.

Syntax

C#
OtpErlangObject ToErlang(
   object objectToConvert
)

Parameters

objectToConvert
The object to convert.

Return Value

the Erlang data type

Exceptions

Exception | Description
ErlangConversionException | in case of conversion failures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IErlangConverter Interface
IErlangConverter Members


$$INTRODUCTION$$ - %%projecttitle%%

Spring.Messaging.Amqp
Introduction
Send Feedback
The assembly Spring.Messaging.Amqp contains the classes that represent the core AMQP "model". Our intention is to provide generic abstractions that do not rely on any particular AMQP broker implementation or client library. As a result, end user code will be more portable across vendor implementations as it can be developed against the abstraction layer only. These abstractions are then used implemented by broker-specific modules, such as 'Spring.Messaging.Amqp.Rabbit'. For the M1 release RabbitMQ and Apache Qpid (2 versions) have been used to vet these base abstractions.


%%phrase%%

Spring.Messaging.Amqp
Spring.Messaging.Amqp Assembly
See Also Send Feedback
This assembly contains integration classes for AMQP, providing classes that represent the core AMQP model that do not rely an any particular AMQP broker implementation or client library.

Namespaces

Namespace | Description
Spring.Messaging.Amqp.Core | Core package of the AMQP support
Spring.Messaging.Amqp.Support.Converter | Provide a MessageConverter abstraction to convert between .NET objects and AMQP payloads.


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Messaging.Amqp
Getting Started
Send Feedback
Please refer to the reference documentation and the sample applications.


%%ItemTitle%%

Spring.Messaging.Amqp
Spring.Messaging.Amqp.Core Namespace
See Also Inheritance Hierarchy Send Feedback
Core package of the AMQP support

Classes

 | Class | Description
Class | AbstractExchange |
Class | Address | Represents an address for publication of an AMQP message. The AMQP 0-8 and 0-9 specifications have an unstructured string that is used as a "reply to" address. There are however conventions in use and this class makes it easier to follow these conventions.
Class | Binding | Simple container collecting information to describe a queue binding. Takes Queue and Exchange class as arguments to facilitate wiring using [Definition] based configuration.
Class | BindingBuilder | Builder class to create bindings for a more fluent API style in code based configuration.
Class | BindingBuilder.DirectExchangeRoutingKeyConfigurer |
Class | BindingBuilder.ExchangeConfigurer |
Class | BindingBuilder.RoutingKeyConfigurer |
Class | ContentType | A simple class to hold content type values.
Class | DirectExchange | Simple container collecting information to describe a direct exchange.
Class | FanoutExchange | Simple container collecting information to describe a fanout exchange.
Class | Message |
Class | Queue | Simple container collecting information to describe a queue.
Class | TopicExchange | Simple container collecting information to describe a topic exchange.

Interfaces

 | Interface | Description
Interface | IAmqpAdmin | Specifies a basic set of portable AMQP administrative operations for AMQP > 0.8
Interface | IAmqpTemplate | Specifies a basic set of AMQP operations
Interface | IExchange | Common properties that describe all exchange types.
Interface | IMessageCreator |
Interface | IMessageListener |
Interface | IMessageProperties |
Interface | IMessagePropertiesFactory | Factory interface for creating instances of IMesssageProperties.

Delegates

 | Delegate | Description
Delegate | MessagePostProcessorDelegate |

Enumerations

 | Enumeration | Description
Enumeration | ExchangeType | Enumeration of exchange types.
Enumeration | MessageDeliveryMode | Enumeration for the Message Delivery Mode. The None value is set in case the properties of the message do not contain any delivery mode value.

See Also

Reference

Spring.Messaging.Amqp Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AbstractExchange Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : AbstractExchange Class

Syntax

C#
public abstract class AbstractExchange : IExchange

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.AbstractExchange
Spring.Messaging.Amqp.Core.DirectExchange
Spring.Messaging.Amqp.Core.FanoutExchange
Spring.Messaging.Amqp.Core.TopicExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
AbstractExchange Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : AbstractExchange Class

The following tables list the members exposed by AbstractExchange.

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange.
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange.
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable.
Public Property | ExchangeType |
Public Property | Name |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

AbstractExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
AbstractExchange Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : AbstractExchange Class

For a list of all members of this type, see AbstractExchange members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

AbstractExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToString Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
AbstractExchange Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : AbstractExchange Class

For a list of all members of this type, see AbstractExchange members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange.
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange.
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable.
Public Property | ExchangeType |
Public Property | Name |
Top

See Also

Reference

AbstractExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Arguments Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : Arguments Property
Gets or sets the collection of arbitrary arguments to use when declaring an exchange.

Syntax

C#
public IDictionary Arguments {get; set;}

Return Value

The arguments.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AutoDelete Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : AutoDelete Property
Gets or sets a value indicating the auto-delete lifecycle of this exchange.

Syntax

C#
public bool AutoDelete {get; set;}

Return Value

true if if the server should delete the exchange when it is no longer in use; otherwise, false.

Remarks

An non-auto-deleted exchange lasts until the server is shut down.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Durable Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : Durable Property
Gets or sets a value indicating whether this AbstractExchange is durable.

Syntax

C#
public bool Durable {get; set;}

Return Value

true if describing a durable exchange (the exchange will survive a server restart), otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : ExchangeType Property

Syntax

C#
public abstract ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Name Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > AbstractExchange Class : Name Property

Syntax

C#
public string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractExchange Class
AbstractExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Address Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Address Class
Represents an address for publication of an AMQP message. The AMQP 0-8 and 0-9 specifications have an unstructured string that is used as a "reply to" address. There are however conventions in use and this class makes it easier to follow these conventions.

Syntax

C#
public class Address

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.Address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
Address Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : Address Class

The following tables list the members exposed by Address.

Public Constructors

 | Name | Description
Public Constructor | Address Constructor | Overloaded. Initializes a new instance of the Address class from an unstructured string
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | PSEUDO_URI_PARSER |
Top

Public Properties

 | Name | Description
Public Property | ExchangeName |
Public Property | ExchangeType |
Public Property | RoutingKey |
Public Property | Structured |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Public Method | ToString | Overridden.
Top

See Also

Reference

Address Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Address Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : Address Constructor
Initializes a new instance of the Address class from an unstructured string

Overload List

Overload | Description
Address Constructor(ExchangeType,String,String) | Initializes a new instance of the Address class given the exchange type, exchange name and routing key.
Address Constructor(String) | Initializes a new instance of the Address class from an unstructured string

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Address Constructor(ExchangeType,String,String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class > Address Constructor : Address Constructor(ExchangeType,String,String)
exchangeType
Type of the exchange.
exchangeName
Name of the exchange.
routingKey
The routing key.
Initializes a new instance of the Address class given the exchange type, exchange name and routing key.

Syntax

C#
public Address(
   ExchangeType exchangeType,
   string exchangeName,
   string routingKey
)

Parameters

exchangeType
Type of the exchange.
exchangeName
Name of the exchange.
routingKey
The routing key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Address Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class > Address Constructor : Address Constructor(String)
unstructuredAddress
The unstructured address.
Initializes a new instance of the Address class from an unstructured string

Syntax

C#
public Address(
   string unstructuredAddress
)

Parameters

unstructuredAddress
The unstructured address.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
Address Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Address Class

For a list of all members of this type, see Address members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse |
Public Method | ToString | Overridden.
Top

See Also

Reference

Address Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Parse Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : Parse Method
address

Syntax

C#
public static Address Parse(
   string address
)

Parameters

address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToString Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
Address Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Address Class

For a list of all members of this type, see Address members.

Public Properties

 | Name | Description
Public Property | ExchangeName |
Public Property | ExchangeType |
Public Property | RoutingKey |
Public Property | Structured |
Top

See Also

Reference

Address Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeName Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : ExchangeName Property

Syntax

C#
public string ExchangeName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : ExchangeType Property

Syntax

C#
public ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
RoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : RoutingKey Property

Syntax

C#
public string RoutingKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Structured Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : Structured Property

Syntax

C#
public bool Structured {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
Address Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Address Class

For a list of all members of this type, see Address members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | PSEUDO_URI_PARSER |
Top

See Also

Reference

Address Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
PSEUDO_URI_PARSER Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Address Class : PSEUDO_URI_PARSER Field

Syntax

C#
public static readonly Regex PSEUDO_URI_PARSER

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Address Class
Address Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Binding Class
Simple container collecting information to describe a queue binding. Takes Queue and Exchange class as arguments to facilitate wiring using [Definition] based configuration.

Syntax

C#
public class Binding

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.Binding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
Binding Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : Binding Class

The following tables list the members exposed by Binding.

Public Constructors

 | Name | Description
Public Constructor | Binding Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Arguments |
Public Property | Exchange |
Public Property | Queue |
Public Property | RoutingKey |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBinding |
Top

See Also

Reference

Binding Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : Binding Constructor

Overload List

Overload | Description
Binding Constructor(Queue,DirectExchange) |
Binding Constructor(Queue,DirectExchange,String) |
Binding Constructor(Queue,FanoutExchange) |
Binding Constructor(Queue,TopicExchange) |
Binding Constructor(Queue,TopicExchange,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor(Queue,DirectExchange)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class > Binding Constructor : Binding Constructor(Queue,DirectExchange)
queue
exchange

Syntax

C#
public Binding(
   Queue queue,
   DirectExchange exchange
)

Parameters

queue
exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor(Queue,DirectExchange,String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class > Binding Constructor : Binding Constructor(Queue,DirectExchange,String)
queue
exchange
routingKey

Syntax

C#
public Binding(
   Queue queue,
   DirectExchange exchange,
   string routingKey
)

Parameters

queue
exchange
routingKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor(Queue,FanoutExchange)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class > Binding Constructor : Binding Constructor(Queue,FanoutExchange)
queue
exchange

Syntax

C#
public Binding(
   Queue queue,
   FanoutExchange exchange
)

Parameters

queue
exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor(Queue,TopicExchange)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class > Binding Constructor : Binding Constructor(Queue,TopicExchange)
queue
exchange

Syntax

C#
public Binding(
   Queue queue,
   TopicExchange exchange
)

Parameters

queue
exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Binding Constructor(Queue,TopicExchange,String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class > Binding Constructor : Binding Constructor(Queue,TopicExchange,String)
queue
exchange
routingKey

Syntax

C#
public Binding(
   Queue queue,
   TopicExchange exchange,
   string routingKey
)

Parameters

queue
exchange
routingKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
Binding Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Binding Class

For a list of all members of this type, see Binding members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBinding |
Top

See Also

Reference

Binding Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CreateBinding Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : CreateBinding Method
queue
exchange
routingKey

Syntax

C#
public static Binding CreateBinding(
   Queue queue,
   IExchange exchange,
   string routingKey
)

Parameters

queue
exchange
routingKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
Binding Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Binding Class

For a list of all members of this type, see Binding members.

Public Properties

 | Name | Description
Public Property | Arguments |
Public Property | Exchange |
Public Property | Queue |
Public Property | RoutingKey |
Top

See Also

Reference

Binding Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Arguments Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : Arguments Property

Syntax

C#
public IDictionary Arguments {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Exchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : Exchange Property

Syntax

C#
public string Exchange {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Queue Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : Queue Property

Syntax

C#
public string Queue {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
RoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Binding Class : RoutingKey Property

Syntax

C#
public string RoutingKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder Class
Builder class to create bindings for a more fluent API style in code based configuration.

Syntax

C#
public class BindingBuilder

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.BindingBuilder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
BindingBuilder Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder Class

The following tables list the members exposed by BindingBuilder.

Public Constructors

 | Name | Description
Public Constructor | BindingBuilder Constructor |
Top

Public Methods

 | Name | Description
Public Method | From |
Top

See Also

Reference

BindingBuilder Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder Class : BindingBuilder Constructor

Syntax

C#
public BindingBuilder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder Class
BindingBuilder Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
BindingBuilder Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder Class

For a list of all members of this type, see BindingBuilder members.

Public Methods

 | Name | Description
Public Method | From |
Top

See Also

Reference

BindingBuilder Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
From Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder Class : From Method
queue

Syntax

C#
public BindingBuilder.ExchangeConfigurer From(
   Queue queue
)

Parameters

queue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder Class
BindingBuilder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.DirectExchangeRoutingKeyConfigurer Class

Object Model

Syntax

C#
public class BindingBuilder.DirectExchangeRoutingKeyConfigurer : BindingBuilder.RoutingKeyConfigurer

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.BindingBuilder.RoutingKeyConfigurer
Spring.Messaging.Amqp.Core.BindingBuilder.DirectExchangeRoutingKeyConfigurer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
BindingBuilder.DirectExchangeRoutingKeyConfigurer Class Members
See Also Fields Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.DirectExchangeRoutingKeyConfigurer Class

The following tables list the members exposed by BindingBuilder.DirectExchangeRoutingKeyConfigurer.

Public Constructors

 | Name | Description
Public Constructor | BindingBuilder.DirectExchangeRoutingKeyConfigurer Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | exchange | (Inherited from BindingBuilder.RoutingKeyConfigurer)
Protected Field | queue | (Inherited from BindingBuilder.RoutingKeyConfigurer)
Top

Public Methods

 | Name | Description
Public Method | With | Overloaded. (Inherited from BindingBuilder.RoutingKeyConfigurer)
Public Method | WithQueueName |
Top

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder.DirectExchangeRoutingKeyConfigurer Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.DirectExchangeRoutingKeyConfigurer Class : BindingBuilder.DirectExchangeRoutingKeyConfigurer Constructor
queue
exchange

Syntax

C#
public BindingBuilder.DirectExchangeRoutingKeyConfigurer(
   Queue queue,
   IExchange exchange
)

Parameters

queue
exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
BindingBuilder.DirectExchangeRoutingKeyConfigurer Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
BindingBuilder.DirectExchangeRoutingKeyConfigurer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.DirectExchangeRoutingKeyConfigurer Class

For a list of all members of this type, see BindingBuilder.DirectExchangeRoutingKeyConfigurer members.

Public Methods

 | Name | Description
Public Method | With | Overloaded. (Inherited from BindingBuilder.RoutingKeyConfigurer)
Public Method | WithQueueName |
Top

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
WithQueueName Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.DirectExchangeRoutingKeyConfigurer Class : WithQueueName Method

Syntax

C#
public Binding WithQueueName()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
BindingBuilder.DirectExchangeRoutingKeyConfigurer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder.ExchangeConfigurer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.ExchangeConfigurer Class

Syntax

C#
public class BindingBuilder.ExchangeConfigurer

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.BindingBuilder.ExchangeConfigurer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.ExchangeConfigurer Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
BindingBuilder.ExchangeConfigurer Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.ExchangeConfigurer Class

The following tables list the members exposed by BindingBuilder.ExchangeConfigurer.

Public Methods

 | Name | Description
Public Method | To | Overloaded.
Top

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
BindingBuilder.ExchangeConfigurer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.ExchangeConfigurer Class

For a list of all members of this type, see BindingBuilder.ExchangeConfigurer members.

Public Methods

 | Name | Description
Public Method | To | Overloaded.
Top

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
To Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.ExchangeConfigurer Class : To Method

Overload List

Overload | Description
To(FanoutExchange) |
To(DirectExchange) |
To(IExchange) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
BindingBuilder.ExchangeConfigurer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
To(FanoutExchange) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.ExchangeConfigurer Class > To Method : To(FanoutExchange) Method
fanoutExchange

Syntax

C#
public Binding To(
   FanoutExchange fanoutExchange
)

Parameters

fanoutExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
BindingBuilder.ExchangeConfigurer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
To(DirectExchange) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.ExchangeConfigurer Class > To Method : To(DirectExchange) Method
directExchange

Syntax

C#
public BindingBuilder.DirectExchangeRoutingKeyConfigurer To(
   DirectExchange directExchange
)

Parameters

directExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
BindingBuilder.ExchangeConfigurer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
To(IExchange) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.ExchangeConfigurer Class > To Method : To(IExchange) Method
exchange

Syntax

C#
public BindingBuilder.RoutingKeyConfigurer To(
   IExchange exchange
)

Parameters

exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.ExchangeConfigurer Class
BindingBuilder.ExchangeConfigurer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder.RoutingKeyConfigurer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.RoutingKeyConfigurer Class

Object Model

Syntax

C#
public class BindingBuilder.RoutingKeyConfigurer

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.BindingBuilder.RoutingKeyConfigurer
Spring.Messaging.Amqp.Core.BindingBuilder.DirectExchangeRoutingKeyConfigurer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
BindingBuilder.RoutingKeyConfigurer Class Members
See Also Fields Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.RoutingKeyConfigurer Class

The following tables list the members exposed by BindingBuilder.RoutingKeyConfigurer.

Public Constructors

 | Name | Description
Public Constructor | BindingBuilder.RoutingKeyConfigurer Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | exchange |
Protected Field | queue |
Top

Public Methods

 | Name | Description
Public Method | With | Overloaded.
Top

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
BindingBuilder.RoutingKeyConfigurer Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class : BindingBuilder.RoutingKeyConfigurer Constructor
queue
exchange

Syntax

C#
public BindingBuilder.RoutingKeyConfigurer(
   Queue queue,
   IExchange exchange
)

Parameters

queue
exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
BindingBuilder.RoutingKeyConfigurer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.RoutingKeyConfigurer Class

For a list of all members of this type, see BindingBuilder.RoutingKeyConfigurer members.

Public Methods

 | Name | Description
Public Method | With | Overloaded.
Top

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
With Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class : With Method

Overload List

Overload | Description
With(String) |
With(Enum) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
With(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class > With Method : With(String) Method
routingKey

Syntax

C#
public Binding With(
   string routingKey
)

Parameters

routingKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
With(Enum) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class > With Method : With(Enum) Method
routingKeyEnum

Syntax

C#
public Binding With(
   Enum routingKeyEnum
)

Parameters

routingKeyEnum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members
Overload List


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
BindingBuilder.RoutingKeyConfigurer Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.RoutingKeyConfigurer Class

For a list of all members of this type, see BindingBuilder.RoutingKeyConfigurer members.

Protected Fields

 | Name | Description
Protected Field | exchange |
Protected Field | queue |
Top

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
exchange Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class : exchange Field

Syntax

C#
protected readonly IExchange exchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
queue Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > BindingBuilder.RoutingKeyConfigurer Class : queue Field

Syntax

C#
protected readonly Queue queue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingBuilder.RoutingKeyConfigurer Class
BindingBuilder.RoutingKeyConfigurer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ContentType Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : ContentType Class
A simple class to hold content type values.

Syntax

C#
public class ContentType

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.ContentType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
ContentType Class Members
See Also Fields Send Feedback
Spring.Messaging.Amqp.Core Namespace : ContentType Class

The following tables list the members exposed by ContentType.

Public Constructors

 | Name | Description
Public Constructor | ContentType Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

See Also

Reference

ContentType Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ContentType Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > ContentType Class : ContentType Constructor

Syntax

C#
public ContentType()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Class
ContentType Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
ContentType Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : ContentType Class

For a list of all members of this type, see ContentType members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

See Also

Reference

ContentType Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CONTENT_TYPE_BYTES Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > ContentType Class : CONTENT_TYPE_BYTES Field

Syntax

C#
public static readonly string CONTENT_TYPE_BYTES

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Class
ContentType Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CONTENT_TYPE_JSON Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > ContentType Class : CONTENT_TYPE_JSON Field

Syntax

C#
public static readonly string CONTENT_TYPE_JSON

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Class
ContentType Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CONTENT_TYPE_SERIALIZED_OBJECT Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > ContentType Class : CONTENT_TYPE_SERIALIZED_OBJECT Field

Syntax

C#
public static readonly string CONTENT_TYPE_SERIALIZED_OBJECT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Class
ContentType Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CONTENT_TYPE_TEXT_PLAIN Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > ContentType Class : CONTENT_TYPE_TEXT_PLAIN Field

Syntax

C#
public static readonly string CONTENT_TYPE_TEXT_PLAIN

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContentType Class
ContentType Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DirectExchange Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : DirectExchange Class
Simple container collecting information to describe a direct exchange.

Syntax

C#
public class DirectExchange : AbstractExchange, IExchange

Remarks

Used in conjunction with administrative operations.

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.AbstractExchange
Spring.Messaging.Amqp.Core.DirectExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
DirectExchange Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : DirectExchange Class

The following tables list the members exposed by DirectExchange.

Public Constructors

 | Name | Description
Public Constructor | DirectExchange Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT |
Top

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

DirectExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DirectExchange Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > DirectExchange Class : DirectExchange Constructor

Overload List

Overload | Description
DirectExchange Constructor(String) |
DirectExchange Constructor(String,Boolean,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Class
DirectExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DirectExchange Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > DirectExchange Class > DirectExchange Constructor : DirectExchange Constructor(String)
name

Syntax

C#
public DirectExchange(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Class
DirectExchange Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DirectExchange Constructor(String,Boolean,Boolean)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > DirectExchange Class > DirectExchange Constructor : DirectExchange Constructor(String,Boolean,Boolean)
name
durable
autoDelete

Syntax

C#
public DirectExchange(
   string name,
   bool durable,
   bool autoDelete
)

Parameters

name
durable
autoDelete

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Class
DirectExchange Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
DirectExchange Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : DirectExchange Class

For a list of all members of this type, see DirectExchange members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

See Also

Reference

DirectExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > DirectExchange Class : ExchangeType Property

Syntax

C#
public override ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Class
DirectExchange Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
DirectExchange Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : DirectExchange Class

For a list of all members of this type, see DirectExchange members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT |
Top

See Also

Reference

DirectExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DEFAULT Field
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > DirectExchange Class : DEFAULT Field

Syntax

C#
public static readonly DirectExchange DEFAULT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DirectExchange Class
DirectExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FanoutExchange Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : FanoutExchange Class
Simple container collecting information to describe a fanout exchange.

Syntax

C#
public class FanoutExchange : AbstractExchange, IExchange

Remarks

Used in conjunction with administrative operations.

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.AbstractExchange
Spring.Messaging.Amqp.Core.FanoutExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FanoutExchange Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
FanoutExchange Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : FanoutExchange Class

The following tables list the members exposed by FanoutExchange.

Public Constructors

 | Name | Description
Public Constructor | FanoutExchange Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

FanoutExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FanoutExchange Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > FanoutExchange Class : FanoutExchange Constructor

Overload List

Overload | Description
FanoutExchange Constructor(String) |
FanoutExchange Constructor(String,Boolean,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FanoutExchange Class
FanoutExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FanoutExchange Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > FanoutExchange Class > FanoutExchange Constructor : FanoutExchange Constructor(String)
name

Syntax

C#
public FanoutExchange(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FanoutExchange Class
FanoutExchange Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FanoutExchange Constructor(String,Boolean,Boolean)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > FanoutExchange Class > FanoutExchange Constructor : FanoutExchange Constructor(String,Boolean,Boolean)
name
durable
autoDelete

Syntax

C#
public FanoutExchange(
   string name,
   bool durable,
   bool autoDelete
)

Parameters

name
durable
autoDelete

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FanoutExchange Class
FanoutExchange Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
FanoutExchange Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : FanoutExchange Class

For a list of all members of this type, see FanoutExchange members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

See Also

Reference

FanoutExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > FanoutExchange Class : ExchangeType Property

Syntax

C#
public override ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FanoutExchange Class
FanoutExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Message Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Message Class

Object Model

Syntax

C#
public class Message

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.Message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Message Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
Message Class Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Core Namespace : Message Class

The following tables list the members exposed by Message.

Public Constructors

 | Name | Description
Public Constructor | Message Constructor | Initializes a new instance of the Object class.
Top

Public Properties

 | Name | Description
Public Property | Body |
Public Property | MessageProperties |
Top

See Also

Reference

Message Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Message Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Message Class : Message Constructor
body
messageProperties
Initializes a new instance of the Object class.

Syntax

C#
public Message(
   byte[] body,
   IMessageProperties messageProperties
)

Parameters

body
messageProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Message Class
Message Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
Message Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Message Class

For a list of all members of this type, see Message members.

Public Properties

 | Name | Description
Public Property | Body |
Public Property | MessageProperties |
Top

See Also

Reference

Message Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Body Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Message Class : Body Property

Syntax

C#
public byte[] Body {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Message Class
Message Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageProperties Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Message Class : MessageProperties Property

Syntax

C#
public IMessageProperties MessageProperties {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Message Class
Message Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Queue Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Queue Class
Simple container collecting information to describe a queue.

Syntax

C#
public class Queue

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.Queue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
Queue Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : Queue Class

The following tables list the members exposed by Queue.

Public Constructors

 | Name | Description
Public Constructor | Queue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arguments |
Public Property | AutoDelete |
Public Property | Durable |
Public Property | Exclusive |
Public Property | Name |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Queue Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Queue Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : Queue Constructor
name

Syntax

C#
public Queue(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
Queue Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Queue Class

For a list of all members of this type, see Queue members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Queue Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToString Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
Queue Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : Queue Class

For a list of all members of this type, see Queue members.

Public Properties

 | Name | Description
Public Property | Arguments |
Public Property | AutoDelete |
Public Property | Durable |
Public Property | Exclusive |
Public Property | Name |
Top

See Also

Reference

Queue Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Arguments Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : Arguments Property

Syntax

C#
public IDictionary Arguments {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AutoDelete Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : AutoDelete Property

Syntax

C#
public bool AutoDelete {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Durable Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : Durable Property

Syntax

C#
public bool Durable {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Exclusive Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : Exclusive Property

Syntax

C#
public bool Exclusive {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Name Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > Queue Class : Name Property

Syntax

C#
public string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Queue Class
Queue Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TopicExchange Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : TopicExchange Class
Simple container collecting information to describe a topic exchange.

Syntax

C#
public class TopicExchange : AbstractExchange, IExchange

Remarks

Used in conjunction with administrative operations.

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.AbstractExchange
Spring.Messaging.Amqp.Core.TopicExchange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TopicExchange Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
TopicExchange Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : TopicExchange Class

The following tables list the members exposed by TopicExchange.

Public Constructors

 | Name | Description
Public Constructor | TopicExchange Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

TopicExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TopicExchange Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > TopicExchange Class : TopicExchange Constructor

Overload List

Overload | Description
TopicExchange Constructor(String) |
TopicExchange Constructor(String,Boolean,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TopicExchange Class
TopicExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TopicExchange Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > TopicExchange Class > TopicExchange Constructor : TopicExchange Constructor(String)
name

Syntax

C#
public TopicExchange(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TopicExchange Class
TopicExchange Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TopicExchange Constructor(String,Boolean,Boolean)
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > TopicExchange Class > TopicExchange Constructor : TopicExchange Constructor(String,Boolean,Boolean)
name
durable
autoDelete

Syntax

C#
public TopicExchange(
   string name,
   bool durable,
   bool autoDelete
)

Parameters

name
durable
autoDelete

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TopicExchange Class
TopicExchange Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
TopicExchange Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : TopicExchange Class

For a list of all members of this type, see TopicExchange members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets or sets the collection of arbitrary arguments to use when declaring an exchange. (Inherited from AbstractExchange)
Public Property | AutoDelete | Gets or sets a value indicating the auto-delete lifecycle of this exchange. (Inherited from AbstractExchange)
Public Property | Durable | Gets or sets a value indicating whether this AbstractExchange is durable. (Inherited from AbstractExchange)
Public Property | ExchangeType | Overridden.
Public Property | Name | (Inherited from AbstractExchange)
Top

See Also

Reference

TopicExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > TopicExchange Class : ExchangeType Property

Syntax

C#
public override ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TopicExchange Class
TopicExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Enumeration
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : ExchangeType Enumeration
Enumeration of exchange types.

Syntax

C#
public enum ExchangeType : Enum

Members

Member | Description
Fanout |
Direct |
Topic |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Spring.Messaging.Amqp.Core.ExchangeType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageDeliveryMode Enumeration
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : MessageDeliveryMode Enumeration
Enumeration for the Message Delivery Mode. The None value is set in case the properties of the message do not contain any delivery mode value.

Syntax

C#
public enum MessageDeliveryMode : Enum

Members

Member | Description
None |
NON_PERSISTENT |
PERSISTENT |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Spring.Messaging.Amqp.Core.MessageDeliveryMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IAmqpAdmin Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpAdmin Interface
Specifies a basic set of portable AMQP administrative operations for AMQP > 0.8

Syntax

C#
public interface IAmqpAdmin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IAmqpAdmin Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpAdmin Interface

The following tables list the members exposed by IAmqpAdmin.

Public Methods

 | Name | Description
Method | DeclareBinding |
Method | DeclareExchange | Declares the exchange.
Method | DeclareQueue | Declares the queue.
Method | DeleteExchange | Deletes the exchange.
Method | DeleteQueue | Overloaded.
Method | PurgeQueue | Purges the queue.
Top

See Also

Reference

IAmqpAdmin Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IAmqpAdmin Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpAdmin Interface

For a list of all members of this type, see IAmqpAdmin members.

Public Methods

 | Name | Description
Method | DeclareBinding |
Method | DeclareExchange | Declares the exchange.
Method | DeclareQueue | Declares the queue.
Method | DeleteExchange | Deletes the exchange.
Method | DeleteQueue | Overloaded.
Method | PurgeQueue | Purges the queue.
Top

See Also

Reference

IAmqpAdmin Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeclareBinding Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : DeclareBinding Method
binding

Syntax

C#
void DeclareBinding(
   Binding binding
)

Parameters

binding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeclareExchange Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : DeclareExchange Method
exchange
The exchange.
Declares the exchange.

Syntax

C#
void DeclareExchange(
   IExchange exchange
)

Parameters

exchange
The exchange.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeclareQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : DeclareQueue Method
queue
The queue.
Declares the queue.

Syntax

C#
void DeclareQueue(
   Queue queue
)

Parameters

queue
The queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeleteExchange Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : DeleteExchange Method
exchangeName
Name of the exchange.
Deletes the exchange.

Syntax

C#
void DeleteExchange(
   string exchangeName
)

Parameters

exchangeName
Name of the exchange.

Remarks

Look at implementation specific subclass for implementation specific behavior, for example for RabbitMQ this will delete the exchange without regard for whether it is in use or not.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeleteQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : DeleteQueue Method

Overload List

Overload | Description
DeleteQueue(String) | Deletes the queue, without regard for whether it is in use or has messages on it
DeleteQueue(String,Boolean,Boolean) | Deletes the queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeleteQueue(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface > DeleteQueue Method : DeleteQueue(String) Method
queueName
Name of the queue.
Deletes the queue, without regard for whether it is in use or has messages on it

Syntax

C#
void DeleteQueue(
   string queueName
)

Parameters

queueName
Name of the queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeleteQueue(String,Boolean,Boolean) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface > DeleteQueue Method : DeleteQueue(String,Boolean,Boolean) Method
queueName
Name of the queue.
unused
if set to true the queue should be deleted only if not in use.
empty
if set to true the queue should be deleted only if empty.
Deletes the queue.

Syntax

C#
void DeleteQueue(
   string queueName,
   bool unused,
   bool empty
)

Parameters

queueName
Name of the queue.
unused
if set to true the queue should be deleted only if not in use.
empty
if set to true the queue should be deleted only if empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
PurgeQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpAdmin Interface : PurgeQueue Method
queueName
Name of the queue.
noWait
if set to true [no wait].
Purges the queue.

Syntax

C#
void PurgeQueue(
   string queueName,
   bool noWait
)

Parameters

queueName
Name of the queue.
noWait
if set to true [no wait].

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpAdmin Interface
IAmqpAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IAmqpTemplate Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpTemplate Interface
Specifies a basic set of AMQP operations

Syntax

C#
public interface IAmqpTemplate

Remarks

Provides synchronous send an receive methods. The ConvertAndSend and ReceiveAndConvert methods allow let you send and receive POCO objects. Implementations are expected to delegate to an instance of Spring.Messaging.Amqp.Support.Converter.IMessageConverter to perform conversion to and from AMQP byte[] payload type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IAmqpTemplate Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpTemplate Interface

The following tables list the members exposed by IAmqpTemplate.

Public Methods

 | Name | Description
Method | ConvertAndSend | Overloaded.
Method | CreateMessageProperties |
Method | Receive | Overloaded.
Method | ReceiveAndConvert | Overloaded.
Top

See Also

Reference

IAmqpTemplate Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IAmqpTemplate Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IAmqpTemplate Interface

For a list of all members of this type, see IAmqpTemplate members.

Public Methods

 | Name | Description
Method | ConvertAndSend | Overloaded.
Method | CreateMessageProperties |
Method | Receive | Overloaded.
Method | ReceiveAndConvert | Overloaded.
Top

See Also

Reference

IAmqpTemplate Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface : ConvertAndSend Method

Overload List

Overload | Description
ConvertAndSend(Object) |
ConvertAndSend(String,Object) |
ConvertAndSend(String,String,Object) |
ConvertAndSend(Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(Object) Method
message

Syntax

C#
void ConvertAndSend(
   object message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(String,Object) Method
routingKey
message

Syntax

C#
void ConvertAndSend(
   string routingKey,
   object message
)

Parameters

routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(String,String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(String,String,Object) Method
exchange
routingKey
message

Syntax

C#
void ConvertAndSend(
   string exchange,
   string routingKey,
   object message
)

Parameters

exchange
routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(Object,MessagePostProcessorDelegate) Method
message
messagePostProcessorDelegate

Syntax

C#
void ConvertAndSend(
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
routingKey
message
messagePostProcessorDelegate

Syntax

C#
void ConvertAndSend(
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ConvertAndSend Method : ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
exchange
routingKey
message
messagePostProcessorDelegate

Syntax

C#
void ConvertAndSend(
   string exchange,
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

exchange
routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CreateMessageProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface : CreateMessageProperties Method

Syntax

C#
IMessageProperties CreateMessageProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Receive Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface : Receive Method

Overload List

Overload | Description
Receive() |
Receive(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Receive() Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > Receive Method : Receive() Method

Syntax

C#
Message Receive()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Receive(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > Receive Method : Receive(String) Method
queueName

Syntax

C#
Message Receive(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReceiveAndConvert Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface : ReceiveAndConvert Method

Overload List

Overload | Description
ReceiveAndConvert() |
ReceiveAndConvert(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReceiveAndConvert() Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ReceiveAndConvert Method : ReceiveAndConvert() Method

Syntax

C#
object ReceiveAndConvert()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReceiveAndConvert(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IAmqpTemplate Interface > ReceiveAndConvert Method : ReceiveAndConvert(String) Method
queueName

Syntax

C#
object ReceiveAndConvert(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAmqpTemplate Interface
IAmqpTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IExchange Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IExchange Interface
Common properties that describe all exchange types.

Syntax

C#
public interface IExchange

Remarks

Implementations of this interface are typically used with administrative operations that declare an exchange.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IExchange Interface Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Core Namespace : IExchange Interface

The following tables list the members exposed by IExchange.

Public Properties

 | Name | Description
Property | Arguments |
Property | AutoDelete |
Property | Durable |
Property | ExchangeType |
Property | Name |
Top

See Also

Reference

IExchange Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
IExchange Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IExchange Interface

For a list of all members of this type, see IExchange members.

Public Properties

 | Name | Description
Property | Arguments |
Property | AutoDelete |
Property | Durable |
Property | ExchangeType |
Property | Name |
Top

See Also

Reference

IExchange Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Arguments Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IExchange Interface : Arguments Property

Syntax

C#
IDictionary Arguments {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Interface
IExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AutoDelete Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IExchange Interface : AutoDelete Property

Syntax

C#
bool AutoDelete {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Interface
IExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Durable Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IExchange Interface : Durable Property

Syntax

C#
bool Durable {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Interface
IExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ExchangeType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IExchange Interface : ExchangeType Property

Syntax

C#
ExchangeType ExchangeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Interface
IExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Name Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IExchange Interface : Name Property

Syntax

C#
string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IExchange Interface
IExchange Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IMessageCreator Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageCreator Interface

Syntax

C#
public interface IMessageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageCreator Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IMessageCreator Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageCreator Interface

The following tables list the members exposed by IMessageCreator.

Public Methods

 | Name | Description
Method | CreateMessage |
Top

See Also

Reference

IMessageCreator Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IMessageCreator Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageCreator Interface

For a list of all members of this type, see IMessageCreator members.

Public Methods

 | Name | Description
Method | CreateMessage |
Top

See Also

Reference

IMessageCreator Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CreateMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageCreator Interface : CreateMessage Method

Syntax

C#
Message CreateMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageCreator Interface
IMessageCreator Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IMessageListener Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageListener Interface

Syntax

C#
public interface IMessageListener

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageListener Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IMessageListener Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageListener Interface

The following tables list the members exposed by IMessageListener.

Public Methods

 | Name | Description
Method | OnMessage |
Top

See Also

Reference

IMessageListener Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IMessageListener Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageListener Interface

For a list of all members of this type, see IMessageListener members.

Public Methods

 | Name | Description
Method | OnMessage |
Top

See Also

Reference

IMessageListener Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
OnMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageListener Interface : OnMessage Method
message

Syntax

C#
void OnMessage(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageListener Interface
IMessageListener Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IMessageProperties Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageProperties Interface

Syntax

C#
public interface IMessageProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IMessageProperties Interface Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageProperties Interface

The following tables list the members exposed by IMessageProperties.

Public Properties

 | Name | Description
Property | AppId |
Property | ClusterId |
Property | ContentEncoding |
Property | ContentLength |
Property | ContentType |
Property | CorrelationId |
Property | DeliveryMode |
Property | DeliveryTag |
Property | Expiration |
Property | Headers |
Property | MessageCount |
Property | MessageId |
Property | Priority |
Property | ReceivedExchange |
Property | ReceivedRoutingKey |
Property | Redelivered |
Property | ReplyTo |
Property | Timestamp |
Property | Type |
Property | UserId |
Top

See Also

Reference

IMessageProperties Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
IMessageProperties Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessageProperties Interface

For a list of all members of this type, see IMessageProperties members.

Public Properties

 | Name | Description
Property | AppId |
Property | ClusterId |
Property | ContentEncoding |
Property | ContentLength |
Property | ContentType |
Property | CorrelationId |
Property | DeliveryMode |
Property | DeliveryTag |
Property | Expiration |
Property | Headers |
Property | MessageCount |
Property | MessageId |
Property | Priority |
Property | ReceivedExchange |
Property | ReceivedRoutingKey |
Property | Redelivered |
Property | ReplyTo |
Property | Timestamp |
Property | Type |
Property | UserId |
Top

See Also

Reference

IMessageProperties Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AppId Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : AppId Property

Syntax

C#
string AppId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ClusterId Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ClusterId Property

Syntax

C#
string ClusterId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ContentEncoding Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ContentEncoding Property

Syntax

C#
string ContentEncoding {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ContentLength Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ContentLength Property

Syntax

C#
long ContentLength {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ContentType Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ContentType Property

Syntax

C#
string ContentType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
CorrelationId Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : CorrelationId Property

Syntax

C#
byte[] CorrelationId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeliveryMode Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : DeliveryMode Property

Syntax

C#
MessageDeliveryMode DeliveryMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DeliveryTag Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : DeliveryTag Property

Syntax

C#
ulong DeliveryTag {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Expiration Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Expiration Property

Syntax

C#
string Expiration {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Headers Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Headers Property

Syntax

C#
IDictionary<string, object> Headers {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageCount Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : MessageCount Property

Syntax

C#
uint MessageCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageId Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : MessageId Property

Syntax

C#
string MessageId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Priority Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Priority Property

Syntax

C#
int Priority {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReceivedExchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ReceivedExchange Property

Syntax

C#
string ReceivedExchange {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReceivedRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ReceivedRoutingKey Property

Syntax

C#
string ReceivedRoutingKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Redelivered Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Redelivered Property

Syntax

C#
bool Redelivered {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ReplyTo Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : ReplyTo Property

Syntax

C#
string ReplyTo {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Timestamp Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Timestamp Property

Syntax

C#
long Timestamp {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Type Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : Type Property

Syntax

C#
string Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
UserId Property
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessageProperties Interface : UserId Property

Syntax

C#
string UserId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageProperties Interface
IMessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IMessagePropertiesFactory Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessagePropertiesFactory Interface
Factory interface for creating instances of IMesssageProperties.

Syntax

C#
public interface IMessagePropertiesFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessagePropertiesFactory Members
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IMessagePropertiesFactory Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessagePropertiesFactory Interface

The following tables list the members exposed by IMessagePropertiesFactory.

Public Methods

 | Name | Description
Method | Create |
Top

See Also

Reference

IMessagePropertiesFactory Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IMessagePropertiesFactory Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : IMessagePropertiesFactory Interface

For a list of all members of this type, see IMessagePropertiesFactory members.

Public Methods

 | Name | Description
Method | Create |
Top

See Also

Reference

IMessagePropertiesFactory Interface
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
Create Method
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace > IMessagePropertiesFactory Interface : Create Method

Syntax

C#
IMessageProperties Create()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessagePropertiesFactory Interface
IMessagePropertiesFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessagePostProcessorDelegate Delegate
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : MessagePostProcessorDelegate Delegate
message

Syntax

C#
public delegate Message MessagePostProcessorDelegate(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Core Namespace


%%ItemTitle%%

Spring.Messaging.Amqp
Spring.Messaging.Amqp.Support.Converter Namespace
See Also Inheritance Hierarchy Send Feedback
Provide a MessageConverter abstraction to convert between .NET objects and AMQP payloads.

Classes

 | Class | Description
Class | JsonMessageConverter |
Class | MessageConversionException |
Class | SimpleMessageConverter | Supports converting String and byte[] object types.
Class | TypeMapper |

Interfaces

 | Interface | Description
Interface | IMessageConverter | Convert from
Interface | ITypeMapper | Provides a layer of indirection when adding the 'type' of the object as a message property.

See Also

Reference

Spring.Messaging.Amqp Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
JsonMessageConverter Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : JsonMessageConverter Class

Syntax

C#
public class JsonMessageConverter : IMessageConverter

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Support.Converter.JsonMessageConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
JsonMessageConverter Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : JsonMessageConverter Class

The following tables list the members exposed by JsonMessageConverter.

Public Constructors

 | Name | Description
Public Constructor | JsonMessageConverter Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_CHARSET |
Top

Public Properties

 | Name | Description
Public Property | TypeMapper |
Top

Public Methods

 | Name | Description
Public Method | FromMessage |
Public Method | ToMessage |
Top

See Also

Reference

JsonMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
JsonMessageConverter Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > JsonMessageConverter Class : JsonMessageConverter Constructor

Syntax

C#
public JsonMessageConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Class
JsonMessageConverter Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
JsonMessageConverter Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : JsonMessageConverter Class

For a list of all members of this type, see JsonMessageConverter members.

Public Methods

 | Name | Description
Public Method | FromMessage |
Public Method | ToMessage |
Top

See Also

Reference

JsonMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FromMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > JsonMessageConverter Class : FromMessage Method
message

Syntax

C#
public object FromMessage(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Class
JsonMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > JsonMessageConverter Class : ToMessage Method
obj
messagePropertiesFactory

Syntax

C#
public Message ToMessage(
   object obj,
   IMessagePropertiesFactory messagePropertiesFactory
)

Parameters

obj
messagePropertiesFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Class
JsonMessageConverter Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
JsonMessageConverter Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : JsonMessageConverter Class

For a list of all members of this type, see JsonMessageConverter members.

Public Properties

 | Name | Description
Public Property | TypeMapper |
Top

See Also

Reference

JsonMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TypeMapper Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > JsonMessageConverter Class : TypeMapper Property

Syntax

C#
public ITypeMapper TypeMapper {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Class
JsonMessageConverter Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
JsonMessageConverter Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : JsonMessageConverter Class

For a list of all members of this type, see JsonMessageConverter members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_CHARSET |
Top

See Also

Reference

JsonMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DEFAULT_CHARSET Field
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > JsonMessageConverter Class : DEFAULT_CHARSET Field

Syntax

C#
public static readonly string DEFAULT_CHARSET

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

JsonMessageConverter Class
JsonMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageConversionException Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : MessageConversionException Class

Syntax

C#
public class MessageConversionException : Exception

Inheritance Hierarchy

System.Object
System.Exception
Spring.Messaging.Amqp.Support.Converter.MessageConversionException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageConversionException Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
MessageConversionException Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : MessageConversionException Class

The following tables list the members exposed by MessageConversionException.

Public Constructors

 | Name | Description
Public Constructor | MessageConversionException Constructor | Overloaded. Creates a new instance of the IMessageConverterException class. with the specified message.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

MessageConversionException Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageConversionException Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > MessageConversionException Class : MessageConversionException Constructor
Creates a new instance of the IMessageConverterException class. with the specified message.

Overload List

Overload | Description
MessageConversionException Constructor(String) | Creates a new instance of the IMessageConverterException class. with the specified message.
MessageConversionException Constructor(String,Exception) | Creates a new instance of the IMessageConverterException class with the specified message and root cause.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageConversionException Class
MessageConversionException Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageConversionException Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > MessageConversionException Class > MessageConversionException Constructor : MessageConversionException Constructor(String)
message
A message about the exception.
Creates a new instance of the IMessageConverterException class. with the specified message.

Syntax

C#
public MessageConversionException(
   string message
)

Parameters

message
A message about the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageConversionException Class
MessageConversionException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
MessageConversionException Constructor(String,Exception)
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > MessageConversionException Class > MessageConversionException Constructor : MessageConversionException Constructor(String,Exception)
message
A message about the exception.
rootCause
The root exception that is being wrapped.
Creates a new instance of the IMessageConverterException class with the specified message and root cause.

Syntax

C#
public MessageConversionException(
   string message,
   Exception rootCause
)

Parameters

message
A message about the exception.
rootCause
The root exception that is being wrapped.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageConversionException Class
MessageConversionException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
SimpleMessageConverter Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : SimpleMessageConverter Class
Supports converting String and byte[] object types.

Syntax

C#
public class SimpleMessageConverter : IMessageConverter

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Support.Converter.SimpleMessageConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageConverter Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
SimpleMessageConverter Class Members
See Also Fields Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : SimpleMessageConverter Class

The following tables list the members exposed by SimpleMessageConverter.

Public Constructors

 | Name | Description
Public Constructor | SimpleMessageConverter Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_CHARSET |
Top

Public Methods

 | Name | Description
Public Method | FromMessage |
Public Method | ToMessage |
Top

See Also

Reference

SimpleMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
SimpleMessageConverter Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > SimpleMessageConverter Class : SimpleMessageConverter Constructor

Syntax

C#
public SimpleMessageConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageConverter Class
SimpleMessageConverter Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
SimpleMessageConverter Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : SimpleMessageConverter Class

For a list of all members of this type, see SimpleMessageConverter members.

Public Methods

 | Name | Description
Public Method | FromMessage |
Public Method | ToMessage |
Top

See Also

Reference

SimpleMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FromMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > SimpleMessageConverter Class : FromMessage Method
message

Syntax

C#
public object FromMessage(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageConverter Class
SimpleMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > SimpleMessageConverter Class : ToMessage Method
obj
messagePropertiesFactory

Syntax

C#
public Message ToMessage(
   object obj,
   IMessagePropertiesFactory messagePropertiesFactory
)

Parameters

obj
messagePropertiesFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageConverter Class
SimpleMessageConverter Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
SimpleMessageConverter Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : SimpleMessageConverter Class

For a list of all members of this type, see SimpleMessageConverter members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_CHARSET |
Top

See Also

Reference

SimpleMessageConverter Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DEFAULT_CHARSET Field
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > SimpleMessageConverter Class : DEFAULT_CHARSET Field

Syntax

C#
public static readonly string DEFAULT_CHARSET

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageConverter Class
SimpleMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TypeMapper Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : TypeMapper Class

Syntax

C#
public class TypeMapper : ITypeMapper

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Support.Converter.TypeMapper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
TypeMapper Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : TypeMapper Class

The following tables list the members exposed by TypeMapper.

Public Constructors

 | Name | Description
Public Constructor | TypeMapper Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_TYPEID_FIELD_NAME |
Top

Public Properties

 | Name | Description
Public Property | DefaultAssemblyName |
Public Property | DefaultHashtableClass |
Public Property | DefaultNamespace |
Public Property | IdTypeMapping |
Public Property | TypeIdFieldName |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | FromType |
Public Method | ToType |
Top

See Also

Reference

TypeMapper Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TypeMapper Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : TypeMapper Constructor

Syntax

C#
public TypeMapper()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
TypeMapper Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : TypeMapper Class

For a list of all members of this type, see TypeMapper members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | FromType |
Public Method | ToType |
Top

See Also

Reference

TypeMapper Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : AfterPropertiesSet Method

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FromType Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : FromType Method
typeOfObjectToConvert

Syntax

C#
public string FromType(
   Type typeOfObjectToConvert
)

Parameters

typeOfObjectToConvert

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToType Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : ToType Method
typeId

Syntax

C#
public Type ToType(
   string typeId
)

Parameters

typeId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
TypeMapper Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : TypeMapper Class

For a list of all members of this type, see TypeMapper members.

Public Properties

 | Name | Description
Public Property | DefaultAssemblyName |
Public Property | DefaultHashtableClass |
Public Property | DefaultNamespace |
Public Property | IdTypeMapping |
Public Property | TypeIdFieldName |
Top

See Also

Reference

TypeMapper Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DefaultAssemblyName Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : DefaultAssemblyName Property

Syntax

C#
public string DefaultAssemblyName {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DefaultHashtableClass Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : DefaultHashtableClass Property

Syntax

C#
public Type DefaultHashtableClass {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DefaultNamespace Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : DefaultNamespace Property

Syntax

C#
public string DefaultNamespace {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IdTypeMapping Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : IdTypeMapping Property

Syntax

C#
public IDictionary IdTypeMapping {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TypeIdFieldName Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : TypeIdFieldName Property

Syntax

C#
public string TypeIdFieldName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
TypeMapper Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : TypeMapper Class

For a list of all members of this type, see TypeMapper members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_TYPEID_FIELD_NAME |
Top

See Also

Reference

TypeMapper Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
DEFAULT_TYPEID_FIELD_NAME Field
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > TypeMapper Class : DEFAULT_TYPEID_FIELD_NAME Field

Syntax

C#
public static readonly string DEFAULT_TYPEID_FIELD_NAME

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeMapper Class
TypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
IMessageConverter Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : IMessageConverter Interface
Convert from

Syntax

C#
public interface IMessageConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageConverter Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
IMessageConverter Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : IMessageConverter Interface

The following tables list the members exposed by IMessageConverter.

Public Methods

 | Name | Description
Method | FromMessage |
Method | ToMessage |
Top

See Also

Reference

IMessageConverter Interface
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
IMessageConverter Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : IMessageConverter Interface

For a list of all members of this type, see IMessageConverter members.

Public Methods

 | Name | Description
Method | FromMessage |
Method | ToMessage |
Top

See Also

Reference

IMessageConverter Interface
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FromMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > IMessageConverter Interface : FromMessage Method
message

Syntax

C#
object FromMessage(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageConverter Interface
IMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > IMessageConverter Interface : ToMessage Method
obj
messagePropertiesFactory

Syntax

C#
Message ToMessage(
   object obj,
   IMessagePropertiesFactory messagePropertiesFactory
)

Parameters

obj
messagePropertiesFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMessageConverter Interface
IMessageConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ITypeMapper Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : ITypeMapper Interface
Provides a layer of indirection when adding the 'type' of the object as a message property.

Syntax

C#
public interface ITypeMapper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITypeMapper Members
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp
ITypeMapper Interface Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : ITypeMapper Interface

The following tables list the members exposed by ITypeMapper.

Public Properties

 | Name | Description
Property | TypeIdFieldName |
Top

Public Methods

 | Name | Description
Method | FromType |
Method | ToType |
Top

See Also

Reference

ITypeMapper Interface
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
ITypeMapper Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : ITypeMapper Interface

For a list of all members of this type, see ITypeMapper members.

Public Methods

 | Name | Description
Method | FromType |
Method | ToType |
Top

See Also

Reference

ITypeMapper Interface
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
FromType Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > ITypeMapper Interface : FromType Method
typeOfObjectToConvert

Syntax

C#
string FromType(
   Type typeOfObjectToConvert
)

Parameters

typeOfObjectToConvert

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITypeMapper Interface
ITypeMapper Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
ToType Method
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > ITypeMapper Interface : ToType Method
typeId

Syntax

C#
Type ToType(
   string typeId
)

Parameters

typeId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITypeMapper Interface
ITypeMapper Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
ITypeMapper Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : ITypeMapper Interface

For a list of all members of this type, see ITypeMapper members.

Public Properties

 | Name | Description
Property | TypeIdFieldName |
Top

See Also

Reference

ITypeMapper Interface
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp
TypeIdFieldName Property
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace > ITypeMapper Interface : TypeIdFieldName Property

Syntax

C#
string TypeIdFieldName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITypeMapper Interface
ITypeMapper Members


$$INTRODUCTION$$ - %%projecttitle%%

Spring.Messaging.Amqp.Qpid-0-8-0.6
Introduction
Send Feedback


%%phrase%%

Spring.Messaging.Amqp.Qpid-0-8-0.6
Spring.Messaging.Amqp.Qpid-0-8-0.6 Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Spring.Messaging.Amqp.Qpid.Core |


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Messaging.Amqp.Qpid-0-8-0.6
Getting Started
Send Feedback


%%ItemTitle%%

Spring.Messaging.Amqp.Qpid-0-8-0.6
Spring.Messaging.Amqp.Qpid.Core Namespace (Spring.Messaging.Amqp.Qpid-0-8-0.6)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | HeadersDictionary |
Class | MessageProperties |

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-8-0.6 Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
HeadersDictionary Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : HeadersDictionary Class

Syntax

C#
[DefaultMemberAttribute("Item")]
public class HeadersDictionary : IHeaders

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.HeadersDictionary

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
HeadersDictionary Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : HeadersDictionary Class

The following tables list the members exposed by HeadersDictionary.

Public Constructors

 | Name | Description
Public Constructor | HeadersDictionary Constructor | Initializes a new instance of the Object class.
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Headers |
Public Property | IsReadOnly |
Public Property | Item |
Public Property | Keys |
Public Property | Values |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | Overloaded.
Public Method | ContainsKey |
Public Method | CopyTo |
Public Method | GetBoolean |
Public Method | GetByte |
Public Method | GetDouble |
Public Method | GetEnumerator |
Public Method | GetFloat |
Public Method | GetInt |
Public Method | GetLong |
Public Method | GetShort |
Public Method | GetString |
Public Method | Remove | Overloaded.
Public Method | SetBoolean |
Public Method | SetByte |
Public Method | SetDouble |
Public Method | SetFloat |
Public Method | SetInt |
Public Method | SetLong |
Public Method | SetShort |
Public Method | SetString |
Public Method | TryGetValue |
Top

See Also

Reference

HeadersDictionary Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
HeadersDictionary Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : HeadersDictionary Constructor
headers
Initializes a new instance of the Object class.

Syntax

C#
public HeadersDictionary(
   IHeaders headers
)

Parameters

headers

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
HeadersDictionary Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : HeadersDictionary Class

For a list of all members of this type, see HeadersDictionary members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | Overloaded.
Public Method | ContainsKey |
Public Method | CopyTo |
Public Method | GetBoolean |
Public Method | GetByte |
Public Method | GetDouble |
Public Method | GetEnumerator |
Public Method | GetFloat |
Public Method | GetInt |
Public Method | GetLong |
Public Method | GetShort |
Public Method | GetString |
Public Method | Remove | Overloaded.
Public Method | SetBoolean |
Public Method | SetByte |
Public Method | SetDouble |
Public Method | SetFloat |
Public Method | SetInt |
Public Method | SetLong |
Public Method | SetShort |
Public Method | SetString |
Public Method | TryGetValue |
Top

See Also

Reference

HeadersDictionary Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Add Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Add Method

Overload List

Overload | Description
Add(Generic KeyValuePair) |
Add(String,Object) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Add(Generic KeyValuePair) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Add Method : Add(Generic KeyValuePair) Method
item

Syntax

C#
public void Add(
   KeyValuePair<string, object> item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Add(String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Add Method : Add(String,Object) Method
key
value

Syntax

C#
public void Add(
   string key,
   object value
)

Parameters

key
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Clear Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Clear Method

Syntax

C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Contains Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Contains Method

Overload List

Overload | Description
Contains(Generic KeyValuePair) |
Contains(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Contains(Generic KeyValuePair) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Contains Method : Contains(Generic KeyValuePair) Method
item

Syntax

C#
public bool Contains(
   KeyValuePair<string, object> item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Contains(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Contains Method : Contains(String) Method
name

Syntax

C#
public bool Contains(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ContainsKey Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : ContainsKey Method
key

Syntax

C#
public bool ContainsKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CopyTo Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : CopyTo Method
array
arrayIndex

Syntax

C#
public void CopyTo(
   KeyValuePair[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetBoolean Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetBoolean Method
name

Syntax

C#
public bool GetBoolean(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetByte Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetByte Method
name

Syntax

C#
public byte GetByte(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetDouble Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetDouble Method
name

Syntax

C#
public double GetDouble(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetEnumerator Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetEnumerator Method

Syntax

C#
public IEnumerator<KeyValuePair<string, object>> GetEnumerator()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetFloat Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetFloat Method
name

Syntax

C#
public float GetFloat(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetInt Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetInt Method
name

Syntax

C#
public int GetInt(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetLong Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetLong Method
name

Syntax

C#
public long GetLong(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetShort Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetShort Method
name

Syntax

C#
public short GetShort(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
GetString Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : GetString Method
name

Syntax

C#
public string GetString(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Remove Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Remove Method

Overload List

Overload | Description
Remove(Generic KeyValuePair) |
Remove(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Remove(Generic KeyValuePair) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Remove Method : Remove(Generic KeyValuePair) Method
item

Syntax

C#
public bool Remove(
   KeyValuePair<string, object> item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Remove(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class > Remove Method : Remove(String) Method
key

Syntax

C#
public bool Remove(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetBoolean Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetBoolean Method
name
value

Syntax

C#
public void SetBoolean(
   string name,
   bool value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetByte Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetByte Method
name
value

Syntax

C#
public void SetByte(
   string name,
   byte value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetDouble Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetDouble Method
name
value

Syntax

C#
public void SetDouble(
   string name,
   double value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetFloat Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetFloat Method
name
value

Syntax

C#
public void SetFloat(
   string name,
   float value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetInt Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetInt Method
name
value

Syntax

C#
public void SetInt(
   string name,
   int value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetLong Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetLong Method
name
value

Syntax

C#
public void SetLong(
   string name,
   long value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetShort Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetShort Method
name
value

Syntax

C#
public void SetShort(
   string name,
   short value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
SetString Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : SetString Method
name
value

Syntax

C#
public void SetString(
   string name,
   string value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
TryGetValue Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : TryGetValue Method
key
value

Syntax

C#
public bool TryGetValue(
   string key,
   out object value
)

Parameters

key
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
HeadersDictionary Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : HeadersDictionary Class

For a list of all members of this type, see HeadersDictionary members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Headers |
Public Property | IsReadOnly |
Public Property | Item |
Public Property | Keys |
Public Property | Values |
Top

See Also

Reference

HeadersDictionary Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Count Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Count Property

Syntax

C#
public int Count {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Headers Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Headers Property

Syntax

C#
public IHeaders Headers {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
IsReadOnly Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : IsReadOnly Property

Syntax

C#
public bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Item Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Item Property
key

Syntax

C#
public object this[
   string key
]; {get; set;}

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Keys Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Keys Property

Syntax

C#
public ICollection<string> Keys {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Values Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > HeadersDictionary Class : Values Property

Syntax

C#
public ICollection<object> Values {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeadersDictionary Class
HeadersDictionary Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageProperties Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

Syntax

C#
public class MessageProperties : IMessageProperties

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.MessageProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageProperties Class Members
See Also Fields Properties Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

The following tables list the members exposed by MessageProperties.

Public Constructors

 | Name | Description
Public Constructor | MessageProperties Constructor | Initializes a new instance of the Object class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | Priority | Gets or sets the priority.
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageProperties Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageProperties Constructor
Initializes a new instance of the Object class.

Syntax

C#
public MessageProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageProperties Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | Priority | Gets or sets the priority.
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
AppId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : AppId Property

Syntax

C#
public string AppId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ClusterId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ClusterId Property

Syntax

C#
public string ClusterId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ContentEncoding Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentEncoding Property

Syntax

C#
public string ContentEncoding {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ContentLength Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentLength Property

Syntax

C#
public long ContentLength {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ContentType Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentType Property

Syntax

C#
public string ContentType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CorrelationId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CorrelationId Property

Syntax

C#
public byte[] CorrelationId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
DeliveryMode Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : DeliveryMode Property

Syntax

C#
public MessageDeliveryMode DeliveryMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
DeliveryTag Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : DeliveryTag Property

Syntax

C#
public ulong DeliveryTag {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Expiration Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Expiration Property

Syntax

C#
public string Expiration {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Headers Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Headers Property

Syntax

C#
public IDictionary<string, object> Headers {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageCount Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageCount Property

Syntax

C#
public uint MessageCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageId Property

Syntax

C#
public string MessageId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Priority Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Priority Property
Gets or sets the priority.

Syntax

C#
public int Priority {get; set;}

Return Value

The priority.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ReceivedExchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReceivedExchange Property

Syntax

C#
public string ReceivedExchange {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ReceivedRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReceivedRoutingKey Property

Syntax

C#
public string ReceivedRoutingKey {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Redelivered Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Redelivered Property

Syntax

C#
public bool Redelivered {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
ReplyTo Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReplyTo Property

Syntax

C#
public string ReplyTo {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Timestamp Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Timestamp Property

Syntax

C#
public long Timestamp {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
Type Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Type Property

Syntax

C#
public string Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
UserId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : UserId Property

Syntax

C#
public string UserId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
MessageProperties Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CONTENT_TYPE_BYTES Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_BYTES Field

Syntax

C#
public static readonly string CONTENT_TYPE_BYTES

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CONTENT_TYPE_JSON Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_JSON Field

Syntax

C#
public static readonly string CONTENT_TYPE_JSON

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CONTENT_TYPE_SERIALIZED_OBJECT Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_SERIALIZED_OBJECT Field

Syntax

C#
public static readonly string CONTENT_TYPE_SERIALIZED_OBJECT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-8-0.6
CONTENT_TYPE_TEXT_PLAIN Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_TEXT_PLAIN Field

Syntax

C#
public static readonly string CONTENT_TYPE_TEXT_PLAIN

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


$$INTRODUCTION$$ - %%projecttitle%%

Spring.Messaging.Amqp.Qpid-0-10-06
Introduction
Send Feedback


%%phrase%%

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid-0-10-06 Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Spring.Messaging.Amqp.Qpid.Client |
Spring.Messaging.Amqp.Qpid.Core |
Spring.Messaging.Amqp.Qpid.Support |


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Messaging.Amqp.Qpid-0-10-06
Getting Started
Send Feedback


%%ItemTitle%%

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Client Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ClientFactoryUtils |
Class | QpidResourceHolder |
Class | SimpleClientFactory |

Interfaces

 | Interface | Description
Interface | IResourceFactory |

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClientFactoryUtils Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : ClientFactoryUtils Class

Syntax

C#
public class ClientFactoryUtils

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Client.ClientFactoryUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Members
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClientFactoryUtils Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : ClientFactoryUtils Class

The following tables list the members exposed by ClientFactoryUtils.

Public Constructors

 | Name | Description
Public Constructor | ClientFactoryUtils Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoGetTransactionalSession |
static (Shared in Visual Basic) | GetTransactionalSession |
static (Shared in Visual Basic) | IsChannelTransactional |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ClientFactoryUtils Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClientFactoryUtils Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > ClientFactoryUtils Class : ClientFactoryUtils Constructor

Syntax

C#
public ClientFactoryUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Class
ClientFactoryUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClientFactoryUtils Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : ClientFactoryUtils Class

For a list of all members of this type, see ClientFactoryUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoGetTransactionalSession |
static (Shared in Visual Basic) | GetTransactionalSession |
static (Shared in Visual Basic) | IsChannelTransactional |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ClientFactoryUtils Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DoGetTransactionalSession Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > ClientFactoryUtils Class : DoGetTransactionalSession Method
clientFactory
resourceFactory

Syntax

C#
public static IClientSession DoGetTransactionalSession(
   IClientFactory clientFactory,
   IResourceFactory resourceFactory
)

Parameters

clientFactory
resourceFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Class
ClientFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
GetTransactionalSession Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > ClientFactoryUtils Class : GetTransactionalSession Method
cf
existingCon
synchedLocalTransactionAllowed

Syntax

C#
public static IClientSession GetTransactionalSession(
   IClientFactory cf,
   IClient existingCon,
   bool synchedLocalTransactionAllowed
)

Parameters

cf
existingCon
synchedLocalTransactionAllowed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Class
ClientFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IsChannelTransactional Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > ClientFactoryUtils Class : IsChannelTransactional Method
session
clientFactory

Syntax

C#
public static bool IsChannelTransactional(
   IClientSession session,
   IClientFactory clientFactory
)

Parameters

session
clientFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Class
ClientFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReleaseConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > ClientFactoryUtils Class : ReleaseConnection Method
client
clientFactory

Syntax

C#
public static void ReleaseConnection(
   IClient client,
   IClientFactory clientFactory
)

Parameters

client
clientFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientFactoryUtils Class
ClientFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : QpidResourceHolder Class

Syntax

C#
public class QpidResourceHolder : ResourceHolderSupport

Inheritance Hierarchy

System.Object
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Qpid.Client.QpidResourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Members
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : QpidResourceHolder Class

The following tables list the members exposed by QpidResourceHolder.

Public Constructors

 | Name | Description
Public Constructor | QpidResourceHolder Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Channel |
Public Property | Connection |
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen |
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded.
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll |
Public Method | CommitAll |
Public Method | ContainsChannel |
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

QpidResourceHolder Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : QpidResourceHolder Constructor

Overload List

Overload | Description
QpidResourceHolder Constructor() |
QpidResourceHolder Constructor(IClient,IClientSession) |
QpidResourceHolder Constructor(IClientFactory) |
QpidResourceHolder Constructor(IClientFactory,IClient,IClientSession) |
QpidResourceHolder Constructor(IClientSession) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > QpidResourceHolder Constructor : QpidResourceHolder Constructor()

Syntax

C#
public QpidResourceHolder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor(IClient,IClientSession)
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > QpidResourceHolder Constructor : QpidResourceHolder Constructor(IClient,IClientSession)
connection
channel

Syntax

C#
public QpidResourceHolder(
   IClient connection,
   IClientSession channel
)

Parameters

connection
channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor(IClientFactory)
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > QpidResourceHolder Constructor : QpidResourceHolder Constructor(IClientFactory)
connectionFactory

Syntax

C#
public QpidResourceHolder(
   IClientFactory connectionFactory
)

Parameters

connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor(IClientFactory,IClient,IClientSession)
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > QpidResourceHolder Constructor : QpidResourceHolder Constructor(IClientFactory,IClient,IClientSession)
connectionFactory
connection
channel

Syntax

C#
public QpidResourceHolder(
   IClientFactory connectionFactory,
   IClient connection,
   IClientSession channel
)

Parameters

connectionFactory
connection
channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Constructor(IClientSession)
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > QpidResourceHolder Constructor : QpidResourceHolder Constructor(IClientSession)
channel

Syntax

C#
public QpidResourceHolder(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : QpidResourceHolder Class

For a list of all members of this type, see QpidResourceHolder members.

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded.
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll |
Public Method | CommitAll |
Public Method | ContainsChannel |
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

QpidResourceHolder Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
AddChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : AddChannel Method

Overload List

Overload | Description
AddChannel(IClientSession) |
AddChannel(IClientSession,IClient) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
AddChannel(IClientSession) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > AddChannel Method : AddChannel(IClientSession) Method
channel

Syntax

C#
public void AddChannel(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
AddChannel(IClientSession,IClient) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class > AddChannel Method : AddChannel(IClientSession,IClient) Method
channel
connection

Syntax

C#
public void AddChannel(
   IClientSession channel,
   IClient connection
)

Parameters

channel
connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CloseAll Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : CloseAll Method

Syntax

C#
public void CloseAll()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CommitAll Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : CommitAll Method

Syntax

C#
public void CommitAll()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ContainsChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : ContainsChannel Method
channel

Syntax

C#
public bool ContainsChannel(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidResourceHolder Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : QpidResourceHolder Class

For a list of all members of this type, see QpidResourceHolder members.

Public Properties

 | Name | Description
Public Property | Channel |
Public Property | Connection |
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen |
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

QpidResourceHolder Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Channel Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Channel Property

Syntax

C#
public IClientSession Channel {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Connection Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Connection Property

Syntax

C#
public IClient Connection {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Frozen Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Frozen Property

Syntax

C#
public bool Frozen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
SimpleClientFactory Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : SimpleClientFactory Class

Syntax

C#
public class SimpleClientFactory : IClientFactory

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Client.SimpleClientFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleClientFactory Members
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
SimpleClientFactory Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : SimpleClientFactory Class

The following tables list the members exposed by SimpleClientFactory.

Public Constructors

 | Name | Description
Public Constructor | SimpleClientFactory Constructor | Initializes a new instance of the Object class.
Top

Public Methods

 | Name | Description
Public Method | CreateClient | Eagerly creates a new client.
Top

See Also

Reference

SimpleClientFactory Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
SimpleClientFactory Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > SimpleClientFactory Class : SimpleClientFactory Constructor
connectionParameters
Initializes a new instance of the Object class.

Syntax

C#
public SimpleClientFactory(
   ConnectionParameters connectionParameters
)

Parameters

connectionParameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleClientFactory Class
SimpleClientFactory Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
SimpleClientFactory Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : SimpleClientFactory Class

For a list of all members of this type, see SimpleClientFactory members.

Public Methods

 | Name | Description
Public Method | CreateClient | Eagerly creates a new client.
Top

See Also

Reference

SimpleClientFactory Class
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateClient Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > SimpleClientFactory Class : CreateClient Method
Eagerly creates a new client.

Syntax

C#
public IClient CreateClient()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleClientFactory Class
SimpleClientFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IResourceFactory Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : IResourceFactory Interface

Syntax

C#
public interface IResourceFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Members
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IResourceFactory Interface Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : IResourceFactory Interface

The following tables list the members exposed by IResourceFactory.

Public Properties

 | Name | Description
Property | IsSynchedLocalTransactionAllowed |
Top

Public Methods

 | Name | Description
Method | CreateChannel |
Method | CreateConnection |
Method | GetChannel |
Method | GetConnection |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IResourceFactory Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : IResourceFactory Interface

For a list of all members of this type, see IResourceFactory members.

Public Methods

 | Name | Description
Method | CreateChannel |
Method | CreateConnection |
Method | GetChannel |
Method | GetConnection |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > IResourceFactory Interface : CreateChannel Method
connection

Syntax

C#
IClientSession CreateChannel(
   IClient connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > IResourceFactory Interface : CreateConnection Method

Syntax

C#
IClient CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > IResourceFactory Interface : GetChannel Method
holder

Syntax

C#
IClientSession GetChannel(
   QpidResourceHolder holder
)

Parameters

holder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
GetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > IResourceFactory Interface : GetConnection Method
rabbitResourceHolder

Syntax

C#
IClient GetConnection(
   QpidResourceHolder rabbitResourceHolder
)

Parameters

rabbitResourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IResourceFactory Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace : IResourceFactory Interface

For a list of all members of this type, see IResourceFactory members.

Public Properties

 | Name | Description
Property | IsSynchedLocalTransactionAllowed |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Qpid.Client Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IsSynchedLocalTransactionAllowed Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > IResourceFactory Interface : IsSynchedLocalTransactionAllowed Property

Syntax

C#
bool IsSynchedLocalTransactionAllowed {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%ItemTitle%%

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Core Namespace (Spring.Messaging.Amqp.Qpid-0-10-06)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ConnectionParameters |
Class | MessageProperties |
Class | QpidAccessor |
Class | QpidTemplate |

Interfaces

 | Interface | Description
Interface | IClientFactory |
Interface | Generic IClientSessionCallback |
Interface | IQpidOperations |

Delegates

 | Delegate | Description
Delegate | Generic ClientSessionCallbackDelegate |
Delegate | MessageCreatorDelegate |

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConnectionParameters Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : ConnectionParameters Class

Syntax

C#
public class ConnectionParameters

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.ConnectionParameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConnectionParameters Class Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : ConnectionParameters Class

The following tables list the members exposed by ConnectionParameters.

Public Constructors

 | Name | Description
Public Constructor | ConnectionParameters Constructor | Initializes a new instance of the Object class.
Top

Public Properties

 | Name | Description
Public Property | Host |
Public Property | Password |
Public Property | Port |
Public Property | Username |
Public Property | VirtualHostName |
Top

See Also

Reference

ConnectionParameters Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConnectionParameters Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : ConnectionParameters Constructor
host
port
virtualHostName
username
password
Initializes a new instance of the Object class.

Syntax

C#
public ConnectionParameters(
   string host,
   int port,
   string virtualHostName,
   string username,
   string password
)

Parameters

host
port
virtualHostName
username
password

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConnectionParameters Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : ConnectionParameters Class

For a list of all members of this type, see ConnectionParameters members.

Public Properties

 | Name | Description
Public Property | Host |
Public Property | Password |
Public Property | Port |
Public Property | Username |
Public Property | VirtualHostName |
Top

See Also

Reference

ConnectionParameters Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Host Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : Host Property

Syntax

C#
public string Host {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Password Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : Password Property

Syntax

C#
public string Password {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Port Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : Port Property

Syntax

C#
public int Port {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Username Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : Username Property

Syntax

C#
public string Username {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
VirtualHostName Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > ConnectionParameters Class : VirtualHostName Property

Syntax

C#
public string VirtualHostName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionParameters Class
ConnectionParameters Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageProperties Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

Syntax

C#
public class MessageProperties : IMessageProperties

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.MessageProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageProperties Class Members
See Also Fields Properties Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

The following tables list the members exposed by MessageProperties.

Public Constructors

 | Name | Description
Public Constructor | MessageProperties Constructor | Initializes a new instance of the Object class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryProperites |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | MessagePropreties |
Public Property | Priority | Gets or sets the priority.
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageProperties Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageProperties Constructor
Initializes a new instance of the Object class.

Syntax

C#
public MessageProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageProperties Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryProperites |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | MessagePropreties |
Public Property | Priority | Gets or sets the priority.
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
AppId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : AppId Property

Syntax

C#
public string AppId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClusterId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ClusterId Property

Syntax

C#
public string ClusterId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ContentEncoding Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentEncoding Property

Syntax

C#
public string ContentEncoding {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ContentLength Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentLength Property

Syntax

C#
public long ContentLength {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ContentType Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ContentType Property

Syntax

C#
public string ContentType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CorrelationId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CorrelationId Property

Syntax

C#
public byte[] CorrelationId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DeliveryMode Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : DeliveryMode Property

Syntax

C#
public MessageDeliveryMode DeliveryMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DeliveryProperites Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : DeliveryProperites Property

Syntax

C#
public DeliveryProperties DeliveryProperites {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DeliveryTag Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : DeliveryTag Property

Syntax

C#
public ulong DeliveryTag {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Expiration Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Expiration Property

Syntax

C#
public string Expiration {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Headers Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Headers Property

Syntax

C#
public IDictionary<string, object> Headers {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageCount Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageCount Property

Syntax

C#
public uint MessageCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessageId Property

Syntax

C#
public string MessageId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessagePropreties Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : MessagePropreties Property

Syntax

C#
public MessageProperties MessagePropreties {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Priority Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Priority Property
Gets or sets the priority.

Syntax

C#
public int Priority {get; set;}

Return Value

The priority.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReceivedExchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReceivedExchange Property

Syntax

C#
public string ReceivedExchange {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReceivedRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReceivedRoutingKey Property

Syntax

C#
public string ReceivedRoutingKey {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Redelivered Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Redelivered Property

Syntax

C#
public bool Redelivered {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReplyTo Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : ReplyTo Property

Syntax

C#
public string ReplyTo {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Timestamp Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Timestamp Property

Syntax

C#
public long Timestamp {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Type Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : Type Property

Syntax

C#
public string Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
UserId Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : UserId Property

Syntax

C#
public string UserId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageProperties Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CONTENT_TYPE_BYTES Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_BYTES Field

Syntax

C#
public static readonly string CONTENT_TYPE_BYTES

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CONTENT_TYPE_JSON Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_JSON Field

Syntax

C#
public static readonly string CONTENT_TYPE_JSON

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CONTENT_TYPE_SERIALIZED_OBJECT Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_SERIALIZED_OBJECT Field

Syntax

C#
public static readonly string CONTENT_TYPE_SERIALIZED_OBJECT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CONTENT_TYPE_TEXT_PLAIN Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > MessageProperties Class : CONTENT_TYPE_TEXT_PLAIN Field

Syntax

C#
public static readonly string CONTENT_TYPE_TEXT_PLAIN

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidAccessor Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidAccessor Class

Object Model

Syntax

C#
public class QpidAccessor : IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.QpidAccessor
Spring.Messaging.Amqp.Qpid.Core.QpidTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidAccessor Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidAccessor Class

The following tables list the members exposed by QpidAccessor.

Public Constructors

 | Name | Description
Public Constructor | QpidAccessor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChannelTransacted |
Public Property | ClientFactory |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel |
Protected Method | CreateClient |
Top

See Also

Reference

QpidAccessor Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidAccessor Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : QpidAccessor Constructor

Syntax

C#
public QpidAccessor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidAccessor Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidAccessor Class

For a list of all members of this type, see QpidAccessor members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel |
Protected Method | CreateClient |
Top

See Also

Reference

QpidAccessor Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : AfterPropertiesSet Method

Syntax

C#
public virtual void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : CreateChannel Method
client

Syntax

C#
protected IClientSession CreateChannel(
   IClient client
)

Parameters

client

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateClient Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : CreateClient Method

Syntax

C#
protected IClient CreateClient()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidAccessor Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidAccessor Class

For a list of all members of this type, see QpidAccessor members.

Public Properties

 | Name | Description
Public Property | ChannelTransacted |
Public Property | ClientFactory |
Top

See Also

Reference

QpidAccessor Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ChannelTransacted Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : ChannelTransacted Property

Syntax

C#
public bool ChannelTransacted {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ClientFactory Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidAccessor Class : ClientFactory Property

Syntax

C#
public IClientFactory ClientFactory {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidAccessor Class
QpidAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidTemplate Class

Object Model

Syntax

C#
public class QpidTemplate : QpidAccessor, IAmqpTemplate, IQpidOperations, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.QpidAccessor
Spring.Messaging.Amqp.Qpid.Core.QpidTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidTemplate Class

The following tables list the members exposed by QpidTemplate.

Public Constructors

 | Name | Description
Public Constructor | QpidTemplate Constructor |
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from QpidAccessor)
Public Property | ClientFactory | (Inherited from QpidAccessor)
Public Property | DefaultQueueName |
Public Property | DefaultRoutingKey |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from QpidAccessor)
Public Method | ConvertAndSend | Overloaded.
Public Method | CreateMessageProperties |
Public Method | Execute | Overloaded.
Public Method | Receive | Overloaded.
Public Method | ReceiveAndConvert | Overloaded.
Public Method | Send | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ChannelLocallyTransacted |
Protected Method | CreateChannel | (Inherited from QpidAccessor)
Protected Method | CreateClient | (Inherited from QpidAccessor)
Protected Method | DoSend |
Protected Method | GetChannel |
Protected Method | GetConnection |
Top

See Also

Reference

QpidTemplate Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : QpidTemplate Constructor

Syntax

C#
public QpidTemplate()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidTemplate Class

For a list of all members of this type, see QpidTemplate members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from QpidAccessor)
Public Method | ConvertAndSend | Overloaded.
Public Method | CreateMessageProperties |
Public Method | Execute | Overloaded.
Public Method | Receive | Overloaded.
Public Method | ReceiveAndConvert | Overloaded.
Public Method | Send | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ChannelLocallyTransacted |
Protected Method | CreateChannel | (Inherited from QpidAccessor)
Protected Method | CreateClient | (Inherited from QpidAccessor)
Protected Method | DoSend |
Protected Method | GetChannel |
Protected Method | GetConnection |
Top

See Also

Reference

QpidTemplate Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ChannelLocallyTransacted Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : ChannelLocallyTransacted Method
channel

Syntax

C#
protected bool ChannelLocallyTransacted(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : ConvertAndSend Method

Overload List

Overload | Description
ConvertAndSend(Object) |
ConvertAndSend(String,Object) |
ConvertAndSend(String,String,Object) |
ConvertAndSend(Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(Object) Method
message

Syntax

C#
public void ConvertAndSend(
   object message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(String,Object) Method
routingKey
message

Syntax

C#
public void ConvertAndSend(
   string routingKey,
   object message
)

Parameters

routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(String,String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(String,String,Object) Method
exchange
routingKey
message

Syntax

C#
public void ConvertAndSend(
   string exchange,
   string routingKey,
   object message
)

Parameters

exchange
routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(Object,MessagePostProcessorDelegate) Method
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
routingKey
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ConvertAndSend Method : ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
exchange
routingKey
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   string exchange,
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

exchange
routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateMessageProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : CreateMessageProperties Method

Syntax

C#
public IMessageProperties CreateMessageProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DoSend Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : DoSend Method
channel
exchange
routingKey
messageCreator
messageCreatorDelegate

Syntax

C#
protected virtual void DoSend(
   IClientSession channel,
   string exchange,
   string routingKey,
   IMessageCreator messageCreator,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

channel
exchange
routingKey
messageCreator
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Execute Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : Execute Method

Overload List

Overload | Description
Generic Execute(Generic IClientSessionCallback) |
Generic Execute(Generic ClientSessionCallbackDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic Execute(Generic IClientSessionCallback) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Execute Method : Generic Execute(Generic IClientSessionCallback) Method
action

Syntax

C#
public T Execute<T>(
   IClientSessionCallback<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic Execute(Generic ClientSessionCallbackDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Execute Method : Generic Execute(Generic ClientSessionCallbackDelegate) Method
action

Syntax

C#
public T Execute<T>(
   ClientSessionCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : GetChannel Method
resourceHolder

Syntax

C#
protected virtual IClientSession GetChannel(
   QpidResourceHolder resourceHolder
)

Parameters

resourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
GetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : GetConnection Method
resourceHolder

Syntax

C#
protected virtual IClient GetConnection(
   QpidResourceHolder resourceHolder
)

Parameters

resourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Receive Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : Receive Method

Overload List

Overload | Description
Receive() |
Receive(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Receive() Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Receive Method : Receive() Method

Syntax

C#
public Message Receive()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Receive(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Receive Method : Receive(String) Method
queueName

Syntax

C#
public Message Receive(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReceiveAndConvert Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : ReceiveAndConvert Method

Overload List

Overload | Description
ReceiveAndConvert() |
ReceiveAndConvert(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReceiveAndConvert() Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ReceiveAndConvert Method : ReceiveAndConvert() Method

Syntax

C#
public object ReceiveAndConvert()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ReceiveAndConvert(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > ReceiveAndConvert Method : ReceiveAndConvert(String) Method
queueName

Syntax

C#
public object ReceiveAndConvert(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : Send Method

Overload List

Overload | Description
Send(MessageCreatorDelegate) |
Send(String,MessageCreatorDelegate) |
Send(String,String,MessageCreatorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Send Method : Send(MessageCreatorDelegate) Method
messageCreator

Syntax

C#
public void Send(
   MessageCreatorDelegate messageCreator
)

Parameters

messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Send Method : Send(String,MessageCreatorDelegate) Method
routingkey
messageCreator

Syntax

C#
public void Send(
   string routingkey,
   MessageCreatorDelegate messageCreator
)

Parameters

routingkey
messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(String,String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class > Send Method : Send(String,String,MessageCreatorDelegate) Method
exchange
routingKey
messageCreatorDelegate

Syntax

C#
public void Send(
   string exchange,
   string routingKey,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

exchange
routingKey
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidTemplate Class

For a list of all members of this type, see QpidTemplate members.

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from QpidAccessor)
Public Property | ClientFactory | (Inherited from QpidAccessor)
Public Property | DefaultQueueName |
Public Property | DefaultRoutingKey |
Top

See Also

Reference

QpidTemplate Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DefaultQueueName Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : DefaultQueueName Property

Syntax

C#
public string DefaultQueueName {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DefaultRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : DefaultRoutingKey Property

Syntax

C#
public string DefaultRoutingKey {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidTemplate Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : QpidTemplate Class

For a list of all members of this type, see QpidTemplate members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

See Also

Reference

QpidTemplate Class
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
logger Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > QpidTemplate Class : logger Field

Syntax

C#
protected static readonly ILog logger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidTemplate Class
QpidTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IClientFactory Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IClientFactory Interface

Syntax

C#
public interface IClientFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientFactory Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IClientFactory Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IClientFactory Interface

The following tables list the members exposed by IClientFactory.

Public Methods

 | Name | Description
Method | CreateClient |
Top

See Also

Reference

IClientFactory Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IClientFactory Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IClientFactory Interface

For a list of all members of this type, see IClientFactory members.

Public Methods

 | Name | Description
Method | CreateClient |
Top

See Also

Reference

IClientFactory Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CreateClient Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IClientFactory Interface : CreateClient Method

Syntax

C#
IClient CreateClient()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientFactory Interface
IClientFactory Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic IClientSessionCallback Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : Generic IClientSessionCallback Interface

Syntax

C#
public interface IClientSessionCallback<T>

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic IClientSessionCallback Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic IClientSessionCallback Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : Generic IClientSessionCallback Interface

The following tables list the members exposed by Generic IClientSessionCallback.

Public Methods

 | Name | Description
Method | DoInSession |
Top

See Also

Reference

Generic IClientSessionCallback Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic IClientSessionCallback Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : Generic IClientSessionCallback Interface

For a list of all members of this type, see Generic IClientSessionCallback members.

Public Methods

 | Name | Description
Method | DoInSession |
Top

See Also

Reference

Generic IClientSessionCallback Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DoInSession Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > Generic IClientSessionCallback Interface : DoInSession Method
model

Syntax

C#
T DoInSession(
   IClientSession model
)

Parameters

model

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic IClientSessionCallback Interface
Generic IClientSessionCallback Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IQpidOperations Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IQpidOperations Interface

Syntax

C#
public interface IQpidOperations : IAmqpTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Members
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IQpidOperations Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IQpidOperations Interface

The following tables list the members exposed by IQpidOperations.

Public Methods

 | Name | Description
Method | Execute | Overloaded.
Method | Send | Overloaded.
Top

See Also

Reference

IQpidOperations Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IQpidOperations Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : IQpidOperations Interface

For a list of all members of this type, see IQpidOperations members.

Public Methods

 | Name | Description
Method | Execute | Overloaded.
Method | Send | Overloaded.
Top

See Also

Reference

IQpidOperations Interface
Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Execute Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface : Execute Method

Overload List

Overload | Description
Generic Execute(Generic IClientSessionCallback) |
Generic Execute(Generic ClientSessionCallbackDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic Execute(Generic IClientSessionCallback) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface > Execute Method : Generic Execute(Generic IClientSessionCallback) Method
action

Syntax

C#
T Execute<T>(
   IClientSessionCallback<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members
Overload List


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic Execute(Generic ClientSessionCallbackDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface > Execute Method : Generic Execute(Generic ClientSessionCallbackDelegate) Method
action

Syntax

C#
T Execute<T>(
   ClientSessionCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface : Send Method

Overload List

Overload | Description
Send(MessageCreatorDelegate) |
Send(String,MessageCreatorDelegate) |
Send(String,String,MessageCreatorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface > Send Method : Send(MessageCreatorDelegate) Method
messageCreator

Syntax

C#
void Send(
   MessageCreatorDelegate messageCreator
)

Parameters

messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface > Send Method : Send(String,MessageCreatorDelegate) Method
routingkey
messageCreator

Syntax

C#
void Send(
   string routingkey,
   MessageCreatorDelegate messageCreator
)

Parameters

routingkey
messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Send(String,String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace > IQpidOperations Interface > Send Method : Send(String,String,MessageCreatorDelegate) Method
exchange
routingKey
messageCreatorDelegate

Syntax

C#
void Send(
   string exchange,
   string routingKey,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

exchange
routingKey
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IQpidOperations Interface
IQpidOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Generic ClientSessionCallbackDelegate Delegate
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : Generic ClientSessionCallbackDelegate Delegate
session

Syntax

C#
public delegate T ClientSessionCallbackDelegate<T>(
   IClientSession session
)

Parameters

session

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Qpid.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
MessageCreatorDelegate Delegate
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Core Namespace : MessageCreatorDelegate Delegate

Syntax

C#
public delegate Message MessageCreatorDelegate()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Qpid.Core Namespace


%%ItemTitle%%

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Support Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | QpidUtils |

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidUtils Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace : QpidUtils Class

Syntax

C#
public class QpidUtils

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Support.QpidUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Members
Spring.Messaging.Amqp.Qpid.Support Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidUtils Class Members
See Also Fields Methods Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace : QpidUtils Class

The following tables list the members exposed by QpidUtils.

Public Constructors

 | Name | Description
Public Constructor | QpidUtils Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_PORT |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseChannel |
static (Shared in Visual Basic) | CloseClient | Closes the given Rabbit Connection and ignore any thrown exception.
static (Shared in Visual Basic) | CommitIfNecessary |
static (Shared in Visual Basic) | ExtractDeliveryProperties |
static (Shared in Visual Basic) | RollbackIfNecessary |
Top

See Also

Reference

QpidUtils Class
Spring.Messaging.Amqp.Qpid.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidUtils Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : QpidUtils Constructor

Syntax

C#
public QpidUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidUtils Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace : QpidUtils Class

For a list of all members of this type, see QpidUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseChannel |
static (Shared in Visual Basic) | CloseClient | Closes the given Rabbit Connection and ignore any thrown exception.
static (Shared in Visual Basic) | CommitIfNecessary |
static (Shared in Visual Basic) | ExtractDeliveryProperties |
static (Shared in Visual Basic) | RollbackIfNecessary |
Top

See Also

Reference

QpidUtils Class
Spring.Messaging.Amqp.Qpid.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CloseChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : CloseChannel Method
channel

Syntax

C#
public static void CloseChannel(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CloseClient Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : CloseClient Method
connection
The connection to close (may be nul).
Closes the given Rabbit Connection and ignore any thrown exception.

Syntax

C#
public static void CloseClient(
   IClient connection
)

Parameters

connection
The connection to close (may be nul).

Remarks

This is useful for typical 'finally' blocks in manual Rabbit code

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
CommitIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : CommitIfNecessary Method
channel

Syntax

C#
public static void CommitIfNecessary(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
ExtractDeliveryProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : ExtractDeliveryProperties Method
message

Syntax

C#
public static DeliveryProperties ExtractDeliveryProperties(
   Message message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
RollbackIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : RollbackIfNecessary Method
channel

Syntax

C#
public static void RollbackIfNecessary(
   IClientSession channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
QpidUtils Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace : QpidUtils Class

For a list of all members of this type, see QpidUtils members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_PORT |
Top

See Also

Reference

QpidUtils Class
Spring.Messaging.Amqp.Qpid.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
DEFAULT_PORT Field
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Support Namespace > QpidUtils Class : DEFAULT_PORT Field

Syntax

C#
public static int DEFAULT_PORT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidUtils Class
QpidUtils Members


$$INTRODUCTION$$ - %%projecttitle%%

Spring.Messaging.Amqp.Rabbit
Introduction
Send Feedback


%%phrase%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit Assembly
See Also Send Feedback
This assembly contains integration classes for RabbitMQ, allowing for Spring-style AMQP access.

Namespaces

Namespace | Description
Spring.Messaging.Amqp.Rabbit.Connection | Provides a interface for a RabbitMQ ConnectionFactory, and a SingleConnectionFactory implementaion.
Spring.Messaging.Amqp.Rabbit.Core | Core package of the RabbitMQ support.
Spring.Messaging.Amqp.Rabbit.Core.Support | Classes supporting the Spring.Messaging.Amqp.Rabbit.Core namespace
Spring.Messaging.Amqp.Rabbit.Listener | This namespace contains the base message listener container facility.
Spring.Messaging.Amqp.Rabbit.Listener.Adapter | Message listener adapter mechanism that delegates to target listener methods, converting messages to appropriate message content types (such as String or byte array) that get passed into listener methods.
Spring.Messaging.Amqp.Rabbit.Support | This package provides generic RabbitMQ support classes, to be used by higher-level classes like RabbitTemplate.


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Messaging.Amqp.Rabbit
Getting Started
Send Feedback
Please refer to the reference documentation and sample applications.


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Connection Namespace
See Also Inheritance Hierarchy Send Feedback
Provides a interface for a RabbitMQ ConnectionFactory, and a SingleConnectionFactory implementaion.

Classes

 | Class | Description
Class | CachedModel |
Class | CachingConnectionFactory | A IConnectionFactory implementation that returns the same Connection from all IConnectionFactory.CreateConnection calls, and ignores call to Close
Class | CloseSuppressingConnection |
Class | ConnectionFactoryUtils |
Class | RabbitResourceHolder |
Class | SingleConnectionFactory | A IConnectionFactory implementation that returns the same Connection from all IConnectionFactory.CreateConnection calls, and ignores call to Close

Interfaces

 | Interface | Description
Interface | IConnectionFactory | An interface based ConnectionFactory for creating IConnections.
Interface | IDecoratorConnection | Subinterface of Connection to be implemented by implementations that wrap an Connection to provide added functionality. Allows access to the the underlying target Connection.
Interface | IDecoratorModel | Subinterface of Model to be implemented by implementations that wrap a Model to provide added functionality. Allows access to the the underlying target Model.
Interface | IResourceFactory |

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachedModel Class

Syntax

C#
public class CachedModel : IModel, IDecoratorModel

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.CachedModel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Class Members
See Also Properties Methods Events Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachedModel Class

The following tables list the members exposed by CachedModel.

Public Constructors

 | Name | Description
Public Constructor | CachedModel Constructor |
Top

Public Properties

 | Name | Description
Public Property | CloseReason |
Public Property | IsOpen |
Public Property | TargetModel | Gets the target, for testing purposes.
Top

Public Methods

 | Name | Description
Public Method | Abort | Overloaded.
Public Method | BasicAck |
Public Method | BasicCancel |
Public Method | BasicConsume | Overloaded.
Public Method | BasicGet |
Public Method | BasicPublish | Overloaded.
Public Method | BasicQos |
Public Method | BasicRecover |
Public Method | BasicReject |
Public Method | ChannelFlow |
Public Method | Close | Overloaded.
Public Method | CreateBasicProperties |
Public Method | CreateFileProperties |
Public Method | CreateStreamProperties |
Public Method | Dispose |
Public Method | DtxSelect |
Public Method | DtxStart |
Public Method | ExchangeDeclare | Overloaded.
Public Method | ExchangeDelete |
Public Method | QueueBind |
Public Method | QueueDeclare | Overloaded.
Public Method | QueueDelete |
Public Method | QueuePurge |
Public Method | QueueUnbind |
Public Method | TxCommit |
Public Method | TxRollback |
Public Method | TxSelect |
Top

Public Events

 | Name | Description
Public Event | BasicReturn |
Public Event | CallbackException |
Public Event | ModelShutdown |
Top

See Also

Reference

CachedModel Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CachedModel Constructor
targetModel
modelList
ccf

Syntax

C#
public CachedModel(
   IModel targetModel,
   LinkedList<IModel> modelList,
   CachingConnectionFactory ccf
)

Parameters

targetModel
modelList
ccf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachedModel Class

For a list of all members of this type, see CachedModel members.

Public Methods

 | Name | Description
Public Method | Abort | Overloaded.
Public Method | BasicAck |
Public Method | BasicCancel |
Public Method | BasicConsume | Overloaded.
Public Method | BasicGet |
Public Method | BasicPublish | Overloaded.
Public Method | BasicQos |
Public Method | BasicRecover |
Public Method | BasicReject |
Public Method | ChannelFlow |
Public Method | Close | Overloaded.
Public Method | CreateBasicProperties |
Public Method | CreateFileProperties |
Public Method | CreateStreamProperties |
Public Method | Dispose |
Public Method | DtxSelect |
Public Method | DtxStart |
Public Method | ExchangeDeclare | Overloaded.
Public Method | ExchangeDelete |
Public Method | QueueBind |
Public Method | QueueDeclare | Overloaded.
Public Method | QueueDelete |
Public Method | QueuePurge |
Public Method | QueueUnbind |
Public Method | TxCommit |
Public Method | TxRollback |
Public Method | TxSelect |
Top

See Also

Reference

CachedModel Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : Abort Method

Overload List

Overload | Description
Abort() |
Abort(UInt16,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > Abort Method : Abort() Method

Syntax

C#
public void Abort()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort(UInt16,String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > Abort Method : Abort(UInt16,String) Method
replyCode
replyText

Syntax

C#
public void Abort(
   ushort replyCode,
   string replyText
)

Parameters

replyCode
replyText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicAck Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicAck Method
deliveryTag
multiple

Syntax

C#
public void BasicAck(
   ulong deliveryTag,
   bool multiple
)

Parameters

deliveryTag
multiple

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicCancel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicCancel Method
consumerTag

Syntax

C#
public void BasicCancel(
   string consumerTag
)

Parameters

consumerTag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicConsume Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicConsume Method

Overload List

Overload | Description
BasicConsume(String,IDictionary,IBasicConsumer) |
BasicConsume(String,Boolean,IDictionary,IBasicConsumer) |
BasicConsume(String,Boolean,String,IDictionary,IBasicConsumer) |
BasicConsume(String,Boolean,String,Boolean,Boolean,IDictionary,IBasicConsumer) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicConsume(String,IDictionary,IBasicConsumer) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicConsume Method : BasicConsume(String,IDictionary,IBasicConsumer) Method
queue
filter
consumer

Syntax

C#
public string BasicConsume(
   string queue,
   IDictionary filter,
   IBasicConsumer consumer
)

Parameters

queue
filter
consumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicConsume(String,Boolean,IDictionary,IBasicConsumer) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicConsume Method : BasicConsume(String,Boolean,IDictionary,IBasicConsumer) Method
queue
noAck
filter
consumer

Syntax

C#
public string BasicConsume(
   string queue,
   bool noAck,
   IDictionary filter,
   IBasicConsumer consumer
)

Parameters

queue
noAck
filter
consumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicConsume(String,Boolean,String,IDictionary,IBasicConsumer) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicConsume Method : BasicConsume(String,Boolean,String,IDictionary,IBasicConsumer) Method
queue
noAck
consumerTag
filter
consumer

Syntax

C#
public string BasicConsume(
   string queue,
   bool noAck,
   string consumerTag,
   IDictionary filter,
   IBasicConsumer consumer
)

Parameters

queue
noAck
consumerTag
filter
consumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicConsume(String,Boolean,String,Boolean,Boolean,IDictionary,IBasicConsumer) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicConsume Method : BasicConsume(String,Boolean,String,Boolean,Boolean,IDictionary,IBasicConsumer) Method
queue
noAck
consumerTag
noLocal
exclusive
filter
consumer

Syntax

C#
public string BasicConsume(
   string queue,
   bool noAck,
   string consumerTag,
   bool noLocal,
   bool exclusive,
   IDictionary filter,
   IBasicConsumer consumer
)

Parameters

queue
noAck
consumerTag
noLocal
exclusive
filter
consumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicGet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicGet Method
queue
noAck

Syntax

C#
public BasicGetResult BasicGet(
   string queue,
   bool noAck
)

Parameters

queue
noAck

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicPublish Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicPublish Method

Overload List

Overload | Description
BasicPublish(PublicationAddress,IBasicProperties,Byte[]) |
BasicPublish(String,String,IBasicProperties,Byte[]) |
BasicPublish(String,String,Boolean,Boolean,IBasicProperties,Byte[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicPublish(PublicationAddress,IBasicProperties,Byte[]) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicPublish Method : BasicPublish(PublicationAddress,IBasicProperties,Byte[]) Method
addr
basicProperties
body

Syntax

C#
public void BasicPublish(
   PublicationAddress addr,
   IBasicProperties basicProperties,
   byte[] body
)

Parameters

addr
basicProperties
body

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicPublish(String,String,IBasicProperties,Byte[]) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicPublish Method : BasicPublish(String,String,IBasicProperties,Byte[]) Method
exchange
routingKey
basicProperties
body

Syntax

C#
public void BasicPublish(
   string exchange,
   string routingKey,
   IBasicProperties basicProperties,
   byte[] body
)

Parameters

exchange
routingKey
basicProperties
body

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicPublish(String,String,Boolean,Boolean,IBasicProperties,Byte[]) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > BasicPublish Method : BasicPublish(String,String,Boolean,Boolean,IBasicProperties,Byte[]) Method
exchange
routingKey
mandatory
immediate
basicProperties
body

Syntax

C#
public void BasicPublish(
   string exchange,
   string routingKey,
   bool mandatory,
   bool immediate,
   IBasicProperties basicProperties,
   byte[] body
)

Parameters

exchange
routingKey
mandatory
immediate
basicProperties
body

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicQos Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicQos Method
prefetchSize
prefetchCount
global

Syntax

C#
public void BasicQos(
   uint prefetchSize,
   ushort prefetchCount,
   bool global
)

Parameters

prefetchSize
prefetchCount
global

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicRecover Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicRecover Method
requeue

Syntax

C#
public void BasicRecover(
   bool requeue
)

Parameters

requeue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicReject Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicReject Method
deliveryTag
requeue

Syntax

C#
public void BasicReject(
   ulong deliveryTag,
   bool requeue
)

Parameters

deliveryTag
requeue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ChannelFlow Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : ChannelFlow Method
active

Syntax

C#
public void ChannelFlow(
   bool active
)

Parameters

active

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : Close Method

Overload List

Overload | Description
Close(UInt16,String) |
Close() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close(UInt16,String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > Close Method : Close(UInt16,String) Method
replyCode
replyText

Syntax

C#
public void Close(
   ushort replyCode,
   string replyText
)

Parameters

replyCode
replyText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > Close Method : Close() Method

Syntax

C#
public void Close()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateBasicProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CreateBasicProperties Method

Syntax

C#
public IBasicProperties CreateBasicProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateFileProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CreateFileProperties Method

Syntax

C#
public IFileProperties CreateFileProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateStreamProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CreateStreamProperties Method

Syntax

C#
public IStreamProperties CreateStreamProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Dispose Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : Dispose Method

Syntax

C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DtxSelect Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : DtxSelect Method

Syntax

C#
public void DtxSelect()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DtxStart Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : DtxStart Method
dtxIdentifier

Syntax

C#
public void DtxStart(
   string dtxIdentifier
)

Parameters

dtxIdentifier

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExchangeDeclare Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : ExchangeDeclare Method

Overload List

Overload | Description
ExchangeDeclare(String,String,Boolean) |
ExchangeDeclare(String,String) |
ExchangeDeclare(String,String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExchangeDeclare(String,String,Boolean) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > ExchangeDeclare Method : ExchangeDeclare(String,String,Boolean) Method
exchange
type
durable

Syntax

C#
public void ExchangeDeclare(
   string exchange,
   string type,
   bool durable
)

Parameters

exchange
type
durable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExchangeDeclare(String,String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > ExchangeDeclare Method : ExchangeDeclare(String,String) Method
exchange
type

Syntax

C#
public void ExchangeDeclare(
   string exchange,
   string type
)

Parameters

exchange
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExchangeDeclare(String,String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > ExchangeDeclare Method : ExchangeDeclare(String,String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) Method
exchange
type
passive
durable
autoDelete
isInternal
nowait
arguments

Syntax

C#
public void ExchangeDeclare(
   string exchange,
   string type,
   bool passive,
   bool durable,
   bool autoDelete,
   bool isInternal,
   bool nowait,
   IDictionary arguments
)

Parameters

exchange
type
passive
durable
autoDelete
isInternal
nowait
arguments

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExchangeDelete Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : ExchangeDelete Method
exchange
ifUnused
nowait

Syntax

C#
public void ExchangeDelete(
   string exchange,
   bool ifUnused,
   bool nowait
)

Parameters

exchange
ifUnused
nowait

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueBind Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : QueueBind Method
queue
exchange
routingKey
nowait
arguments

Syntax

C#
public void QueueBind(
   string queue,
   string exchange,
   string routingKey,
   bool nowait,
   IDictionary arguments
)

Parameters

queue
exchange
routingKey
nowait
arguments

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDeclare Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : QueueDeclare Method

Overload List

Overload | Description
QueueDeclare() |
QueueDeclare(String) |
QueueDeclare(String,Boolean) |
QueueDeclare(String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDeclare() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > QueueDeclare Method : QueueDeclare() Method

Syntax

C#
public string QueueDeclare()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDeclare(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > QueueDeclare Method : QueueDeclare(String) Method
queue

Syntax

C#
public string QueueDeclare(
   string queue
)

Parameters

queue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDeclare(String,Boolean) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > QueueDeclare Method : QueueDeclare(String,Boolean) Method
queue
durable

Syntax

C#
public string QueueDeclare(
   string queue,
   bool durable
)

Parameters

queue
durable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDeclare(String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class > QueueDeclare Method : QueueDeclare(String,Boolean,Boolean,Boolean,Boolean,Boolean,IDictionary) Method
queue
passive
durable
exclusive
autoDelete
nowait
arguments

Syntax

C#
public string QueueDeclare(
   string queue,
   bool passive,
   bool durable,
   bool exclusive,
   bool autoDelete,
   bool nowait,
   IDictionary arguments
)

Parameters

queue
passive
durable
exclusive
autoDelete
nowait
arguments

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueDelete Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : QueueDelete Method
queue
ifUnused
ifEmpty
nowait

Syntax

C#
public uint QueueDelete(
   string queue,
   bool ifUnused,
   bool ifEmpty,
   bool nowait
)

Parameters

queue
ifUnused
ifEmpty
nowait

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueuePurge Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : QueuePurge Method
queue
nowait

Syntax

C#
public uint QueuePurge(
   string queue,
   bool nowait
)

Parameters

queue
nowait

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
QueueUnbind Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : QueueUnbind Method
queue
exchange
routingKey
arguments

Syntax

C#
public void QueueUnbind(
   string queue,
   string exchange,
   string routingKey,
   IDictionary arguments
)

Parameters

queue
exchange
routingKey
arguments

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TxCommit Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : TxCommit Method

Syntax

C#
public void TxCommit()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TxRollback Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : TxRollback Method

Syntax

C#
public void TxRollback()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TxSelect Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : TxSelect Method

Syntax

C#
public void TxSelect()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachedModel Class

For a list of all members of this type, see CachedModel members.

Public Properties

 | Name | Description
Public Property | CloseReason |
Public Property | IsOpen |
Public Property | TargetModel | Gets the target, for testing purposes.
Top

See Also

Reference

CachedModel Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseReason Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CloseReason Property

Syntax

C#
public ShutdownEventArgs CloseReason {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsOpen Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : IsOpen Property

Syntax

C#
public bool IsOpen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TargetModel Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : TargetModel Property
Gets the target, for testing purposes.

Syntax

C#
public IModel TargetModel {get;}

Return Value

The target.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%% $$Events$$

[image]
Spring.Messaging.Amqp.Rabbit
CachedModel Class Events
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachedModel Class

For a list of all members of this type, see CachedModel members.

Public Events

 | Name | Description
Public Event | BasicReturn |
Public Event | CallbackException |
Public Event | ModelShutdown |
Top

See Also

Reference

CachedModel Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicReturn Event
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : BasicReturn Event

Syntax

C#
public event BasicReturnEventHandler BasicReturn()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CallbackException Event
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : CallbackException Event

Syntax

C#
public event CallbackExceptionEventHandler CallbackException()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ModelShutdown Event
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachedModel Class : ModelShutdown Event

Syntax

C#
public event ModelShutdownEventHandler ModelShutdown()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachedModel Class
CachedModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachingConnectionFactory Class
A IConnectionFactory implementation that returns the same Connection from all IConnectionFactory.CreateConnection calls, and ignores call to Close

Syntax

C#
public class CachingConnectionFactory : SingleConnectionFactory, IConnectionFactory, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.SingleConnectionFactory
Spring.Messaging.Amqp.Rabbit.Connection.CachingConnectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachingConnectionFactory Class

The following tables list the members exposed by CachingConnectionFactory.

Public Constructors

 | Name | Description
Public Constructor | CachingConnectionFactory Constructor | Overloaded. Initializes a new instance of the Object class.
Top

Public Properties

 | Name | Description
Public Property | Active |
Public Property | ChannelCacheSize |
Public Property | HostName | (Inherited from SingleConnectionFactory)
Public Property | RabbitConnectionFactory | (Inherited from SingleConnectionFactory)
Public Property | VirtualHost | (Inherited from SingleConnectionFactory)
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from SingleConnectionFactory)
Public Method | CreateConnection | (Inherited from SingleConnectionFactory)
Public Method | Dispose | Close the underlying shared connection. (Inherited from SingleConnectionFactory)
Public Method | GetChannel | Overridden.
Public Method | InitConnection | Initialize the underlying shared Connection. Closes and reinitializes the Connection if an underlying Connection is present already. (Inherited from SingleConnectionFactory)
Public Method | ResetConnection | Overridden.
Public Method | ToString | (Inherited from SingleConnectionFactory)
Top

Protected Methods

 | Name | Description
Protected Method | CloseConnection | Closes the given connection. (Inherited from SingleConnectionFactory)
Protected Method | CreateChannel | (Inherited from SingleConnectionFactory)
Protected Method | DoCreateConnection | (Inherited from SingleConnectionFactory)
Protected Method | GetCachedModelWrapper | Wraps the given Model so that it delegates every method call to the target model but adapts close calls. This is useful for allowing application code to handle a special framework Model just like an ordinary Model.
Protected Method | GetSharedConnection | Wrap the given Connection with a proxy that delegates every method call to it but suppresses close calls. This is useful for allowing application code to handle a special framework Connection just like an ordinary Connection from a ConnectionFactory. (Inherited from SingleConnectionFactory)
Protected Method | PrepareConnection | (Inherited from SingleConnectionFactory)
Top

See Also

Reference

CachingConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : CachingConnectionFactory Constructor
Initializes a new instance of the Object class.

Overload List

Overload | Description
CachingConnectionFactory Constructor() | Initializes a new instance of the Object class.
CachingConnectionFactory Constructor(ConnectionFactory,String) | Initializes a new instance of the CachingConnectionFactory class.
CachingConnectionFactory Constructor(ConnectionParameters) |
CachingConnectionFactory Constructor(ConnectionParameters,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class > CachingConnectionFactory Constructor : CachingConnectionFactory Constructor()
Initializes a new instance of the Object class.

Syntax

C#
public CachingConnectionFactory()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Constructor(ConnectionFactory,String)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class > CachingConnectionFactory Constructor : CachingConnectionFactory Constructor(ConnectionFactory,String)
connectionFactory
The connection factory.
address
The address.
Initializes a new instance of the CachingConnectionFactory class.

Syntax

C#
public CachingConnectionFactory(
   ConnectionFactory connectionFactory,
   string address
)

Parameters

connectionFactory
The connection factory.
address
The address.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Constructor(ConnectionParameters)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class > CachingConnectionFactory Constructor : CachingConnectionFactory Constructor(ConnectionParameters)
connectionParameters

Syntax

C#
public CachingConnectionFactory(
   ConnectionParameters connectionParameters
)

Parameters

connectionParameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Constructor(ConnectionParameters,String)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class > CachingConnectionFactory Constructor : CachingConnectionFactory Constructor(ConnectionParameters,String)
connectionParameters
address

Syntax

C#
public CachingConnectionFactory(
   ConnectionParameters connectionParameters,
   string address
)

Parameters

connectionParameters
address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachingConnectionFactory Class

For a list of all members of this type, see CachingConnectionFactory members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from SingleConnectionFactory)
Public Method | CreateConnection | (Inherited from SingleConnectionFactory)
Public Method | Dispose | Close the underlying shared connection. (Inherited from SingleConnectionFactory)
Public Method | GetChannel | Overridden.
Public Method | InitConnection | Initialize the underlying shared Connection. Closes and reinitializes the Connection if an underlying Connection is present already. (Inherited from SingleConnectionFactory)
Public Method | ResetConnection | Overridden.
Public Method | ToString | (Inherited from SingleConnectionFactory)
Top

Protected Methods

 | Name | Description
Protected Method | CloseConnection | Closes the given connection. (Inherited from SingleConnectionFactory)
Protected Method | CreateChannel | (Inherited from SingleConnectionFactory)
Protected Method | DoCreateConnection | (Inherited from SingleConnectionFactory)
Protected Method | GetCachedModelWrapper | Wraps the given Model so that it delegates every method call to the target model but adapts close calls. This is useful for allowing application code to handle a special framework Model just like an ordinary Model.
Protected Method | GetSharedConnection | Wrap the given Connection with a proxy that delegates every method call to it but suppresses close calls. This is useful for allowing application code to handle a special framework Connection just like an ordinary Connection from a ConnectionFactory. (Inherited from SingleConnectionFactory)
Protected Method | PrepareConnection | (Inherited from SingleConnectionFactory)
Top

See Also

Reference

CachingConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetCachedModelWrapper Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : GetCachedModelWrapper Method
targetModel
The original Model to wrap.
modelList
The List of cached Model that the given Model belongs to.
Wraps the given Model so that it delegates every method call to the target model but adapts close calls. This is useful for allowing application code to handle a special framework Model just like an ordinary Model.

Syntax

C#
protected virtual IModel GetCachedModelWrapper(
   IModel targetModel,
   LinkedList<IModel> modelList
)

Parameters

targetModel
The original Model to wrap.
modelList
The List of cached Model that the given Model belongs to.

Return Value

The wrapped Model

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : GetChannel Method
connection

Syntax

C#
public override IModel GetChannel(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ResetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : ResetConnection Method

Syntax

C#
public override void ResetConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
CachingConnectionFactory Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CachingConnectionFactory Class

For a list of all members of this type, see CachingConnectionFactory members.

Public Properties

 | Name | Description
Public Property | Active |
Public Property | ChannelCacheSize |
Public Property | HostName | (Inherited from SingleConnectionFactory)
Public Property | RabbitConnectionFactory | (Inherited from SingleConnectionFactory)
Public Property | VirtualHost | (Inherited from SingleConnectionFactory)
Top

See Also

Reference

CachingConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Active Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : Active Property

Syntax

C#
public bool Active {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ChannelCacheSize Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CachingConnectionFactory Class : ChannelCacheSize Property

Syntax

C#
public int ChannelCacheSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CachingConnectionFactory Class
CachingConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CloseSuppressingConnection Class

Syntax

C#
public class CloseSuppressingConnection : IConnection, IDecoratorConnection

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.CloseSuppressingConnection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Class Members
See Also Properties Methods Events Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CloseSuppressingConnection Class

The following tables list the members exposed by CloseSuppressingConnection.

Public Constructors

 | Name | Description
Public Constructor | CloseSuppressingConnection Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoClose |
Public Property | ChannelMax |
Public Property | CloseReason |
Public Property | Endpoint |
Public Property | FrameMax |
Public Property | Heartbeat |
Public Property | IsOpen |
Public Property | KnownHosts |
Public Property | Parameters |
Public Property | Protocol |
Public Property | ShutdownReport |
Public Property | TargetConnection |
Top

Public Methods

 | Name | Description
Public Method | Abort | Overloaded.
Public Method | Close | Overloaded.
Public Method | CreateModel |
Public Method | Dispose |
Top

Public Events

 | Name | Description
Public Event | CallbackException |
Public Event | ConnectionShutdown |
Top

See Also

Reference

CloseSuppressingConnection Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : CloseSuppressingConnection Constructor
factory
connection

Syntax

C#
public CloseSuppressingConnection(
   SingleConnectionFactory factory,
   IConnection connection
)

Parameters

factory
connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CloseSuppressingConnection Class

For a list of all members of this type, see CloseSuppressingConnection members.

Public Methods

 | Name | Description
Public Method | Abort | Overloaded.
Public Method | Close | Overloaded.
Public Method | CreateModel |
Public Method | Dispose |
Top

See Also

Reference

CloseSuppressingConnection Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Abort Method

Overload List

Overload | Description
Abort() |
Abort(UInt16,String) |
Abort(Int32) |
Abort(UInt16,String,Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Abort Method : Abort() Method

Syntax

C#
public void Abort()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort(UInt16,String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Abort Method : Abort(UInt16,String) Method
reasonCode
reasonText

Syntax

C#
public void Abort(
   ushort reasonCode,
   string reasonText
)

Parameters

reasonCode
reasonText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort(Int32) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Abort Method : Abort(Int32) Method
timeout

Syntax

C#
public void Abort(
   int timeout
)

Parameters

timeout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Abort(UInt16,String,Int32) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Abort Method : Abort(UInt16,String,Int32) Method
reasonCode
reasonText
timeout

Syntax

C#
public void Abort(
   ushort reasonCode,
   string reasonText,
   int timeout
)

Parameters

reasonCode
reasonText
timeout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Close Method

Overload List

Overload | Description
Close() |
Close(UInt16,String) |
Close(Int32) |
Close(UInt16,String,Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Close Method : Close() Method

Syntax

C#
public void Close()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close(UInt16,String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Close Method : Close(UInt16,String) Method
reasonCode
reasonText

Syntax

C#
public void Close(
   ushort reasonCode,
   string reasonText
)

Parameters

reasonCode
reasonText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close(Int32) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Close Method : Close(Int32) Method
timeout

Syntax

C#
public void Close(
   int timeout
)

Parameters

timeout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Close(UInt16,String,Int32) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class > Close Method : Close(UInt16,String,Int32) Method
reasonCode
reasonText
timeout

Syntax

C#
public void Close(
   ushort reasonCode,
   string reasonText,
   int timeout
)

Parameters

reasonCode
reasonText
timeout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateModel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : CreateModel Method

Syntax

C#
public IModel CreateModel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Dispose Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Dispose Method

Syntax

C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CloseSuppressingConnection Class

For a list of all members of this type, see CloseSuppressingConnection members.

Public Properties

 | Name | Description
Public Property | AutoClose |
Public Property | ChannelMax |
Public Property | CloseReason |
Public Property | Endpoint |
Public Property | FrameMax |
Public Property | Heartbeat |
Public Property | IsOpen |
Public Property | KnownHosts |
Public Property | Parameters |
Public Property | Protocol |
Public Property | ShutdownReport |
Public Property | TargetConnection |
Top

See Also

Reference

CloseSuppressingConnection Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AutoClose Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : AutoClose Property

Syntax

C#
public bool AutoClose {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ChannelMax Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : ChannelMax Property

Syntax

C#
public ushort ChannelMax {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseReason Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : CloseReason Property

Syntax

C#
public ShutdownEventArgs CloseReason {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Endpoint Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Endpoint Property

Syntax

C#
public AmqpTcpEndpoint Endpoint {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
FrameMax Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : FrameMax Property

Syntax

C#
public uint FrameMax {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Heartbeat Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Heartbeat Property

Syntax

C#
public ushort Heartbeat {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsOpen Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : IsOpen Property

Syntax

C#
public bool IsOpen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
KnownHosts Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : KnownHosts Property

Syntax

C#
public AmqpTcpEndpoint[] KnownHosts {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Parameters Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Parameters Property

Syntax

C#
public ConnectionParameters Parameters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Protocol Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : Protocol Property

Syntax

C#
public IProtocol Protocol {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ShutdownReport Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : ShutdownReport Property

Syntax

C#
public IList ShutdownReport {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TargetConnection Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : TargetConnection Property

Syntax

C#
public IConnection TargetConnection {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%% $$Events$$

[image]
Spring.Messaging.Amqp.Rabbit
CloseSuppressingConnection Class Events
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : CloseSuppressingConnection Class

For a list of all members of this type, see CloseSuppressingConnection members.

Public Events

 | Name | Description
Public Event | CallbackException |
Public Event | ConnectionShutdown |
Top

See Also

Reference

CloseSuppressingConnection Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CallbackException Event
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : CallbackException Event

Syntax

C#
public event CallbackExceptionEventHandler CallbackException()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionShutdown Event
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > CloseSuppressingConnection Class : ConnectionShutdown Event

Syntax

C#
public event ConnectionShutdownEventHandler ConnectionShutdown()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CloseSuppressingConnection Class
CloseSuppressingConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactoryUtils Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : ConnectionFactoryUtils Class

Syntax

C#
public class ConnectionFactoryUtils

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.ConnectionFactoryUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactoryUtils Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : ConnectionFactoryUtils Class

The following tables list the members exposed by ConnectionFactoryUtils.

Public Constructors

 | Name | Description
Public Constructor | ConnectionFactoryUtils Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoGetTransactionalChannel |
static (Shared in Visual Basic) | GetTargetConnection | Return the innermost target IConnection of the given IConnection. If the given IConnection is a decorated connection, it will be unwrapped until a non-decorated IConnection is found. Otherwise, the passed-in IConnection will be returned as-is.
static (Shared in Visual Basic) | GetTargetModel | Return the innermost target IModel of the given IModel. If the given IModel is a decorated model, it will be unwrapped until a non-decorated IModel is found. Otherwise, the passed-in IModel will be returned as-is.
static (Shared in Visual Basic) | GetTransactionalChannel |
static (Shared in Visual Basic) | IsChannelTransactional |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ConnectionFactoryUtils Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactoryUtils Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : ConnectionFactoryUtils Constructor

Syntax

C#
public ConnectionFactoryUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactoryUtils Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : ConnectionFactoryUtils Class

For a list of all members of this type, see ConnectionFactoryUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoGetTransactionalChannel |
static (Shared in Visual Basic) | GetTargetConnection | Return the innermost target IConnection of the given IConnection. If the given IConnection is a decorated connection, it will be unwrapped until a non-decorated IConnection is found. Otherwise, the passed-in IConnection will be returned as-is.
static (Shared in Visual Basic) | GetTargetModel | Return the innermost target IModel of the given IModel. If the given IModel is a decorated model, it will be unwrapped until a non-decorated IModel is found. Otherwise, the passed-in IModel will be returned as-is.
static (Shared in Visual Basic) | GetTransactionalChannel |
static (Shared in Visual Basic) | IsChannelTransactional |
static (Shared in Visual Basic) | ReleaseConnection |
Top

See Also

Reference

ConnectionFactoryUtils Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoGetTransactionalChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : DoGetTransactionalChannel Method
connectionFactory
resourceFactory

Syntax

C#
public static IModel DoGetTransactionalChannel(
   IConnectionFactory connectionFactory,
   IResourceFactory resourceFactory
)

Parameters

connectionFactory
resourceFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetTargetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : GetTargetConnection Method
connection
Return the innermost target IConnection of the given IConnection. If the given IConnection is a decorated connection, it will be unwrapped until a non-decorated IConnection is found. Otherwise, the passed-in IConnection will be returned as-is.

Syntax

C#
public static IConnection GetTargetConnection(
   IConnection connection
)

Parameters

connection

Return Value

The innermost target IConnection, or the passed-in one if no decorator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetTargetModel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : GetTargetModel Method
model
The model to unwrap
Return the innermost target IModel of the given IModel. If the given IModel is a decorated model, it will be unwrapped until a non-decorated IModel is found. Otherwise, the passed-in IModel will be returned as-is.

Syntax

C#
public static IModel GetTargetModel(
   IModel model
)

Parameters

model
The model to unwrap

Return Value

The innermost target IModel, or the passed-in one if no decorator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetTransactionalChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : GetTransactionalChannel Method
cf
existingCon
synchedLocalTransactionAllowed

Syntax

C#
public static IModel GetTransactionalChannel(
   IConnectionFactory cf,
   IConnection existingCon,
   bool synchedLocalTransactionAllowed
)

Parameters

cf
existingCon
synchedLocalTransactionAllowed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsChannelTransactional Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : IsChannelTransactional Method
channel
connectionFactory

Syntax

C#
public static bool IsChannelTransactional(
   IModel channel,
   IConnectionFactory connectionFactory
)

Parameters

channel
connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReleaseConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > ConnectionFactoryUtils Class : ReleaseConnection Method
connection
connectionFactory

Syntax

C#
public static void ReleaseConnection(
   IConnection connection,
   IConnectionFactory connectionFactory
)

Parameters

connection
connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConnectionFactoryUtils Class
ConnectionFactoryUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : RabbitResourceHolder Class

Syntax

C#
public class RabbitResourceHolder : ResourceHolderSupport

Inheritance Hierarchy

System.Object
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder
Spring.Messaging.Amqp.Rabbit.Listener.LocallyExposedRabbitResourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : RabbitResourceHolder Class

The following tables list the members exposed by RabbitResourceHolder.

Public Constructors

 | Name | Description
Public Constructor | RabbitResourceHolder Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Channel |
Public Property | Connection |
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen |
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded.
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll |
Public Method | CommitAll |
Public Method | ContainsChannel |
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

RabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : RabbitResourceHolder Constructor

Overload List

Overload | Description
RabbitResourceHolder Constructor() |
RabbitResourceHolder Constructor(IConnection,IModel) |
RabbitResourceHolder Constructor(IConnectionFactory) |
RabbitResourceHolder Constructor(IConnectionFactory,IConnection,IModel) |
RabbitResourceHolder Constructor(IModel) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > RabbitResourceHolder Constructor : RabbitResourceHolder Constructor()

Syntax

C#
public RabbitResourceHolder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor(IConnection,IModel)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > RabbitResourceHolder Constructor : RabbitResourceHolder Constructor(IConnection,IModel)
connection
channel

Syntax

C#
public RabbitResourceHolder(
   IConnection connection,
   IModel channel
)

Parameters

connection
channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor(IConnectionFactory)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > RabbitResourceHolder Constructor : RabbitResourceHolder Constructor(IConnectionFactory)
connectionFactory

Syntax

C#
public RabbitResourceHolder(
   IConnectionFactory connectionFactory
)

Parameters

connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor(IConnectionFactory,IConnection,IModel)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > RabbitResourceHolder Constructor : RabbitResourceHolder Constructor(IConnectionFactory,IConnection,IModel)
connectionFactory
connection
channel

Syntax

C#
public RabbitResourceHolder(
   IConnectionFactory connectionFactory,
   IConnection connection,
   IModel channel
)

Parameters

connectionFactory
connection
channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Constructor(IModel)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > RabbitResourceHolder Constructor : RabbitResourceHolder Constructor(IModel)
channel

Syntax

C#
public RabbitResourceHolder(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : RabbitResourceHolder Class

For a list of all members of this type, see RabbitResourceHolder members.

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded.
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll |
Public Method | CommitAll |
Public Method | ContainsChannel |
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

RabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AddChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : AddChannel Method

Overload List

Overload | Description
AddChannel(IModel) |
AddChannel(IModel,IConnection) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AddChannel(IModel) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > AddChannel Method : AddChannel(IModel) Method
channel

Syntax

C#
public void AddChannel(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AddChannel(IModel,IConnection) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class > AddChannel Method : AddChannel(IModel,IConnection) Method
channel
connection

Syntax

C#
public void AddChannel(
   IModel channel,
   IConnection connection
)

Parameters

channel
connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseAll Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : CloseAll Method

Syntax

C#
public void CloseAll()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CommitAll Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : CommitAll Method

Syntax

C#
public void CommitAll()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ContainsChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : ContainsChannel Method
channel

Syntax

C#
public bool ContainsChannel(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitResourceHolder Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : RabbitResourceHolder Class

For a list of all members of this type, see RabbitResourceHolder members.

Public Properties

 | Name | Description
Public Property | Channel |
Public Property | Connection |
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen |
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

RabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Channel Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Channel Property

Syntax

C#
public IModel Channel {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Connection Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Connection Property

Syntax

C#
public IConnection Connection {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Frozen Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Frozen Property

Syntax

C#
public bool Frozen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : SingleConnectionFactory Class
A IConnectionFactory implementation that returns the same Connection from all IConnectionFactory.CreateConnection calls, and ignores call to Close

Syntax

C#
public class SingleConnectionFactory : IConnectionFactory, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.SingleConnectionFactory
Spring.Messaging.Amqp.Rabbit.Connection.CachingConnectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : SingleConnectionFactory Class

The following tables list the members exposed by SingleConnectionFactory.

Public Constructors

 | Name | Description
Public Constructor | SingleConnectionFactory Constructor | Overloaded. Initializes a new instance of the CachingConnectionFactory class.
Top

Public Properties

 | Name | Description
Public Property | HostName |
Public Property | RabbitConnectionFactory |
Public Property | VirtualHost |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | CreateConnection |
Public Method | Dispose | Close the underlying shared connection.
Public Method | GetChannel |
Public Method | InitConnection | Initialize the underlying shared Connection. Closes and reinitializes the Connection if an underlying Connection is present already.
Public Method | ResetConnection |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloseConnection | Closes the given connection.
Protected Method | CreateChannel |
Protected Method | DoCreateConnection |
Protected Method | GetSharedConnection | Wrap the given Connection with a proxy that delegates every method call to it but suppresses close calls. This is useful for allowing application code to handle a special framework Connection just like an ordinary Connection from a ConnectionFactory.
Protected Method | PrepareConnection |
Top

See Also

Reference

SingleConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : SingleConnectionFactory Constructor
Initializes a new instance of the CachingConnectionFactory class.

Overload List

Overload | Description
SingleConnectionFactory Constructor() |
SingleConnectionFactory Constructor(ConnectionFactory,String) | Initializes a new instance of the CachingConnectionFactory class.
SingleConnectionFactory Constructor(ConnectionParameters) |
SingleConnectionFactory Constructor(ConnectionParameters,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class > SingleConnectionFactory Constructor : SingleConnectionFactory Constructor()

Syntax

C#
public SingleConnectionFactory()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Constructor(ConnectionFactory,String)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class > SingleConnectionFactory Constructor : SingleConnectionFactory Constructor(ConnectionFactory,String)
connectionFactory
The connection factory.
hostName
The hostName.
Initializes a new instance of the CachingConnectionFactory class.

Syntax

C#
public SingleConnectionFactory(
   ConnectionFactory connectionFactory,
   string hostName
)

Parameters

connectionFactory
The connection factory.
hostName
The hostName.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Constructor(ConnectionParameters)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class > SingleConnectionFactory Constructor : SingleConnectionFactory Constructor(ConnectionParameters)
connectionParameters

Syntax

C#
public SingleConnectionFactory(
   ConnectionParameters connectionParameters
)

Parameters

connectionParameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Constructor(ConnectionParameters,String)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class > SingleConnectionFactory Constructor : SingleConnectionFactory Constructor(ConnectionParameters,String)
connectionParameters
address

Syntax

C#
public SingleConnectionFactory(
   ConnectionParameters connectionParameters,
   string address
)

Parameters

connectionParameters
address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : SingleConnectionFactory Class

For a list of all members of this type, see SingleConnectionFactory members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | CreateConnection |
Public Method | Dispose | Close the underlying shared connection.
Public Method | GetChannel |
Public Method | InitConnection | Initialize the underlying shared Connection. Closes and reinitializes the Connection if an underlying Connection is present already.
Public Method | ResetConnection |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloseConnection | Closes the given connection.
Protected Method | CreateChannel |
Protected Method | DoCreateConnection |
Protected Method | GetSharedConnection | Wrap the given Connection with a proxy that delegates every method call to it but suppresses close calls. This is useful for allowing application code to handle a special framework Connection just like an ordinary Connection from a ConnectionFactory.
Protected Method | PrepareConnection |
Top

See Also

Reference

SingleConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : AfterPropertiesSet Method

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : CloseConnection Method
con
The connection.
Closes the given connection.

Syntax

C#
protected virtual void CloseConnection(
   IConnection con
)

Parameters

con
The connection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : CreateChannel Method
connection

Syntax

C#
protected virtual IModel CreateChannel(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : CreateConnection Method

Syntax

C#
public IConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Dispose Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : Dispose Method
Close the underlying shared connection.

Syntax

C#
public void Dispose()

Remarks

The provider of this ConnectionFactory needs to care for proper shutdown. As this bean implements IDisposable, the application context will automatically invoke this on destruction of its cached singletons.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoCreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : DoCreateConnection Method

Syntax

C#
protected virtual IConnection DoCreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : GetChannel Method
connection

Syntax

C#
public virtual IModel GetChannel(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetSharedConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : GetSharedConnection Method
target
The original connection to wrap.
Wrap the given Connection with a proxy that delegates every method call to it but suppresses close calls. This is useful for allowing application code to handle a special framework Connection just like an ordinary Connection from a ConnectionFactory.

Syntax

C#
protected virtual IConnection GetSharedConnection(
   IConnection target
)

Parameters

target
The original connection to wrap.

Return Value

the wrapped connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InitConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : InitConnection Method
Initialize the underlying shared Connection. Closes and reinitializes the Connection if an underlying Connection is present already.

Syntax

C#
public void InitConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PrepareConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : PrepareConnection Method
connection

Syntax

C#
protected virtual void PrepareConnection(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ResetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : ResetConnection Method

Syntax

C#
public virtual void ResetConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ToString Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : ToString Method

Syntax

C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
SingleConnectionFactory Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : SingleConnectionFactory Class

For a list of all members of this type, see SingleConnectionFactory members.

Public Properties

 | Name | Description
Public Property | HostName |
Public Property | RabbitConnectionFactory |
Public Property | VirtualHost |
Top

See Also

Reference

SingleConnectionFactory Class
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HostName Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : HostName Property

Syntax

C#
public string HostName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitConnectionFactory Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : RabbitConnectionFactory Property

Syntax

C#
public ConnectionFactory RabbitConnectionFactory {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
VirtualHost Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > SingleConnectionFactory Class : VirtualHost Property

Syntax

C#
public string VirtualHost {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SingleConnectionFactory Class
SingleConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IConnectionFactory Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IConnectionFactory Interface
An interface based ConnectionFactory for creating IConnections.

Syntax

C#
public interface IConnectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IConnectionFactory Interface Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IConnectionFactory Interface

The following tables list the members exposed by IConnectionFactory.

Public Properties

 | Name | Description
Property | HostName |
Property | VirtualHost |
Top

Public Methods

 | Name | Description
Method | CreateConnection |
Top

See Also

Reference

IConnectionFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
IConnectionFactory Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IConnectionFactory Interface

For a list of all members of this type, see IConnectionFactory members.

Public Methods

 | Name | Description
Method | CreateConnection |
Top

See Also

Reference

IConnectionFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IConnectionFactory Interface : CreateConnection Method

Syntax

C#
IConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Interface
IConnectionFactory Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
IConnectionFactory Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IConnectionFactory Interface

For a list of all members of this type, see IConnectionFactory members.

Public Properties

 | Name | Description
Property | HostName |
Property | VirtualHost |
Top

See Also

Reference

IConnectionFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HostName Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IConnectionFactory Interface : HostName Property

Syntax

C#
string HostName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Interface
IConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
VirtualHost Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IConnectionFactory Interface : VirtualHost Property

Syntax

C#
string VirtualHost {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IConnectionFactory Interface
IConnectionFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorConnection Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorConnection Interface
Subinterface of Connection to be implemented by implementations that wrap an Connection to provide added functionality. Allows access to the the underlying target Connection.

Syntax

C#
public interface IDecoratorConnection : IConnection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDecoratorConnection Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorConnection Interface Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorConnection Interface

The following tables list the members exposed by IDecoratorConnection.

Public Properties

 | Name | Description
Property | TargetConnection | Gets the target connection of the decorator. This will typically be the native provider IConnection or a wrapper from a model pool.
Top

See Also

Reference

IDecoratorConnection Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorConnection Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorConnection Interface

For a list of all members of this type, see IDecoratorConnection members.

Public Properties

 | Name | Description
Property | TargetConnection | Gets the target connection of the decorator. This will typically be the native provider IConnection or a wrapper from a model pool.
Top

See Also

Reference

IDecoratorConnection Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TargetConnection Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IDecoratorConnection Interface : TargetConnection Property
Gets the target connection of the decorator. This will typically be the native provider IConnection or a wrapper from a model pool.

Syntax

C#
IConnection TargetConnection {get;}

Return Value

The underlying connection, never null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDecoratorConnection Interface
IDecoratorConnection Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorModel Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorModel Interface
Subinterface of Model to be implemented by implementations that wrap a Model to provide added functionality. Allows access to the the underlying target Model.

Syntax

C#
public interface IDecoratorModel : IModel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDecoratorModel Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorModel Interface Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorModel Interface

The following tables list the members exposed by IDecoratorModel.

Public Properties

 | Name | Description
Property | TargetModel | Gets the target model of the decorator. This will typically be the native provider IModel or a wrapper from a model pool.
Top

See Also

Reference

IDecoratorModel Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
IDecoratorModel Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IDecoratorModel Interface

For a list of all members of this type, see IDecoratorModel members.

Public Properties

 | Name | Description
Property | TargetModel | Gets the target model of the decorator. This will typically be the native provider IModel or a wrapper from a model pool.
Top

See Also

Reference

IDecoratorModel Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TargetModel Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IDecoratorModel Interface : TargetModel Property
Gets the target model of the decorator. This will typically be the native provider IModel or a wrapper from a model pool.

Syntax

C#
IModel TargetModel {get;}

Return Value

The underlying model, never null

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDecoratorModel Interface
IDecoratorModel Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IResourceFactory Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IResourceFactory Interface

Syntax

C#
public interface IResourceFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Members
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IResourceFactory Interface Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IResourceFactory Interface

The following tables list the members exposed by IResourceFactory.

Public Properties

 | Name | Description
Property | IsSynchedLocalTransactionAllowed |
Top

Public Methods

 | Name | Description
Method | CreateChannel |
Method | CreateConnection |
Method | GetChannel |
Method | GetConnection |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
IResourceFactory Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IResourceFactory Interface

For a list of all members of this type, see IResourceFactory members.

Public Methods

 | Name | Description
Method | CreateChannel |
Method | CreateConnection |
Method | GetChannel |
Method | GetConnection |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IResourceFactory Interface : CreateChannel Method
connection

Syntax

C#
IModel CreateChannel(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IResourceFactory Interface : CreateConnection Method

Syntax

C#
IConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IResourceFactory Interface : GetChannel Method
holder

Syntax

C#
IModel GetChannel(
   RabbitResourceHolder holder
)

Parameters

holder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IResourceFactory Interface : GetConnection Method
rabbitResourceHolder

Syntax

C#
IConnection GetConnection(
   RabbitResourceHolder rabbitResourceHolder
)

Parameters

rabbitResourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
IResourceFactory Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace : IResourceFactory Interface

For a list of all members of this type, see IResourceFactory members.

Public Properties

 | Name | Description
Property | IsSynchedLocalTransactionAllowed |
Top

See Also

Reference

IResourceFactory Interface
Spring.Messaging.Amqp.Rabbit.Connection Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsSynchedLocalTransactionAllowed Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > IResourceFactory Interface : IsSynchedLocalTransactionAllowed Property

Syntax

C#
bool IsSynchedLocalTransactionAllowed {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResourceFactory Interface
IResourceFactory Members


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Core Namespace
See Also Inheritance Hierarchy Send Feedback
Core package of the RabbitMQ support.

Classes

 | Class | Description
Class | MessageProperties | Rabbit implementation that stores much of the message property information in Rabbit's IBasicProperties class. Also contains static strings for various content types.
Class | RabbitAccessor |
Class | RabbitAdmin | RabbitMQ implementation of portable AMQP administrative operations for AMQP >= 0.8
Class | RabbitMessagePropertiesFactory | Simple implementation of Spring.Messaging.Amqp.Core.IMessagePropertiesFactory interface.
Class | RabbitTemplate | Helper class that simplifies synchronous RabbitMQ access code.

Interfaces

 | Interface | Description
Interface | IChannelAwareMessageListener |
Interface | Generic IChannelCallback |
Interface | IRabbitOperations | Rabbit specific methods for AMQP functionality.

Delegates

 | Delegate | Description
Delegate | Generic ChannelCallbackDelegate |
Delegate | MessageCreatorDelegate | Strategy interface for creating AMQP messages.

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : MessageProperties Class
Rabbit implementation that stores much of the message property information in Rabbit's IBasicProperties class. Also contains static strings for various content types.

Syntax

C#
public class MessageProperties : IMessageProperties

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.MessageProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Class Members
See Also Fields Properties Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : MessageProperties Class

The following tables list the members exposed by MessageProperties.

Public Constructors

 | Name | Description
Public Constructor | MessageProperties Constructor | Overloaded. Initializes a new instance of the Object class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | BasicProperties |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | Priority |
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : MessageProperties Constructor
Initializes a new instance of the Object class.

Overload List

Overload | Description
MessageProperties Constructor(IBasicProperties) | Initializes a new instance of the Object class.
MessageProperties Constructor(IBasicProperties,String,String,Boolean,UInt64,UInt32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Constructor(IBasicProperties)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class > MessageProperties Constructor : MessageProperties Constructor(IBasicProperties)
basicProperties
Initializes a new instance of the Object class.

Syntax

C#
public MessageProperties(
   IBasicProperties basicProperties
)

Parameters

basicProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Constructor(IBasicProperties,String,String,Boolean,UInt64,UInt32)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class > MessageProperties Constructor : MessageProperties Constructor(IBasicProperties,String,String,Boolean,UInt64,UInt32)
basicProperties
receivedExchange
receivedRoutingKey
redelivered
deliveryTag
messageCount

Syntax

C#
public MessageProperties(
   IBasicProperties basicProperties,
   string receivedExchange,
   string receivedRoutingKey,
   bool redelivered,
   ulong deliveryTag,
   uint messageCount
)

Parameters

basicProperties
receivedExchange
receivedRoutingKey
redelivered
deliveryTag
messageCount

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Properties

 | Name | Description
Public Property | AppId |
Public Property | BasicProperties |
Public Property | ClusterId |
Public Property | ContentEncoding |
Public Property | ContentLength |
Public Property | ContentType |
Public Property | CorrelationId |
Public Property | DeliveryMode |
Public Property | DeliveryTag |
Public Property | Expiration |
Public Property | Headers |
Public Property | MessageCount |
Public Property | MessageId |
Public Property | Priority |
Public Property | ReceivedExchange |
Public Property | ReceivedRoutingKey |
Public Property | Redelivered |
Public Property | ReplyTo |
Public Property | Timestamp |
Public Property | Type |
Public Property | UserId |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AppId Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : AppId Property

Syntax

C#
public string AppId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BasicProperties Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : BasicProperties Property

Syntax

C#
public IBasicProperties BasicProperties {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ClusterId Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ClusterId Property

Syntax

C#
public string ClusterId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ContentEncoding Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ContentEncoding Property

Syntax

C#
public string ContentEncoding {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ContentLength Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ContentLength Property

Syntax

C#
public long ContentLength {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ContentType Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ContentType Property

Syntax

C#
public string ContentType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CorrelationId Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : CorrelationId Property

Syntax

C#
public byte[] CorrelationId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeliveryMode Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : DeliveryMode Property

Syntax

C#
public MessageDeliveryMode DeliveryMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeliveryTag Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : DeliveryTag Property

Syntax

C#
public ulong DeliveryTag {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Expiration Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Expiration Property

Syntax

C#
public string Expiration {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Headers Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Headers Property

Syntax

C#
public IDictionary<string, object> Headers {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageCount Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : MessageCount Property

Syntax

C#
public uint MessageCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageId Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : MessageId Property

Syntax

C#
public string MessageId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Priority Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Priority Property

Syntax

C#
public int Priority {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReceivedExchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ReceivedExchange Property

Syntax

C#
public string ReceivedExchange {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReceivedRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ReceivedRoutingKey Property

Syntax

C#
public string ReceivedRoutingKey {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Redelivered Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Redelivered Property

Syntax

C#
public bool Redelivered {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReplyTo Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : ReplyTo Property

Syntax

C#
public string ReplyTo {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Timestamp Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Timestamp Property

Syntax

C#
public long Timestamp {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Type Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : Type Property

Syntax

C#
public string Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
UserId Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : UserId Property

Syntax

C#
public string UserId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageProperties Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : MessageProperties Class

For a list of all members of this type, see MessageProperties members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CONTENT_TYPE_BYTES |
static (Shared in Visual Basic) | CONTENT_TYPE_JSON |
static (Shared in Visual Basic) | CONTENT_TYPE_SERIALIZED_OBJECT |
static (Shared in Visual Basic) | CONTENT_TYPE_TEXT_PLAIN |
Top

See Also

Reference

MessageProperties Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CONTENT_TYPE_BYTES Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : CONTENT_TYPE_BYTES Field

Syntax

C#
public static readonly string CONTENT_TYPE_BYTES

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CONTENT_TYPE_JSON Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : CONTENT_TYPE_JSON Field

Syntax

C#
public static readonly string CONTENT_TYPE_JSON

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CONTENT_TYPE_SERIALIZED_OBJECT Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : CONTENT_TYPE_SERIALIZED_OBJECT Field

Syntax

C#
public static readonly string CONTENT_TYPE_SERIALIZED_OBJECT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CONTENT_TYPE_TEXT_PLAIN Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > MessageProperties Class : CONTENT_TYPE_TEXT_PLAIN Field

Syntax

C#
public static readonly string CONTENT_TYPE_TEXT_PLAIN

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageProperties Class
MessageProperties Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAccessor Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAccessor Class

Object Model

Syntax

C#
public class RabbitAccessor : IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate
Spring.Messaging.Amqp.Rabbit.Listener.AbstractRabbitListeningContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAccessor Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAccessor Class

The following tables list the members exposed by RabbitAccessor.

Public Constructors

 | Name | Description
Public Constructor | RabbitAccessor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChannelTransacted |
Public Property | ConnectionFactory |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel |
Protected Method | CreateConnection |
Top

See Also

Reference

RabbitAccessor Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAccessor Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : RabbitAccessor Constructor

Syntax

C#
public RabbitAccessor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAccessor Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAccessor Class

For a list of all members of this type, see RabbitAccessor members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel |
Protected Method | CreateConnection |
Top

See Also

Reference

RabbitAccessor Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : AfterPropertiesSet Method

Syntax

C#
public virtual void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : CreateChannel Method
connection

Syntax

C#
protected IModel CreateChannel(
   IConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : CreateConnection Method

Syntax

C#
protected IConnection CreateConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAccessor Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAccessor Class

For a list of all members of this type, see RabbitAccessor members.

Public Properties

 | Name | Description
Public Property | ChannelTransacted |
Public Property | ConnectionFactory |
Top

See Also

Reference

RabbitAccessor Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ChannelTransacted Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : ChannelTransacted Property

Syntax

C#
public bool ChannelTransacted {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactory Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAccessor Class : ConnectionFactory Property

Syntax

C#
public IConnectionFactory ConnectionFactory {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAccessor Class
RabbitAccessor Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAdmin Class
RabbitMQ implementation of portable AMQP administrative operations for AMQP >= 0.8

Object Model

Syntax

C#
public class RabbitAdmin : IAmqpAdmin, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAdmin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAdmin Class

The following tables list the members exposed by RabbitAdmin.

Public Constructors

 | Name | Description
Public Constructor | RabbitAdmin Constructor | Overloaded. Initializes a new instance of the RabbitAdmin class.
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

Public Properties

 | Name | Description
Public Property | RabbitTemplate |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | DeclareBinding |
Public Method | DeclareExchange | Declares the exchange.
Public Method | DeclareQueue | Declares the queue.
Public Method | DeleteExchange | Deletes the exchange.
Public Method | DeleteQueue | Overloaded. Deletes the queue, without regard for whether it is in use or has messages on it
Public Method | PurgeQueue | Purges the queue.
Top

See Also

Reference

RabbitAdmin Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : RabbitAdmin Constructor
Initializes a new instance of the RabbitAdmin class.

Overload List

Overload | Description
RabbitAdmin Constructor() | Initializes a new instance of the RabbitAdmin class.
RabbitAdmin Constructor(RabbitTemplate) | Initializes a new instance of the RabbitAdmin class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class > RabbitAdmin Constructor : RabbitAdmin Constructor()
Initializes a new instance of the RabbitAdmin class.

Syntax

C#
public RabbitAdmin()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Constructor(RabbitTemplate)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class > RabbitAdmin Constructor : RabbitAdmin Constructor(RabbitTemplate)
rabbitTemplate
The rabbit template.
Initializes a new instance of the RabbitAdmin class.

Syntax

C#
public RabbitAdmin(
   RabbitTemplate rabbitTemplate
)

Parameters

rabbitTemplate
The rabbit template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAdmin Class

For a list of all members of this type, see RabbitAdmin members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet |
Public Method | DeclareBinding |
Public Method | DeclareExchange | Declares the exchange.
Public Method | DeclareQueue | Declares the queue.
Public Method | DeleteExchange | Deletes the exchange.
Public Method | DeleteQueue | Overloaded. Deletes the queue, without regard for whether it is in use or has messages on it
Public Method | PurgeQueue | Purges the queue.
Top

See Also

Reference

RabbitAdmin Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : AfterPropertiesSet Method

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeclareBinding Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : DeclareBinding Method
binding

Syntax

C#
public void DeclareBinding(
   Binding binding
)

Parameters

binding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeclareExchange Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : DeclareExchange Method
exchange
The exchange.
Declares the exchange.

Syntax

C#
public void DeclareExchange(
   IExchange exchange
)

Parameters

exchange
The exchange.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeclareQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : DeclareQueue Method
queue
The queue.
Declares the queue.

Syntax

C#
public void DeclareQueue(
   Queue queue
)

Parameters

queue
The queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeleteExchange Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : DeleteExchange Method
exchangeName
Name of the exchange.
Deletes the exchange.

Syntax

C#
public void DeleteExchange(
   string exchangeName
)

Parameters

exchangeName
Name of the exchange.

Remarks

Look at implementation specific subclass for implementation specific behavior, for example for RabbitMQ this will delete the exchange without regard for whether it is in use or not.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeleteQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : DeleteQueue Method
Deletes the queue, without regard for whether it is in use or has messages on it

Overload List

Overload | Description
DeleteQueue(String) | Deletes the queue, without regard for whether it is in use or has messages on it
DeleteQueue(String,Boolean,Boolean) | Deletes the queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeleteQueue(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class > DeleteQueue Method : DeleteQueue(String) Method
queueName
Name of the queue.
Deletes the queue, without regard for whether it is in use or has messages on it

Syntax

C#
public void DeleteQueue(
   string queueName
)

Parameters

queueName
Name of the queue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DeleteQueue(String,Boolean,Boolean) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class > DeleteQueue Method : DeleteQueue(String,Boolean,Boolean) Method
queueName
Name of the queue.
unused
if set to true the queue should be deleted only if not in use.
empty
if set to true the queue should be deleted only if empty.
Deletes the queue.

Syntax

C#
public void DeleteQueue(
   string queueName,
   bool unused,
   bool empty
)

Parameters

queueName
Name of the queue.
unused
if set to true the queue should be deleted only if not in use.
empty
if set to true the queue should be deleted only if empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PurgeQueue Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : PurgeQueue Method
queueName
Name of the queue.
noWait
if set to true [no wait].
Purges the queue.

Syntax

C#
public void PurgeQueue(
   string queueName,
   bool noWait
)

Parameters

queueName
Name of the queue.
noWait
if set to true [no wait].

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAdmin Class

For a list of all members of this type, see RabbitAdmin members.

Public Properties

 | Name | Description
Public Property | RabbitTemplate |
Top

See Also

Reference

RabbitAdmin Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : RabbitTemplate Property

Syntax

C#
public RabbitTemplate RabbitTemplate {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitAdmin Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitAdmin Class

For a list of all members of this type, see RabbitAdmin members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

See Also

Reference

RabbitAdmin Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
logger Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitAdmin Class : logger Field

Syntax

C#
protected static readonly ILog logger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitAdmin Class
RabbitAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitMessagePropertiesFactory Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitMessagePropertiesFactory Class
Simple implementation of Spring.Messaging.Amqp.Core.IMessagePropertiesFactory interface.

Syntax

C#
public class RabbitMessagePropertiesFactory : IMessagePropertiesFactory

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitMessagePropertiesFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitMessagePropertiesFactory Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitMessagePropertiesFactory Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitMessagePropertiesFactory Class

The following tables list the members exposed by RabbitMessagePropertiesFactory.

Public Constructors

 | Name | Description
Public Constructor | RabbitMessagePropertiesFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | Create |
Top

See Also

Reference

RabbitMessagePropertiesFactory Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitMessagePropertiesFactory Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitMessagePropertiesFactory Class : RabbitMessagePropertiesFactory Constructor
model

Syntax

C#
public RabbitMessagePropertiesFactory(
   IModel model
)

Parameters

model

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitMessagePropertiesFactory Class
RabbitMessagePropertiesFactory Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitMessagePropertiesFactory Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitMessagePropertiesFactory Class

For a list of all members of this type, see RabbitMessagePropertiesFactory members.

Public Methods

 | Name | Description
Public Method | Create |
Top

See Also

Reference

RabbitMessagePropertiesFactory Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Create Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitMessagePropertiesFactory Class : Create Method

Syntax

C#
public IMessageProperties Create()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitMessagePropertiesFactory Class
RabbitMessagePropertiesFactory Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitTemplate Class
Helper class that simplifies synchronous RabbitMQ access code.

Object Model

Syntax

C#
public class RabbitTemplate : RabbitAccessor, IAmqpTemplate, IRabbitOperations, IInitializingObject

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitTemplate Class

The following tables list the members exposed by RabbitTemplate.

Public Constructors

 | Name | Description
Public Constructor | RabbitTemplate Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from RabbitAccessor)
Public Property | Exchange |
Public Property | ImmediatePublish |
Public Property | MandatoryPublish |
Public Property | MessageConverter |
Public Property | Queue |
Public Property | RequireAck |
Public Property | RoutingKey |
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from RabbitAccessor)
Public Method | ConvertAndSend | Overloaded.
Public Method | CreateMessageProperties |
Public Method | Execute | Overloaded.
Public Method | Receive | Overloaded.
Public Method | ReceiveAndConvert | Overloaded.
Public Method | Send | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ChannelLocallyTransacted |
Protected Method | CreateChannel | (Inherited from RabbitAccessor)
Protected Method | CreateConnection | (Inherited from RabbitAccessor)
Protected Method | DoCreateMessageProperties |
Protected Method | DoSend |
Protected Method | GetChannel |
Protected Method | GetConnection |
Protected Method | InitDefaultStrategies |
Top

See Also

Reference

RabbitTemplate Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : RabbitTemplate Constructor

Overload List

Overload | Description
RabbitTemplate Constructor() |
RabbitTemplate Constructor(IConnectionFactory) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > RabbitTemplate Constructor : RabbitTemplate Constructor()

Syntax

C#
public RabbitTemplate()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Constructor(IConnectionFactory)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > RabbitTemplate Constructor : RabbitTemplate Constructor(IConnectionFactory)
connectionFactory

Syntax

C#
public RabbitTemplate(
   IConnectionFactory connectionFactory
)

Parameters

connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitTemplate Class

For a list of all members of this type, see RabbitTemplate members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from RabbitAccessor)
Public Method | ConvertAndSend | Overloaded.
Public Method | CreateMessageProperties |
Public Method | Execute | Overloaded.
Public Method | Receive | Overloaded.
Public Method | ReceiveAndConvert | Overloaded.
Public Method | Send | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ChannelLocallyTransacted |
Protected Method | CreateChannel | (Inherited from RabbitAccessor)
Protected Method | CreateConnection | (Inherited from RabbitAccessor)
Protected Method | DoCreateMessageProperties |
Protected Method | DoSend |
Protected Method | GetChannel |
Protected Method | GetConnection |
Protected Method | InitDefaultStrategies |
Top

See Also

Reference

RabbitTemplate Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ChannelLocallyTransacted Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : ChannelLocallyTransacted Method
channel

Syntax

C#
protected bool ChannelLocallyTransacted(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : ConvertAndSend Method

Overload List

Overload | Description
ConvertAndSend(Object) |
ConvertAndSend(String,Object) |
ConvertAndSend(String,String,Object) |
ConvertAndSend(Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,Object,MessagePostProcessorDelegate) |
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(Object) Method
message

Syntax

C#
public void ConvertAndSend(
   object message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(String,Object) Method
routingKey
message

Syntax

C#
public void ConvertAndSend(
   string routingKey,
   object message
)

Parameters

routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(String,String,Object) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(String,String,Object) Method
exchange
routingKey
message

Syntax

C#
public void ConvertAndSend(
   string exchange,
   string routingKey,
   object message
)

Parameters

exchange
routingKey
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(Object,MessagePostProcessorDelegate) Method
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(String,Object,MessagePostProcessorDelegate) Method
routingKey
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ConvertAndSend Method : ConvertAndSend(String,String,Object,MessagePostProcessorDelegate) Method
exchange
routingKey
message
messagePostProcessorDelegate

Syntax

C#
public void ConvertAndSend(
   string exchange,
   string routingKey,
   object message,
   MessagePostProcessorDelegate messagePostProcessorDelegate
)

Parameters

exchange
routingKey
message
messagePostProcessorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateMessageProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : CreateMessageProperties Method

Syntax

C#
public IMessageProperties CreateMessageProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoCreateMessageProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : DoCreateMessageProperties Method
basicProperties

Syntax

C#
protected virtual IMessageProperties DoCreateMessageProperties(
   IBasicProperties basicProperties
)

Parameters

basicProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoSend Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : DoSend Method
channel
exchange
routingKey
messageCreator
messageCreatorDelegate

Syntax

C#
protected virtual void DoSend(
   IModel channel,
   string exchange,
   string routingKey,
   IMessageCreator messageCreator,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

channel
exchange
routingKey
messageCreator
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Execute Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : Execute Method

Overload List

Overload | Description
Generic Execute(Generic ChannelCallbackDelegate) |
Generic Execute(Generic IChannelCallback) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Rabbit
Generic Execute(Generic ChannelCallbackDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Execute Method : Generic Execute(Generic ChannelCallbackDelegate) Method
action

Syntax

C#
public T Execute<T>(
   ChannelCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Rabbit
Generic Execute(Generic IChannelCallback) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Execute Method : Generic Execute(Generic IChannelCallback) Method
action

Syntax

C#
public T Execute<T>(
   IChannelCallback<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : GetChannel Method
resourceHolder

Syntax

C#
protected virtual IModel GetChannel(
   RabbitResourceHolder resourceHolder
)

Parameters

resourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : GetConnection Method
resourceHolder

Syntax

C#
protected virtual IConnection GetConnection(
   RabbitResourceHolder resourceHolder
)

Parameters

resourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InitDefaultStrategies Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : InitDefaultStrategies Method

Syntax

C#
protected virtual void InitDefaultStrategies()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Receive Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : Receive Method

Overload List

Overload | Description
Receive() |
Receive(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Receive() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Receive Method : Receive() Method

Syntax

C#
public Message Receive()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Receive(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Receive Method : Receive(String) Method
queueName

Syntax

C#
public Message Receive(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReceiveAndConvert Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : ReceiveAndConvert Method

Overload List

Overload | Description
ReceiveAndConvert() |
ReceiveAndConvert(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReceiveAndConvert() Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ReceiveAndConvert Method : ReceiveAndConvert() Method

Syntax

C#
public object ReceiveAndConvert()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ReceiveAndConvert(String) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > ReceiveAndConvert Method : ReceiveAndConvert(String) Method
queueName

Syntax

C#
public object ReceiveAndConvert(
   string queueName
)

Parameters

queueName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : Send Method

Overload List

Overload | Description
Send(MessageCreatorDelegate) |
Send(String,MessageCreatorDelegate) |
Send(String,String,MessageCreatorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Send Method : Send(MessageCreatorDelegate) Method
messageCreatorDelegate

Syntax

C#
public void Send(
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Send Method : Send(String,MessageCreatorDelegate) Method
routingKey
messageCreatorDelegate

Syntax

C#
public void Send(
   string routingKey,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

routingKey
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(String,String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class > Send Method : Send(String,String,MessageCreatorDelegate) Method
exchange
routingKey
messageCreatorDelegate

Syntax

C#
public void Send(
   string exchange,
   string routingKey,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

exchange
routingKey
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitTemplate Class

For a list of all members of this type, see RabbitTemplate members.

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from RabbitAccessor)
Public Property | Exchange |
Public Property | ImmediatePublish |
Public Property | MandatoryPublish |
Public Property | MessageConverter |
Public Property | Queue |
Public Property | RequireAck |
Public Property | RoutingKey |
Top

See Also

Reference

RabbitTemplate Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Exchange Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : Exchange Property

Syntax

C#
public string Exchange {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ImmediatePublish Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : ImmediatePublish Property

Syntax

C#
public bool ImmediatePublish {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MandatoryPublish Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : MandatoryPublish Property

Syntax

C#
public bool MandatoryPublish {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageConverter Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : MessageConverter Property

Syntax

C#
public IMessageConverter MessageConverter {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Queue Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : Queue Property

Syntax

C#
public string Queue {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RequireAck Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : RequireAck Property

Syntax

C#
public bool RequireAck {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : RoutingKey Property

Syntax

C#
public string RoutingKey {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : RabbitTemplate Class

For a list of all members of this type, see RabbitTemplate members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | logger |
Top

See Also

Reference

RabbitTemplate Class
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
logger Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > RabbitTemplate Class : logger Field

Syntax

C#
protected static readonly ILog logger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitTemplate Class
RabbitTemplate Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IChannelAwareMessageListener Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IChannelAwareMessageListener Interface

Syntax

C#
public interface IChannelAwareMessageListener

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IChannelAwareMessageListener Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IChannelAwareMessageListener Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IChannelAwareMessageListener Interface

The following tables list the members exposed by IChannelAwareMessageListener.

Public Methods

 | Name | Description
Method | OnMessage |
Top

See Also

Reference

IChannelAwareMessageListener Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
IChannelAwareMessageListener Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IChannelAwareMessageListener Interface

For a list of all members of this type, see IChannelAwareMessageListener members.

Public Methods

 | Name | Description
Method | OnMessage |
Top

See Also

Reference

IChannelAwareMessageListener Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
OnMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IChannelAwareMessageListener Interface : OnMessage Method
message
model

Syntax

C#
void OnMessage(
   Message message,
   IModel model
)

Parameters

message
model

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IChannelAwareMessageListener Interface
IChannelAwareMessageListener Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Rabbit
Generic IChannelCallback Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : Generic IChannelCallback Interface

Syntax

C#
public interface IChannelCallback<T>

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic IChannelCallback Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
Generic IChannelCallback Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : Generic IChannelCallback Interface

The following tables list the members exposed by Generic IChannelCallback.

Public Methods

 | Name | Description
Method | DoInRabbit |
Top

See Also

Reference

Generic IChannelCallback Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
Generic IChannelCallback Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : Generic IChannelCallback Interface

For a list of all members of this type, see Generic IChannelCallback members.

Public Methods

 | Name | Description
Method | DoInRabbit |
Top

See Also

Reference

Generic IChannelCallback Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInRabbit Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > Generic IChannelCallback Interface : DoInRabbit Method
model

Syntax

C#
T DoInRabbit(
   IModel model
)

Parameters

model

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Generic IChannelCallback Interface
Generic IChannelCallback Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IRabbitOperations Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IRabbitOperations Interface
Rabbit specific methods for AMQP functionality.

Syntax

C#
public interface IRabbitOperations : IAmqpTemplate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Members
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
IRabbitOperations Interface Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IRabbitOperations Interface

The following tables list the members exposed by IRabbitOperations.

Public Methods

 | Name | Description
Method | Execute | Overloaded.
Method | Send | Overloaded.
Top

See Also

Reference

IRabbitOperations Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
IRabbitOperations Interface Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : IRabbitOperations Interface

For a list of all members of this type, see IRabbitOperations members.

Public Methods

 | Name | Description
Method | Execute | Overloaded.
Method | Send | Overloaded.
Top

See Also

Reference

IRabbitOperations Interface
Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Execute Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface : Execute Method

Overload List

Overload | Description
Generic Execute(Generic IChannelCallback) |
Generic Execute(Generic ChannelCallbackDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Rabbit
Generic Execute(Generic IChannelCallback) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface > Execute Method : Generic Execute(Generic IChannelCallback) Method
action

Syntax

C#
T Execute<T>(
   IChannelCallback<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members
Overload List


%%PageItemTitle%%

T
[image]
Spring.Messaging.Amqp.Rabbit
Generic Execute(Generic ChannelCallbackDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface > Execute Method : Generic Execute(Generic ChannelCallbackDelegate) Method
action

Syntax

C#
T Execute<T>(
   ChannelCallbackDelegate<T> action
)

Parameters

action

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface : Send Method

Overload List

Overload | Description
Send(MessageCreatorDelegate) |
Send(String,MessageCreatorDelegate) |
Send(String,String,MessageCreatorDelegate) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface > Send Method : Send(MessageCreatorDelegate) Method
messageCreator

Syntax

C#
void Send(
   MessageCreatorDelegate messageCreator
)

Parameters

messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface > Send Method : Send(String,MessageCreatorDelegate) Method
routingkey
messageCreator

Syntax

C#
void Send(
   string routingkey,
   MessageCreatorDelegate messageCreator
)

Parameters

routingkey
messageCreator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Send(String,String,MessageCreatorDelegate) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace > IRabbitOperations Interface > Send Method : Send(String,String,MessageCreatorDelegate) Method
exchange
routingKey
messageCreatorDelegate

Syntax

C#
void Send(
   string exchange,
   string routingKey,
   MessageCreatorDelegate messageCreatorDelegate
)

Parameters

exchange
routingKey
messageCreatorDelegate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitOperations Interface
IRabbitOperations Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Generic ChannelCallbackDelegate Delegate
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : Generic ChannelCallbackDelegate Delegate
channel

Syntax

C#
public delegate T ChannelCallbackDelegate<T>(
   IModel channel
)

Parameters

channel

Type Parameters

T

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Rabbit.Core Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageCreatorDelegate Delegate
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core Namespace : MessageCreatorDelegate Delegate
channel
Strategy interface for creating AMQP messages.

Syntax

C#
public delegate Message MessageCreatorDelegate(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Spring.Messaging.Amqp.Rabbit.Core Namespace


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace
See Also Inheritance Hierarchy Send Feedback
Classes supporting the Spring.Messaging.Amqp.Rabbit.Core namespace

Classes

 | Class | Description
Class | RabbitGatewaySupport | Convenient super class for application classes that need Rabbit access.

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitGatewaySupport Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace : RabbitGatewaySupport Class
Convenient super class for application classes that need Rabbit access.

Object Model

Syntax

C#
public class RabbitGatewaySupport : IInitializingObject

Remarks

Requires a ConnectionFactory or a RabbitTemplate instance to be set. It will create its own RabbitTemplate if a ConnectionFactory is passed in. A custom RabbitTemplate instance can be created for a given ConnectionFactory through overriding the
createNmsTemplate
method.

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.Support.RabbitGatewaySupport

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Members
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitGatewaySupport Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace : RabbitGatewaySupport Class

The following tables list the members exposed by RabbitGatewaySupport.

Public Constructors

 | Name | Description
Public Constructor | RabbitGatewaySupport Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectionFactory | Gets or sets he NMS connection factory to be used by the gateway. Will automatically create a NmsTemplate for the given ConnectionFactory.
Public Property | RabbitTemplate | Gets or sets the Rabbit template for the gateway.
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | Ensures that the Rabbit Template is specified and calls InitGateway.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRabbitTemplate | Creates a RabbitTemplate for the given ConnectionFactory.
Protected Method | InitGateway | Subclasses can override this for custom initialization behavior. Gets called after population of this instance's properties.
Top

See Also

Reference

RabbitGatewaySupport Class
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitGatewaySupport Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : RabbitGatewaySupport Constructor

Syntax

C#
public RabbitGatewaySupport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitGatewaySupport Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace : RabbitGatewaySupport Class

For a list of all members of this type, see RabbitGatewaySupport members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | Ensures that the Rabbit Template is specified and calls InitGateway.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRabbitTemplate | Creates a RabbitTemplate for the given ConnectionFactory.
Protected Method | InitGateway | Subclasses can override this for custom initialization behavior. Gets called after population of this instance's properties.
Top

See Also

Reference

RabbitGatewaySupport Class
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : AfterPropertiesSet Method
Ensures that the Rabbit Template is specified and calls InitGateway.

Syntax

C#
public void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateRabbitTemplate Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : CreateRabbitTemplate Method
connectionFactory
The connection factory.
Creates a RabbitTemplate for the given ConnectionFactory.

Syntax

C#
protected virtual RabbitTemplate CreateRabbitTemplate(
   IConnectionFactory connectionFactory
)

Parameters

connectionFactory
The connection factory.

Remarks

Only invoked if populating the gateway with a ConnectionFactory reference. Can be overridden in subclasses to provide a different RabbitTemplate instance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InitGateway Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : InitGateway Method
Subclasses can override this for custom initialization behavior. Gets called after population of this instance's properties.

Syntax

C#
protected virtual void InitGateway()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitGatewaySupport Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace : RabbitGatewaySupport Class

For a list of all members of this type, see RabbitGatewaySupport members.

Public Properties

 | Name | Description
Public Property | ConnectionFactory | Gets or sets he NMS connection factory to be used by the gateway. Will automatically create a NmsTemplate for the given ConnectionFactory.
Public Property | RabbitTemplate | Gets or sets the Rabbit template for the gateway.
Top

See Also

Reference

RabbitGatewaySupport Class
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConnectionFactory Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : ConnectionFactory Property
Gets or sets he NMS connection factory to be used by the gateway. Will automatically create a NmsTemplate for the given ConnectionFactory.

Syntax

C#
public IConnectionFactory ConnectionFactory {get; set;}

Return Value

The connection factory.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitTemplate Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace > RabbitGatewaySupport Class : RabbitTemplate Property
Gets or sets the Rabbit template for the gateway.

Syntax

C#
public RabbitTemplate RabbitTemplate {get; set;}

Return Value

The Tabbity template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitGatewaySupport Class
RabbitGatewaySupport Members


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Listener Namespace
See Also Inheritance Hierarchy Send Feedback
This namespace contains the base message listener container facility.

Classes

 | Class | Description
Class | AbstractMessageListenerContainer |
Class | AbstractRabbitListeningContainer |
Class | AsyncMessageProcessingConsumer |
Class | BlockingQueueConsumer |
Class | LocallyExposedRabbitResourceHolder |
Class | SharedConnectionNotInitializedException | Exception that indicates that the initial setup of this container's shared Connection failed. This is indicating to invokers that they need to establish the shared Connection themselves on first access.
Class | SimpleMessageListenerContainer |

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AbstractMessageListenerContainer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractMessageListenerContainer Class

Object Model

Syntax

C#
public abstract class AbstractMessageListenerContainer : AbstractRabbitListeningContainer, ILifecycle, IInitializingObject, IObjectNameAware

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Listener.AbstractRabbitListeningContainer
Spring.Messaging.Amqp.Rabbit.Listener.AbstractMessageListenerContainer
Spring.Messaging.Amqp.Rabbit.Listener.SimpleMessageListenerContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractMessageListenerContainer Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractMessageListenerContainer Class

The following tables list the members exposed by AbstractMessageListenerContainer.

Protected Fields

 | Name | Description
Protected Field | autoAck |
Protected Field | lifecycleMonitor | (Inherited from AbstractRabbitListeningContainer)
Top

Public Properties

 | Name | Description
Public Property | AutoAck |
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ErrorHandler | Sets an ErrorHandler to be invoked in case of any uncaught exceptions thrown while processing a Message. By default there will be no ErrorHandler so that error-level logging is the only result.
Public Property | ExposeListenerChannel | Exposes the listener channel to a registered Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener as well as to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. Default is true, reusing the listener's IModel
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | IsRunning | (Inherited from AbstractRabbitListeningContainer)
Public Property | MessageListener | Sets the message listener to register with the container. This can be either a Spring Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object.
Public Property | ObjectName | Set the name of the object in the object factory that created this object. (Inherited from AbstractRabbitListeningContainer)
Public Property | Queue | Gets or sets the name of the queue to receive messages from
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection | (Inherited from AbstractRabbitListeningContainer)
Protected Property | SharedConnectionEnabled | Gets a value indicating whether a shared Rabbited connection should be maintained by this container base class (Inherited from AbstractRabbitListeningContainer)
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from AbstractRabbitListeningContainer)
Public Method | Dispose | (Inherited from AbstractRabbitListeningContainer)
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize. (Inherited from AbstractRabbitListeningContainer)
Public Method | RequiredQueueName |
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container (Inherited from AbstractRabbitListeningContainer)
Public Method | Start | Starts this container. (Inherited from AbstractRabbitListeningContainer)
Public Method | Stop | Stop this container. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Methods

 | Name | Description
Protected Method | CheckMessageListener | Checks the message listener, throwing an exception if it does not correspond to a supported listener type. By default, only a Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object will be accepted.
Protected Method | CommitIfNecessary | Perform a commit or message acknowledgement, as appropriate
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).
Protected Method | DoInitialize | Registers any invokers within this container. Subclasses need to implement this method for their specific invoker management process. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoInvokeListener | Overloaded. Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded.
Protected Method | DoShutdown | Close the registered invokers. Subclasses need to implement this method for their specific invoker management process. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoStart | Start the shared Connection, if any, and notify all invoker tasks. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any. (Inherited from AbstractRabbitListeningContainer)
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution.
Protected Method | InvokeErrorHandler | Invokes the error handler.
Protected Method | InvokeListener | Invokes the specified listener: either as standard NMS MessageListener or (preferably) as Spring SessionAwareMessageListener.
Protected Method | IsChannelLocallyTransacted | Determines whether the given Channel is locally transacted, that is, whether its transaction is managed by this listener container's Channel handling and not by an external transaction coordinator.
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | RollbackIfNecessary | Perform a rollback, if appropriate.
Protected Method | RollbackOnExceptionIfNecessary | Perform a rollback, handling rollback excepitons properly.
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop. (Inherited from AbstractRabbitListeningContainer)
Protected Method | StopSharedConnection | Stops the shared connection. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ValidateConfiguration | Validates the configuration of this container (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

AbstractMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractMessageListenerContainer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractMessageListenerContainer Class

For a list of all members of this type, see AbstractMessageListenerContainer members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from AbstractRabbitListeningContainer)
Public Method | Dispose | (Inherited from AbstractRabbitListeningContainer)
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize. (Inherited from AbstractRabbitListeningContainer)
Public Method | RequiredQueueName |
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container (Inherited from AbstractRabbitListeningContainer)
Public Method | Start | Starts this container. (Inherited from AbstractRabbitListeningContainer)
Public Method | Stop | Stop this container. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Methods

 | Name | Description
Protected Method | CheckMessageListener | Checks the message listener, throwing an exception if it does not correspond to a supported listener type. By default, only a Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object will be accepted.
Protected Method | CommitIfNecessary | Perform a commit or message acknowledgement, as appropriate
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).
Protected Method | DoInitialize | Registers any invokers within this container. Subclasses need to implement this method for their specific invoker management process. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoInvokeListener | Overloaded. Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded.
Protected Method | DoShutdown | Close the registered invokers. Subclasses need to implement this method for their specific invoker management process. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoStart | Start the shared Connection, if any, and notify all invoker tasks. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any. (Inherited from AbstractRabbitListeningContainer)
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution.
Protected Method | InvokeErrorHandler | Invokes the error handler.
Protected Method | InvokeListener | Invokes the specified listener: either as standard NMS MessageListener or (preferably) as Spring SessionAwareMessageListener.
Protected Method | IsChannelLocallyTransacted | Determines whether the given Channel is locally transacted, that is, whether its transaction is managed by this listener container's Channel handling and not by an external transaction coordinator.
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | RollbackIfNecessary | Perform a rollback, if appropriate.
Protected Method | RollbackOnExceptionIfNecessary | Perform a rollback, handling rollback excepitons properly.
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop. (Inherited from AbstractRabbitListeningContainer)
Protected Method | StopSharedConnection | Stops the shared connection. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ValidateConfiguration | Validates the configuration of this container (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

AbstractMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CheckMessageListener Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : CheckMessageListener Method
listenerToCheck
Checks the message listener, throwing an exception if it does not correspond to a supported listener type. By default, only a Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object will be accepted.

Syntax

C#
protected virtual void CheckMessageListener(
   object listenerToCheck
)

Parameters

listenerToCheck

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CommitIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : CommitIfNecessary Method
channel
The channel to commit.
message
The message to acknowledge.
Perform a commit or message acknowledgement, as appropriate

Syntax

C#
protected virtual void CommitIfNecessary(
   IModel channel,
   Message message
)

Parameters

channel
The channel to commit.
message
The message to acknowledge.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoExecuteListener Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : DoExecuteListener Method
channel
message
The received message.
Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).

Syntax

C#
protected virtual void DoExecuteListener(
   IModel channel,
   Message message
)

Parameters

channel
message
The received message.

Exceptions

Exception | Description
NMSException | If thrown by NMS API methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInvokeListener Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : DoInvokeListener Method
Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded.

Overload List

Overload | Description
DoInvokeListener(IChannelAwareMessageListener,IModel,Message) | Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded.
DoInvokeListener(IMessageListener,Message) | Invoke the specified listener a Spring Rabbit MessageListener.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInvokeListener(IChannelAwareMessageListener,IModel,Message) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class > DoInvokeListener Method : DoInvokeListener(IChannelAwareMessageListener,IModel,Message) Method
listener
The Spring ISessionAwareMessageListener to invoke.
channel
The channel to operate on.
message
The received message.
Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded.

Syntax

C#
protected virtual void DoInvokeListener(
   IChannelAwareMessageListener listener,
   IModel channel,
   Message message
)

Parameters

listener
The Spring ISessionAwareMessageListener to invoke.
channel
The channel to operate on.
message
The received message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInvokeListener(IMessageListener,Message) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class > DoInvokeListener Method : DoInvokeListener(IMessageListener,Message) Method
listener
The listener to invoke.
message
The received message.
Invoke the specified listener a Spring Rabbit MessageListener.

Syntax

C#
protected virtual void DoInvokeListener(
   IMessageListener listener,
   Message message
)

Parameters

listener
The listener to invoke.
message
The received message.

Remarks

Default implementation performs a plain invocation of the
OnMessage
methods

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExecuteListener Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : ExecuteListener Method
channel
The channel.
message
The received message.
Executes the specified listener, committing or rolling back the transaction afterwards (if necessary).

Syntax

C#
protected virtual void ExecuteListener(
   IModel channel,
   Message message
)

Parameters

channel
The channel.
message
The received message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleListenerException Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : HandleListenerException Method
ex
The exception to handle
Handle the given exception that arose during listener execution.

Syntax

C#
protected virtual void HandleListenerException(
   Exception ex
)

Parameters

ex
The exception to handle

Remarks

The default implementation logs the exception at error level, not propagating it to the Rabbit provider - assuming that all handling of acknowledgement and/or transactions is done by this listener container. This can be overridden in subclasses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InvokeErrorHandler Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : InvokeErrorHandler Method
exception
The exception.
Invokes the error handler.

Syntax

C#
protected virtual void InvokeErrorHandler(
   Exception exception
)

Parameters

exception
The exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InvokeListener Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : InvokeListener Method
channel
message
The received message.
Invokes the specified listener: either as standard NMS MessageListener or (preferably) as Spring SessionAwareMessageListener.

Syntax

C#
protected virtual void InvokeListener(
   IModel channel,
   Message message
)

Parameters

channel
message
The received message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsChannelLocallyTransacted Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : IsChannelLocallyTransacted Method
channel
The channel to check.
Determines whether the given Channel is locally transacted, that is, whether its transaction is managed by this listener container's Channel handling and not by an external transaction coordinator.

Syntax

C#
protected virtual bool IsChannelLocallyTransacted(
   IModel channel
)

Parameters

channel
The channel to check.

Return Value

true if the is channel locally transacted; otherwise, false.

Remarks

This method is about finding out whether the Channel's transaction is local or externally coordinated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RequiredQueueName Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : RequiredQueueName Method

Syntax

C#
public string RequiredQueueName()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RollbackIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : RollbackIfNecessary Method
channel
Perform a rollback, if appropriate.

Syntax

C#
protected virtual void RollbackIfNecessary(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RollbackOnExceptionIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : RollbackOnExceptionIfNecessary Method
channel
The channel to rollback.
ex
The thrown application exception.
Perform a rollback, handling rollback excepitons properly.

Syntax

C#
protected virtual void RollbackOnExceptionIfNecessary(
   IModel channel,
   Exception ex
)

Parameters

channel
The channel to rollback.
ex
The thrown application exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractMessageListenerContainer Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractMessageListenerContainer Class

For a list of all members of this type, see AbstractMessageListenerContainer members.

Public Properties

 | Name | Description
Public Property | AutoAck |
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ErrorHandler | Sets an ErrorHandler to be invoked in case of any uncaught exceptions thrown while processing a Message. By default there will be no ErrorHandler so that error-level logging is the only result.
Public Property | ExposeListenerChannel | Exposes the listener channel to a registered Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener as well as to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. Default is true, reusing the listener's IModel
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | IsRunning | (Inherited from AbstractRabbitListeningContainer)
Public Property | MessageListener | Sets the message listener to register with the container. This can be either a Spring Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object.
Public Property | ObjectName | Set the name of the object in the object factory that created this object. (Inherited from AbstractRabbitListeningContainer)
Public Property | Queue | Gets or sets the name of the queue to receive messages from
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection | (Inherited from AbstractRabbitListeningContainer)
Protected Property | SharedConnectionEnabled | Gets a value indicating whether a shared Rabbited connection should be maintained by this container base class (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

AbstractMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
autoAck Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : autoAck Field

Syntax

C#
protected bool autoAck

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ErrorHandler Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : ErrorHandler Property
Sets an ErrorHandler to be invoked in case of any uncaught exceptions thrown while processing a Message. By default there will be no ErrorHandler so that error-level logging is the only result.

Syntax

C#
public IErrorHandler ErrorHandler {set;}

Return Value

The error handler.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExposeListenerChannel Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : ExposeListenerChannel Property
Exposes the listener channel to a registered Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener as well as to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. Default is true, reusing the listener's IModel

Syntax

C#
public bool ExposeListenerChannel {get; set;}

Return Value

true if expose listener channel; otherwise, false.

Remarks

Turn this off to expose a fresh Rabbit Channel fetched from the same underlying Rabbit IConnection instead. Note that Channels managed by an external transaction manager will always get exposed to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. So interms of RabbitTemplate exposure, this setting only affects locally transacted Channels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageListener Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : MessageListener Property
Sets the message listener to register with the container. This can be either a Spring Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object.

Syntax

C#
public object MessageListener {get; set;}

Return Value

The message listener.

Exceptions

Exception | Description
ArgumentException | If the supplied listener

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Queue Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractMessageListenerContainer Class : Queue Property
Gets or sets the name of the queue to receive messages from

Syntax

C#
public string Queue {get; set;}

Return Value

The name of the queue. Can not be null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractMessageListenerContainer Class
AbstractMessageListenerContainer Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractMessageListenerContainer Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractMessageListenerContainer Class

For a list of all members of this type, see AbstractMessageListenerContainer members.

Protected Fields

 | Name | Description
Protected Field | autoAck |
Protected Field | lifecycleMonitor | (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

AbstractMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AbstractRabbitListeningContainer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractRabbitListeningContainer Class

Object Model

Syntax

C#
public abstract class AbstractRabbitListeningContainer : RabbitAccessor, ILifecycle, IInitializingObject, IObjectNameAware

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Listener.AbstractRabbitListeningContainer
Spring.Messaging.Amqp.Rabbit.Listener.AbstractMessageListenerContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractRabbitListeningContainer Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractRabbitListeningContainer Class

The following tables list the members exposed by AbstractRabbitListeningContainer.

Protected Fields

 | Name | Description
Protected Field | lifecycleMonitor |
Top

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet.
Public Property | IsRunning |
Public Property | ObjectName | Set the name of the object in the object factory that created this object.
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet.
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection |
Protected Property | SharedConnectionEnabled | Gets a value indicating whether a shared Rabbited connection should be maintained by this container base class
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | Overridden.
Public Method | Dispose |
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize.
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container
Public Method | Start | Starts this container.
Public Method | Stop | Stop this container.
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container.
Protected Method | DoInitialize | Registers any invokers within this container. Subclasses need to implement this method for their specific invoker management process.
Protected Method | DoShutdown | Close the registered invokers. Subclasses need to implement this method for their specific invoker management process.
Protected Method | DoStart | Start the shared Connection, if any, and notify all invoker tasks.
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any.
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container.
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container.
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop.
Protected Method | StopSharedConnection | Stops the shared connection.
Protected Method | ValidateConfiguration | Validates the configuration of this container
Top

See Also

Reference

AbstractRabbitListeningContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractRabbitListeningContainer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractRabbitListeningContainer Class

For a list of all members of this type, see AbstractRabbitListeningContainer members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | Overridden.
Public Method | Dispose |
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize.
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container
Public Method | Start | Starts this container.
Public Method | Stop | Stop this container.
Top

Protected Methods

 | Name | Description
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container.
Protected Method | DoInitialize | Registers any invokers within this container. Subclasses need to implement this method for their specific invoker management process.
Protected Method | DoShutdown | Close the registered invokers. Subclasses need to implement this method for their specific invoker management process.
Protected Method | DoStart | Start the shared Connection, if any, and notify all invoker tasks.
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any.
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container.
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container.
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop.
Protected Method | StopSharedConnection | Stops the shared connection.
Protected Method | ValidateConfiguration | Validates the configuration of this container
Top

See Also

Reference

AbstractRabbitListeningContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AfterPropertiesSet Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : AfterPropertiesSet Method

Syntax

C#
public override void AfterPropertiesSet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CreateSharedConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : CreateSharedConnection Method
Creates the shared connection for this container.

Syntax

C#
protected virtual IConnection CreateSharedConnection()

Return Value

The prepared Connection

Remarks

The default implementation creates a standard Connection and prepares it through PrepareSharedConnection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Dispose Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Dispose Method

Syntax

C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInitialize Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : DoInitialize Method
Registers any invokers within this container. Subclasses need to implement this method for their specific invoker management process.

Syntax

C#
protected abstract void DoInitialize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoShutdown Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : DoShutdown Method
Close the registered invokers. Subclasses need to implement this method for their specific invoker management process.

Syntax

C#
protected abstract void DoShutdown()

Remarks

A shared Rabbit connection, if any, will automatically be closed afterwards.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoStart Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : DoStart Method
Start the shared Connection, if any, and notify all invoker tasks.

Syntax

C#
protected virtual void DoStart()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoStop Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : DoStop Method
Notify all invoker tasks and stop the shared Connection, if any.

Syntax

C#
protected virtual void DoStop()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
EstablishSharedConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : EstablishSharedConnection Method
Establishes the shared connection for this container.

Syntax

C#
protected virtual void EstablishSharedConnection()

Remarks

The default implementation delegates to CreateSharedConnection which does one immediate connection attempt and throws an exception if it fails. Can be overridden to have a recover process in place, retrying until a Connection can be successfully established.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Initialize Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Initialize Method
Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize.

Syntax

C#
public virtual void Initialize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PrepareSharedConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : PrepareSharedConnection Method
connection
The connection to prepare.
Prepares the given connection, which is about to be registered as the shared connection for this container.

Syntax

C#
protected virtual void PrepareSharedConnection(
   IConnection connection
)

Parameters

connection
The connection to prepare.

Remarks

Subclasses can override this to apply further settings.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RunningAllowed Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : RunningAllowed Method
Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop.

Syntax

C#
protected virtual bool RunningAllowed()

Return Value

true if running is allowed, false otherise

Remarks

Subclasses may override this method to check against temporary conditions that prevent listeners from actually running. In other words, they may apply further restrictions to the 'running' state, returning false if such a restriction prevents listeners from running.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Shutdown Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Shutdown Method
Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container

Syntax

C#
public virtual void Shutdown()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Start Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Start Method
Starts this container.

Syntax

C#
public void Start()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Stop Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Stop Method
Stop this container.

Syntax

C#
public void Stop()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
StopSharedConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : StopSharedConnection Method
Stops the shared connection.

Syntax

C#
protected virtual void StopSharedConnection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ValidateConfiguration Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : ValidateConfiguration Method
Validates the configuration of this container

Syntax

C#
protected virtual void ValidateConfiguration()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractRabbitListeningContainer Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractRabbitListeningContainer Class

For a list of all members of this type, see AbstractRabbitListeningContainer members.

Public Properties

 | Name | Description
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet.
Public Property | IsRunning |
Public Property | ObjectName | Set the name of the object in the object factory that created this object.
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet.
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection |
Protected Property | SharedConnectionEnabled | Gets a value indicating whether a shared Rabbited connection should be maintained by this container base class
Top

See Also

Reference

AbstractRabbitListeningContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsActive Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : IsActive Property
Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet.

Syntax

C#
public bool IsActive {get;}

Return Value

true if this instance is active; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsRunning Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : IsRunning Property

Syntax

C#
public bool IsRunning {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ObjectName Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : ObjectName Property
Set the name of the object in the object factory that created this object.

Syntax

C#
public string ObjectName {get; set;}

Return Value

The name of the object in the factory.

Remarks

Invoked after population of normal object properties but before an init callback like IInitializingObject's AfterPropertiesSet method or a custom init-method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Running Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : Running Property
Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet.

Syntax

C#
public bool Running {get;}

Return Value

true if running; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnection Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : SharedConnection Property

Syntax

C#
protected virtual IConnection SharedConnection {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionEnabled Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : SharedConnectionEnabled Property
Gets a value indicating whether a shared Rabbited connection should be maintained by this container base class

Syntax

C#
protected abstract bool SharedConnectionEnabled {get;}

Return Value

true if shared connection enabled; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
AbstractRabbitListeningContainer Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AbstractRabbitListeningContainer Class

For a list of all members of this type, see AbstractRabbitListeningContainer members.

Protected Fields

 | Name | Description
Protected Field | lifecycleMonitor |
Top

See Also

Reference

AbstractRabbitListeningContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
lifecycleMonitor Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AbstractRabbitListeningContainer Class : lifecycleMonitor Field

Syntax

C#
protected object lifecycleMonitor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AbstractRabbitListeningContainer Class
AbstractRabbitListeningContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AsyncMessageProcessingConsumer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AsyncMessageProcessingConsumer Class

Syntax

C#
public class AsyncMessageProcessingConsumer : IRunnable

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Listener.AsyncMessageProcessingConsumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AsyncMessageProcessingConsumer Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
AsyncMessageProcessingConsumer Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AsyncMessageProcessingConsumer Class

The following tables list the members exposed by AsyncMessageProcessingConsumer.

Public Constructors

 | Name | Description
Public Constructor | AsyncMessageProcessingConsumer Constructor |
Top

Public Methods

 | Name | Description
Public Method | Run |
Top

See Also

Reference

AsyncMessageProcessingConsumer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
AsyncMessageProcessingConsumer Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AsyncMessageProcessingConsumer Class : AsyncMessageProcessingConsumer Constructor
consumer
messageListenerContainer

Syntax

C#
public AsyncMessageProcessingConsumer(
   QueueingBasicConsumer consumer,
   SimpleMessageListenerContainer messageListenerContainer
)

Parameters

consumer
messageListenerContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AsyncMessageProcessingConsumer Class
AsyncMessageProcessingConsumer Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
AsyncMessageProcessingConsumer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : AsyncMessageProcessingConsumer Class

For a list of all members of this type, see AsyncMessageProcessingConsumer members.

Public Methods

 | Name | Description
Public Method | Run |
Top

See Also

Reference

AsyncMessageProcessingConsumer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Run Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > AsyncMessageProcessingConsumer Class : Run Method

Syntax

C#
public void Run()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AsyncMessageProcessingConsumer Class
AsyncMessageProcessingConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : BlockingQueueConsumer Class

Syntax

C#
public class BlockingQueueConsumer : DefaultBasicConsumer, IBasicConsumer

Inheritance Hierarchy

System.Object
RabbitMQ.Client.DefaultBasicConsumer
Spring.Messaging.Amqp.Rabbit.Listener.BlockingQueueConsumer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumer Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : BlockingQueueConsumer Class

The following tables list the members exposed by BlockingQueueConsumer.

Public Constructors

 | Name | Description
Public Constructor | BlockingQueueConsumer Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConsumerTag | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | IsRunning | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | Model | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | ShutdownReason | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Top

Public Methods

 | Name | Description
Public Method | HandleBasicCancelOk | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleBasicConsumeOk | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleBasicDeliver | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleModelShutdown | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | OnCancel | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Top

See Also

Reference

BlockingQueueConsumer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumer Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : BlockingQueueConsumer Constructor

Syntax

C#
public BlockingQueueConsumer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
LocallyExposedRabbitResourceHolder Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : LocallyExposedRabbitResourceHolder Class

Syntax

C#
public class LocallyExposedRabbitResourceHolder : RabbitResourceHolder

Inheritance Hierarchy

System.Object
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder
Spring.Messaging.Amqp.Rabbit.Listener.LocallyExposedRabbitResourceHolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
LocallyExposedRabbitResourceHolder Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : LocallyExposedRabbitResourceHolder Class

The following tables list the members exposed by LocallyExposedRabbitResourceHolder.

Public Constructors

 | Name | Description
Public Constructor | LocallyExposedRabbitResourceHolder Constructor |
Top

Public Properties

 | Name | Description
Public Property | Channel | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | Connection | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded. (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | CommitAll | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | ContainsChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

LocallyExposedRabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
LocallyExposedRabbitResourceHolder Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : LocallyExposedRabbitResourceHolder Constructor
channel

Syntax

C#
public LocallyExposedRabbitResourceHolder(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionNotInitializedException Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SharedConnectionNotInitializedException Class
Exception that indicates that the initial setup of this container's shared Connection failed. This is indicating to invokers that they need to establish the shared Connection themselves on first access.

Syntax

C#
public class SharedConnectionNotInitializedException : Exception

Inheritance Hierarchy

System.Object
System.Exception
Spring.Messaging.Amqp.Rabbit.Listener.SharedConnectionNotInitializedException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SharedConnectionNotInitializedException Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionNotInitializedException Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SharedConnectionNotInitializedException Class

The following tables list the members exposed by SharedConnectionNotInitializedException.

Public Constructors

 | Name | Description
Public Constructor | SharedConnectionNotInitializedException Constructor | Initializes a new instance of the SharedConnectionNotInitializedException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SharedConnectionNotInitializedException Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionNotInitializedException Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SharedConnectionNotInitializedException Class : SharedConnectionNotInitializedException Constructor
message
The message.
Initializes a new instance of the SharedConnectionNotInitializedException class.

Syntax

C#
public SharedConnectionNotInitializedException(
   string message
)

Parameters

message
The message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SharedConnectionNotInitializedException Class
SharedConnectionNotInitializedException Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SimpleMessageListenerContainer Class

Object Model

Syntax

C#
public class SimpleMessageListenerContainer : AbstractMessageListenerContainer, ILifecycle, IInitializingObject, IObjectNameAware

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Listener.AbstractRabbitListeningContainer
Spring.Messaging.Amqp.Rabbit.Listener.AbstractMessageListenerContainer
Spring.Messaging.Amqp.Rabbit.Listener.SimpleMessageListenerContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Members
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SimpleMessageListenerContainer Class

The following tables list the members exposed by SimpleMessageListenerContainer.

Public Constructors

 | Name | Description
Public Constructor | SimpleMessageListenerContainer Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | autoAck | (Inherited from AbstractMessageListenerContainer)
Protected Field | lifecycleMonitor | (Inherited from AbstractRabbitListeningContainer)
Top

Public Properties

 | Name | Description
Public Property | AutoAck | (Inherited from AbstractMessageListenerContainer)
Public Property | BlockingQueueConsumerCapacity |
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConcurrentConsumers | Sets the number of concurrent consumers to create. Default is 1.
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ErrorHandler | Sets an ErrorHandler to be invoked in case of any uncaught exceptions thrown while processing a Message. By default there will be no ErrorHandler so that error-level logging is the only result. (Inherited from AbstractMessageListenerContainer)
Public Property | ExposeListenerChannel | Exposes the listener channel to a registered Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener as well as to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. Default is true, reusing the listener's IModel (Inherited from AbstractMessageListenerContainer)
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | IsRunning | (Inherited from AbstractRabbitListeningContainer)
Public Property | MessageListener | Sets the message listener to register with the container. This can be either a Spring Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object. (Inherited from AbstractMessageListenerContainer)
Public Property | ObjectName | Set the name of the object in the object factory that created this object. (Inherited from AbstractRabbitListeningContainer)
Public Property | PrefetchCount |
Public Property | Queue | Gets or sets the name of the queue to receive messages from (Inherited from AbstractMessageListenerContainer)
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | TaskExector |
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection | (Inherited from AbstractRabbitListeningContainer)
Protected Property | SharedConnectionEnabled | Overridden.
Top

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from AbstractRabbitListeningContainer)
Public Method | Dispose | (Inherited from AbstractRabbitListeningContainer)
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize. (Inherited from AbstractRabbitListeningContainer)
Public Method | ProcessMessage |
Public Method | RequiredQueueName | (Inherited from AbstractMessageListenerContainer)
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container (Inherited from AbstractRabbitListeningContainer)
Public Method | Start | Starts this container. (Inherited from AbstractRabbitListeningContainer)
Public Method | Stop | Stop this container. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Methods

 | Name | Description
Protected Method | CheckMessageListener | Checks the message listener, throwing an exception if it does not correspond to a supported listener type. By default, only a Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object will be accepted. (Inherited from AbstractMessageListenerContainer)
Protected Method | CommitIfNecessary | Perform a commit or message acknowledgement, as appropriate (Inherited from AbstractMessageListenerContainer)
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary). (Inherited from AbstractMessageListenerContainer)
Protected Method | DoInitialize | Overridden. Creates the specified number of concurrent consumers, in the from of a Rabbit Channel plus associated MessageConsumer process.
Protected Method | DoInvokeListener | Overloaded. Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded. (Inherited from AbstractMessageListenerContainer)
Protected Method | DoShutdown | Overridden.
Protected Method | DoStart | Overridden.
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any. (Inherited from AbstractRabbitListeningContainer)
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary). (Inherited from AbstractMessageListenerContainer)
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution. (Inherited from AbstractMessageListenerContainer)
Protected Method | InvokeErrorHandler | Invokes the error handler. (Inherited from AbstractMessageListenerContainer)
Protected Method | InvokeListener | Invokes the specified listener: either as standard NMS MessageListener or (preferably) as Spring SessionAwareMessageListener. (Inherited from AbstractMessageListenerContainer)
Protected Method | IsChannelLocallyTransacted | Determines whether the given Channel is locally transacted, that is, whether its transaction is managed by this listener container's Channel handling and not by an external transaction coordinator. (Inherited from AbstractMessageListenerContainer)
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | RollbackIfNecessary | Perform a rollback, if appropriate. (Inherited from AbstractMessageListenerContainer)
Protected Method | RollbackOnExceptionIfNecessary | Perform a rollback, handling rollback excepitons properly. (Inherited from AbstractMessageListenerContainer)
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop. (Inherited from AbstractRabbitListeningContainer)
Protected Method | StopSharedConnection | Stops the shared connection. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ValidateConfiguration | Validates the configuration of this container (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

SimpleMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : SimpleMessageListenerContainer Constructor

Syntax

C#
public SimpleMessageListenerContainer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SimpleMessageListenerContainer Class

For a list of all members of this type, see SimpleMessageListenerContainer members.

Public Methods

 | Name | Description
Public Method | AfterPropertiesSet | (Inherited from AbstractRabbitListeningContainer)
Public Method | Dispose | (Inherited from AbstractRabbitListeningContainer)
Public Method | Initialize | Initializes this container. Creates and calls a Rabbit Connection and calls AbstractRabbitListeningContainer.DoInitialize. (Inherited from AbstractRabbitListeningContainer)
Public Method | ProcessMessage |
Public Method | RequiredQueueName | (Inherited from AbstractMessageListenerContainer)
Public Method | Shutdown | Stop the shared Connection, call AbstractRabbitListeningContainer.DoShutdown and close this container (Inherited from AbstractRabbitListeningContainer)
Public Method | Start | Starts this container. (Inherited from AbstractRabbitListeningContainer)
Public Method | Stop | Stop this container. (Inherited from AbstractRabbitListeningContainer)
Top

Protected Methods

 | Name | Description
Protected Method | CheckMessageListener | Checks the message listener, throwing an exception if it does not correspond to a supported listener type. By default, only a Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object will be accepted. (Inherited from AbstractMessageListenerContainer)
Protected Method | CommitIfNecessary | Perform a commit or message acknowledgement, as appropriate (Inherited from AbstractMessageListenerContainer)
Protected Method | CreateChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateConnection | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Protected Method | CreateSharedConnection | Creates the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | DoExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary). (Inherited from AbstractMessageListenerContainer)
Protected Method | DoInitialize | Overridden. Creates the specified number of concurrent consumers, in the from of a Rabbit Channel plus associated MessageConsumer process.
Protected Method | DoInvokeListener | Overloaded. Invoke the specified listener as Spring SessionAwareMessageListener, exposing a new Rabbit Channel (potentially with its own transaction) to the listener if demanded. (Inherited from AbstractMessageListenerContainer)
Protected Method | DoShutdown | Overridden.
Protected Method | DoStart | Overridden.
Protected Method | DoStop | Notify all invoker tasks and stop the shared Connection, if any. (Inherited from AbstractRabbitListeningContainer)
Protected Method | EstablishSharedConnection | Establishes the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ExecuteListener | Executes the specified listener, committing or rolling back the transaction afterwards (if necessary). (Inherited from AbstractMessageListenerContainer)
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution. (Inherited from AbstractMessageListenerContainer)
Protected Method | InvokeErrorHandler | Invokes the error handler. (Inherited from AbstractMessageListenerContainer)
Protected Method | InvokeListener | Invokes the specified listener: either as standard NMS MessageListener or (preferably) as Spring SessionAwareMessageListener. (Inherited from AbstractMessageListenerContainer)
Protected Method | IsChannelLocallyTransacted | Determines whether the given Channel is locally transacted, that is, whether its transaction is managed by this listener container's Channel handling and not by an external transaction coordinator. (Inherited from AbstractMessageListenerContainer)
Protected Method | PrepareSharedConnection | Prepares the given connection, which is about to be registered as the shared connection for this container. (Inherited from AbstractRabbitListeningContainer)
Protected Method | RollbackIfNecessary | Perform a rollback, if appropriate. (Inherited from AbstractMessageListenerContainer)
Protected Method | RollbackOnExceptionIfNecessary | Perform a rollback, handling rollback excepitons properly. (Inherited from AbstractMessageListenerContainer)
Protected Method | RunningAllowed | Check whether this container's listeners are generally allowed to run. This implementation always returns true; the default 'running' state is purely determined by AbstractRabbitListeningContainer.Start / AbstractRabbitListeningContainer.Stop. (Inherited from AbstractRabbitListeningContainer)
Protected Method | StopSharedConnection | Stops the shared connection. (Inherited from AbstractRabbitListeningContainer)
Protected Method | ValidateConfiguration | Validates the configuration of this container (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

SimpleMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoInitialize Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : DoInitialize Method
Creates the specified number of concurrent consumers, in the from of a Rabbit Channel plus associated MessageConsumer process.

Syntax

C#
protected override void DoInitialize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoShutdown Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : DoShutdown Method

Syntax

C#
protected override void DoShutdown()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DoStart Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : DoStart Method

Syntax

C#
protected override void DoStart()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ProcessMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : ProcessMessage Method
message
channel

Syntax

C#
public void ProcessMessage(
   Message message,
   IModel channel
)

Parameters

message
channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SimpleMessageListenerContainer Class

For a list of all members of this type, see SimpleMessageListenerContainer members.

Public Properties

 | Name | Description
Public Property | AutoAck | (Inherited from AbstractMessageListenerContainer)
Public Property | BlockingQueueConsumerCapacity |
Public Property | ChannelTransacted | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ConcurrentConsumers | Sets the number of concurrent consumers to create. Default is 1.
Public Property | ConnectionFactory | (Inherited from Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor)
Public Property | ErrorHandler | Sets an ErrorHandler to be invoked in case of any uncaught exceptions thrown while processing a Message. By default there will be no ErrorHandler so that error-level logging is the only result. (Inherited from AbstractMessageListenerContainer)
Public Property | ExposeListenerChannel | Exposes the listener channel to a registered Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener as well as to Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate calls. Default is true, reusing the listener's IModel (Inherited from AbstractMessageListenerContainer)
Public Property | IsActive | Gets a value indicating whether this container is currently active, that is whether it has been set up but not shut down yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | IsRunning | (Inherited from AbstractRabbitListeningContainer)
Public Property | MessageListener | Sets the message listener to register with the container. This can be either a Spring Spring.Messaging.Amqp.Core.IMessageListener object or a Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener object. (Inherited from AbstractMessageListenerContainer)
Public Property | ObjectName | Set the name of the object in the object factory that created this object. (Inherited from AbstractRabbitListeningContainer)
Public Property | PrefetchCount |
Public Property | Queue | Gets or sets the name of the queue to receive messages from (Inherited from AbstractMessageListenerContainer)
Public Property | Running | Gets a value indicating whether this container is currently running, that is, whether it has been started and not stopped yet. (Inherited from AbstractRabbitListeningContainer)
Public Property | TaskExector |
Top

Protected Properties

 | Name | Description
Protected Property | SharedConnection | (Inherited from AbstractRabbitListeningContainer)
Protected Property | SharedConnectionEnabled | Overridden.
Top

See Also

Reference

SimpleMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumerCapacity Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : BlockingQueueConsumerCapacity Property

Syntax

C#
public int BlockingQueueConsumerCapacity {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConcurrentConsumers Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : ConcurrentConsumers Property
Sets the number of concurrent consumers to create. Default is 1.

Syntax

C#
public int ConcurrentConsumers {set;}

Return Value

The concurrent consumers.

Remarks

Raising the number of concurrent consumers is recommended in order to scale the consumption of messages coming in from a queue. However, note that any ordering guarantees are lost once multiple consumers are registered. In general, stick with 1 consumer for low-volume queues.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PrefetchCount Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : PrefetchCount Property

Syntax

C#
public ushort PrefetchCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionEnabled Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : SharedConnectionEnabled Property

Syntax

C#
protected override bool SharedConnectionEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TaskExector Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > SimpleMessageListenerContainer Class : TaskExector Property

Syntax

C#
public IExecutorService TaskExector {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SimpleMessageListenerContainer Class
SimpleMessageListenerContainer Members


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace
See Also Inheritance Hierarchy Send Feedback
Message listener adapter mechanism that delegates to target listener methods, converting messages to appropriate message content types (such as String or byte array) that get passed into listener methods.

Classes

 | Class | Description
Class | ListenerExecutionFailedException | Exception to be thrown when the execution of a listener method failed.
Class | MessageListenerAdapter | Message listener adapter that delegates the handling of messages to target listener methods via reflection, with flexible message type conversion. Allows listener methods to operate on message content types, completely independent from the Rabbit API.

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : ListenerExecutionFailedException Class
Exception to be thrown when the execution of a listener method failed.

Syntax

C#
public class ListenerExecutionFailedException : Exception

Inheritance Hierarchy

System.Object
System.Exception
Spring.Messaging.Amqp.Rabbit.Listener.Adapter.ListenerExecutionFailedException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListenerExecutionFailedException Members
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Class Members
See Also Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : ListenerExecutionFailedException Class

The following tables list the members exposed by ListenerExecutionFailedException.

Public Constructors

 | Name | Description
Public Constructor | ListenerExecutionFailedException Constructor | Overloaded. Initializes a new instance of the ListenerExecutionFailedException class, with the specified message
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ListenerExecutionFailedException Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > ListenerExecutionFailedException Class : ListenerExecutionFailedException Constructor
Initializes a new instance of the ListenerExecutionFailedException class, with the specified message

Overload List

Overload | Description
ListenerExecutionFailedException Constructor(String) | Initializes a new instance of the ListenerExecutionFailedException class, with the specified message
ListenerExecutionFailedException Constructor(String,Exception) | Initializes a new instance of the ListenerExecutionFailedException class, with the specified message and root cause exception

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListenerExecutionFailedException Class
ListenerExecutionFailedException Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Constructor(String)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > ListenerExecutionFailedException Class > ListenerExecutionFailedException Constructor : ListenerExecutionFailedException Constructor(String)
message
The message.
Initializes a new instance of the ListenerExecutionFailedException class, with the specified message

Syntax

C#
public ListenerExecutionFailedException(
   string message
)

Parameters

message
The message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListenerExecutionFailedException Class
ListenerExecutionFailedException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Constructor(String,Exception)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > ListenerExecutionFailedException Class > ListenerExecutionFailedException Constructor : ListenerExecutionFailedException Constructor(String,Exception)
message
The message.
innerException
The inner exception.
Initializes a new instance of the ListenerExecutionFailedException class, with the specified message and root cause exception

Syntax

C#
public ListenerExecutionFailedException(
   string message,
   Exception innerException
)

Parameters

message
The message.
innerException
The inner exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListenerExecutionFailedException Class
ListenerExecutionFailedException Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : MessageListenerAdapter Class
Message listener adapter that delegates the handling of messages to target listener methods via reflection, with flexible message type conversion. Allows listener methods to operate on message content types, completely independent from the Rabbit API.

Object Model

Syntax

C#
public class MessageListenerAdapter : IMessageListener, IChannelAwareMessageListener

Remarks

By default, the content of incoming messages gets extracted before being passed into the target listener method, to let the target method operate on message content types such as String or byte array instead of the raw Message. Message type conversion is delegated to a Spring Spring.Messaging.Amqp.Support.Converter.IMessageConverter. By default, a Spring.Messaging.Amqp.Support.Converter.SimpleMessageConverter will be used. (If you do not want such automatic message conversion taking place, then be sure to set the MessageConverter property to

null
.)

If a target listener method returns a non-null object (typically of a message content type such as

String
or byte array), it will get wrapped in a Rabbit
Message
and sent to the exchange of the incoming message with the routing key that comes from the Rabbit ReplyTo property if available or via the DefaultResponseRoutingKey property.

The sending of response messages is only available when using the Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener entry point (typically through a Spring message listener container). Usage as a MessageListener does not support the generation of response messages.

Consult the reference documentation for examples of method signatures compliant with this adapter class.

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Listener.Adapter.MessageListenerAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Members
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Class Members
See Also Fields Properties Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : MessageListenerAdapter Class

The following tables list the members exposed by MessageListenerAdapter.

Public Constructors

 | Name | Description
Public Constructor | MessageListenerAdapter Constructor | Overloaded. Initializes a new instance of the MessageListenerAdapter class with default settings.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ORIGINAL_DEFAULT_HANDLER_METHOD | The default handler method name.
Top

Public Properties

 | Name | Description
Public Property | DefaultHandlerMethod | Gets or sets the default handler method to delegate to, for the case where no specific listener method has been determined. Out-of-the-box value is ORIGINAL_DEFAULT_HANDLER_METHOD ("HandleMessage"}.
Public Property | DefaultResponseRoutingKey | Sets the default routing key to use when sending response messages. This will be applied in case of a request message that does not carry a "ReplyTo" property. Response destinations are only relevant for listener methods that return result objects, which will be wrapped in a response message and sent to a response destination.
Public Property | HandlerObject | Gets or sets the handler object to delegate message listening to.
Public Property | ImmediatePublish |
Public Property | MandatoryPublish |
Public Property | MessageConverter | Gets or sets the message converter that will convert incoming Rabbit messages to listener method arguments, and objects returned from listener methods back to Rabbit messages.
Top

Public Methods

 | Name | Description
Public Method | OnMessage | Overloaded. Rabbit Spring.Messaging.Amqp.Core.IMessageListener entry point. Delegates the message to the target listener method, with appropriate conversion of the message arguments
Top

Protected Methods

 | Name | Description
Protected Method | BuildMessage | Builds a Rabbit message to be sent as response based on the given result object.
Protected Method | GetHandlerMethodName | Gets the name of the listener method that is supposed to handle the given message. The default implementation simply returns the configured default listener method, if any.
Protected Method | GetResponseReplyTo | Determine a response destination for the given message.
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution. The default implementation logs the exception at error level. This method only applies when used with Spring.Messaging.Amqp.Core.IMessageListener. In case of the Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener mechanism, exceptions get handled by the caller instead.
Protected Method | HandleResult | Handles the given result object returned from the listener method, sending a response message back.
Protected Method | InitDefaultStrategies | Initialize the default implementations for the adapter's strategies.
Protected Method | PostProcessChannel | Post-process the given message producer before using it to send the response. The default implementation is empty.
Protected Method | PostProcessResponse | Post-process the given response message before it will be sent. The default implementation sets the response's correlation id to the request message's correlation id.
Protected Method | SendResponse | Sends the given response message to the given destination.
Top

See Also

Reference

MessageListenerAdapter Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : MessageListenerAdapter Constructor
Initializes a new instance of the MessageListenerAdapter class with default settings.

Overload List

Overload | Description
MessageListenerAdapter Constructor() | Initializes a new instance of the MessageListenerAdapter class with default settings.
MessageListenerAdapter Constructor(Object) | Initializes a new instance of the MessageListenerAdapter class for the given handler object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Constructor()
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class > MessageListenerAdapter Constructor : MessageListenerAdapter Constructor()
Initializes a new instance of the MessageListenerAdapter class with default settings.

Syntax

C#
public MessageListenerAdapter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Constructor(Object)
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class > MessageListenerAdapter Constructor : MessageListenerAdapter Constructor(Object)
handlerObject
The delegate object.
Initializes a new instance of the MessageListenerAdapter class for the given handler object

Syntax

C#
public MessageListenerAdapter(
   object handlerObject
)

Parameters

handlerObject
The delegate object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : MessageListenerAdapter Class

For a list of all members of this type, see MessageListenerAdapter members.

Public Methods

 | Name | Description
Public Method | OnMessage | Overloaded. Rabbit Spring.Messaging.Amqp.Core.IMessageListener entry point. Delegates the message to the target listener method, with appropriate conversion of the message arguments
Top

Protected Methods

 | Name | Description
Protected Method | BuildMessage | Builds a Rabbit message to be sent as response based on the given result object.
Protected Method | GetHandlerMethodName | Gets the name of the listener method that is supposed to handle the given message. The default implementation simply returns the configured default listener method, if any.
Protected Method | GetResponseReplyTo | Determine a response destination for the given message.
Protected Method | HandleListenerException | Handle the given exception that arose during listener execution. The default implementation logs the exception at error level. This method only applies when used with Spring.Messaging.Amqp.Core.IMessageListener. In case of the Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener mechanism, exceptions get handled by the caller instead.
Protected Method | HandleResult | Handles the given result object returned from the listener method, sending a response message back.
Protected Method | InitDefaultStrategies | Initialize the default implementations for the adapter's strategies.
Protected Method | PostProcessChannel | Post-process the given message producer before using it to send the response. The default implementation is empty.
Protected Method | PostProcessResponse | Post-process the given response message before it will be sent. The default implementation sets the response's correlation id to the request message's correlation id.
Protected Method | SendResponse | Sends the given response message to the given destination.
Top

See Also

Reference

MessageListenerAdapter Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
BuildMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : BuildMessage Method
channel
The Rabbit Channel to operate on.
result
The content of the message, as returned from the listener method.
Builds a Rabbit message to be sent as response based on the given result object.

Syntax

C#
protected virtual Message BuildMessage(
   IModel channel,
   object result
)

Parameters

channel
The Rabbit Channel to operate on.
result
The content of the message, as returned from the listener method.

Return Value

the Rabbit
Message
(never
null
)

Exceptions

Exception | Description
Spring.Messaging.Amqp.Support.Converter.MessageConversionException | If there was an error in message conversion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetHandlerMethodName Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : GetHandlerMethodName Method
originalMessage
The EMS request message.
extractedMessage
The converted Rabbit request message, to be passed into the listener method as argument.
Gets the name of the listener method that is supposed to handle the given message. The default implementation simply returns the configured default listener method, if any.

Syntax

C#
protected virtual string GetHandlerMethodName(
   Message originalMessage,
   object extractedMessage
)

Parameters

originalMessage
The EMS request message.
extractedMessage
The converted Rabbit request message, to be passed into the listener method as argument.

Return Value

the name of the listener method (never
null
)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
GetResponseReplyTo Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : GetResponseReplyTo Method
request
The original incoming message.
response
Tthe outgoing message about to be sent.
channel
The channel to operate on.
Determine a response destination for the given message.

Syntax

C#
protected virtual string GetResponseReplyTo(
   Message request,
   Message response,
   IModel channel
)

Parameters

request
The original incoming message.
response
Tthe outgoing message about to be sent.
channel
The channel to operate on.

Return Value

the response destination (never
null
)

Exceptions

Exception | Description
InvalidOperationException | if no destination can be determined.

Remarks

The default implementation first checks the Rabbit ReplyTo property of the supplied request; if that is not

null
it is returned; if it is
null
, then the configured DefaultResponseRoutingKey default response routing key} is returned; if this too is
null
, then an InvalidOperationExceptionis thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleListenerException Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : HandleListenerException Method
ex
The exception to handle.
Handle the given exception that arose during listener execution. The default implementation logs the exception at error level.

This method only applies when used with Spring.Messaging.Amqp.Core.IMessageListener. In case of the Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener mechanism, exceptions get handled by the caller instead.

Syntax

C#
protected virtual void HandleListenerException(
   Exception ex
)

Parameters

ex
The exception to handle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleResult Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : HandleResult Method
result
The result object to handle (never
null
).
request
The original request message.
channel
The channel to operate on (may be
null
).
Handles the given result object returned from the listener method, sending a response message back.

Syntax

C#
protected virtual void HandleResult(
   object result,
   Message request,
   IModel channel
)

Parameters

result
The result object to handle (never
null
).
request
The original request message.
channel
The channel to operate on (may be
null
).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
InitDefaultStrategies Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : InitDefaultStrategies Method
Initialize the default implementations for the adapter's strategies.

Syntax

C#
protected virtual void InitDefaultStrategies()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
OnMessage Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : OnMessage Method
Rabbit Spring.Messaging.Amqp.Core.IMessageListener entry point.

Delegates the message to the target listener method, with appropriate conversion of the message arguments

Overload List

Overload | Description
OnMessage(Message) | Rabbit Spring.Messaging.Amqp.Core.IMessageListener entry point. Delegates the message to the target listener method, with appropriate conversion of the message arguments
OnMessage(Message,IModel) | Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener entry point. Delegates the message to the target listener method, with appropriate conversion of the message argument. If the target method returns a non-null object, wrap in a Rabbit message and send it back.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
OnMessage(Message) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class > OnMessage Method : OnMessage(Message) Method
message
The incoming message.
Rabbit Spring.Messaging.Amqp.Core.IMessageListener entry point.

Delegates the message to the target listener method, with appropriate conversion of the message arguments

Syntax

C#
public void OnMessage(
   Message message
)

Parameters

message
The incoming message.

Remarks

In case of an exception, the HandleListenerException method will be invoked. Note Does not support sending response messages based on result objects returned from listener methods. Use the Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener entry point (typically through a Spring message listener container) for handling result objects as well.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
OnMessage(Message,IModel) Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class > OnMessage Method : OnMessage(Message,IModel) Method
message
The incoming message.
channel
The channel to operate on.
Spring Spring.Messaging.Amqp.Rabbit.Core.IChannelAwareMessageListener entry point.

Delegates the message to the target listener method, with appropriate conversion of the message argument. If the target method returns a non-null object, wrap in a Rabbit message and send it back.

Syntax

C#
public void OnMessage(
   Message message,
   IModel channel
)

Parameters

message
The incoming message.
channel
The channel to operate on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members
Overload List


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PostProcessChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : PostProcessChannel Method
channel
The channel that will be used to send the message.
response
The outgoing message about to be sent.
Post-process the given message producer before using it to send the response. The default implementation is empty.

Syntax

C#
protected virtual void PostProcessChannel(
   IModel channel,
   Message response
)

Parameters

channel
The channel that will be used to send the message.
response
The outgoing message about to be sent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
PostProcessResponse Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : PostProcessResponse Method
request
The original incoming message.
response
The outgoing Rabbit message about to be sent.
Post-process the given response message before it will be sent. The default implementation sets the response's correlation id to the request message's correlation id.

Syntax

C#
protected virtual void PostProcessResponse(
   Message request,
   Message response
)

Parameters

request
The original incoming message.
response
The outgoing Rabbit message about to be sent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SendResponse Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : SendResponse Method
channel
The channel to operate on.
replyTo
The replyto property to determine where to send a response.
message
The outgoing message about to be sent.
Sends the given response message to the given destination.

Syntax

C#
protected virtual void SendResponse(
   IModel channel,
   string replyTo,
   Message message
)

Parameters

channel
The channel to operate on.
replyTo
The replyto property to determine where to send a response.
message
The outgoing message about to be sent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : MessageListenerAdapter Class

For a list of all members of this type, see MessageListenerAdapter members.

Public Properties

 | Name | Description
Public Property | DefaultHandlerMethod | Gets or sets the default handler method to delegate to, for the case where no specific listener method has been determined. Out-of-the-box value is ORIGINAL_DEFAULT_HANDLER_METHOD ("HandleMessage"}.
Public Property | DefaultResponseRoutingKey | Sets the default routing key to use when sending response messages. This will be applied in case of a request message that does not carry a "ReplyTo" property. Response destinations are only relevant for listener methods that return result objects, which will be wrapped in a response message and sent to a response destination.
Public Property | HandlerObject | Gets or sets the handler object to delegate message listening to.
Public Property | ImmediatePublish |
Public Property | MandatoryPublish |
Public Property | MessageConverter | Gets or sets the message converter that will convert incoming Rabbit messages to listener method arguments, and objects returned from listener methods back to Rabbit messages.
Top

See Also

Reference

MessageListenerAdapter Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DefaultHandlerMethod Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : DefaultHandlerMethod Property
Gets or sets the default handler method to delegate to, for the case where no specific listener method has been determined. Out-of-the-box value is ORIGINAL_DEFAULT_HANDLER_METHOD ("HandleMessage"}.

Syntax

C#
public string DefaultHandlerMethod {get; set;}

Return Value

The default handler method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DefaultResponseRoutingKey Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : DefaultResponseRoutingKey Property
Sets the default routing key to use when sending response messages. This will be applied in case of a request message that does not carry a "ReplyTo" property. Response destinations are only relevant for listener methods that return result objects, which will be wrapped in a response message and sent to a response destination.

Syntax

C#
public string DefaultResponseRoutingKey {set;}

Return Value

The default ReplyTo value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandlerObject Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : HandlerObject Property
Gets or sets the handler object to delegate message listening to.

Syntax

C#
public object HandlerObject {get; set;}

Return Value

The handler object.

Remarks

Specified listener methods have to be present on this target object. If no explicit handler object has been specified, listener methods are expected to present on this adapter instance, that is, on a custom subclass of this adapter, defining listener methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ImmediatePublish Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : ImmediatePublish Property

Syntax

C#
public bool ImmediatePublish {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MandatoryPublish Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : MandatoryPublish Property

Syntax

C#
public bool MandatoryPublish {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
MessageConverter Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : MessageConverter Property
Gets or sets the message converter that will convert incoming Rabbit messages to listener method arguments, and objects returned from listener methods back to Rabbit messages.

Syntax

C#
public IMessageConverter MessageConverter {get; set;}

Return Value

The message converter.

Remarks

The default converter is a {@link SimpleMessageConverter}, which is able to handle Byte arrays and strings.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
MessageListenerAdapter Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : MessageListenerAdapter Class

For a list of all members of this type, see MessageListenerAdapter members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ORIGINAL_DEFAULT_HANDLER_METHOD | The default handler method name.
Top

See Also

Reference

MessageListenerAdapter Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ORIGINAL_DEFAULT_HANDLER_METHOD Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace > MessageListenerAdapter Class : ORIGINAL_DEFAULT_HANDLER_METHOD Field
The default handler method name.

Syntax

C#
public static string ORIGINAL_DEFAULT_HANDLER_METHOD

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageListenerAdapter Class
MessageListenerAdapter Members


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Support Namespace
See Also Inheritance Hierarchy Send Feedback
This package provides generic RabbitMQ support classes, to be used by higher-level classes like RabbitTemplate.

Classes

 | Class | Description
Class | RabbitUtils |

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitUtils Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace : RabbitUtils Class

Syntax

C#
public class RabbitUtils

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Support.RabbitUtils

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Members
Spring.Messaging.Amqp.Rabbit.Support Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitUtils Class Members
See Also Fields Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace : RabbitUtils Class

The following tables list the members exposed by RabbitUtils.

Public Constructors

 | Name | Description
Public Constructor | RabbitUtils Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_PORT |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseChannel |
static (Shared in Visual Basic) | CloseConnection | Closes the given Rabbit Connection and ignore any thrown exception.
static (Shared in Visual Basic) | CloseMessageConsumer |
static (Shared in Visual Basic) | CommitIfNecessary |
static (Shared in Visual Basic) | ExtractBasicProperties |
static (Shared in Visual Basic) | RollbackIfNecessary |
Top

See Also

Reference

RabbitUtils Class
Spring.Messaging.Amqp.Rabbit.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RabbitUtils Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : RabbitUtils Constructor

Syntax

C#
public RabbitUtils()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitUtils Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace : RabbitUtils Class

For a list of all members of this type, see RabbitUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CloseChannel |
static (Shared in Visual Basic) | CloseConnection | Closes the given Rabbit Connection and ignore any thrown exception.
static (Shared in Visual Basic) | CloseMessageConsumer |
static (Shared in Visual Basic) | CommitIfNecessary |
static (Shared in Visual Basic) | ExtractBasicProperties |
static (Shared in Visual Basic) | RollbackIfNecessary |
Top

See Also

Reference

RabbitUtils Class
Spring.Messaging.Amqp.Rabbit.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseChannel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : CloseChannel Method
channel

Syntax

C#
public static void CloseChannel(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseConnection Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : CloseConnection Method
connection
The connection to close (may be nul).
Closes the given Rabbit Connection and ignore any thrown exception.

Syntax

C#
public static void CloseConnection(
   IConnection connection
)

Parameters

connection
The connection to close (may be nul).

Remarks

This is useful for typical 'finally' blocks in manual Rabbit code

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CloseMessageConsumer Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : CloseMessageConsumer Method
channel
consumerTag

Syntax

C#
public static void CloseMessageConsumer(
   IModel channel,
   string consumerTag
)

Parameters

channel
consumerTag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
CommitIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : CommitIfNecessary Method
channel

Syntax

C#
public static void CommitIfNecessary(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ExtractBasicProperties Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : ExtractBasicProperties Method
channel
message

Syntax

C#
public static IBasicProperties ExtractBasicProperties(
   IModel channel,
   Message message
)

Parameters

channel
message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RollbackIfNecessary Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : RollbackIfNecessary Method
channel

Syntax

C#
public static void RollbackIfNecessary(
   IModel channel
)

Parameters

channel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
RabbitUtils Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace : RabbitUtils Class

For a list of all members of this type, see RabbitUtils members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DEFAULT_PORT |
Top

See Also

Reference

RabbitUtils Class
Spring.Messaging.Amqp.Rabbit.Support Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
DEFAULT_PORT Field
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Support Namespace > RabbitUtils Class : DEFAULT_PORT Field

Syntax

C#
public static int DEFAULT_PORT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitUtils Class
RabbitUtils Members


$$INTRODUCTION$$ - %%projecttitle%%

Spring.Messaging.Amqp.Rabbit.Admin
Introduction
Send Feedback


%%phrase%%

Spring.Messaging.Amqp.Rabbit.Admin
Spring.Messaging.Amqp.Rabbit.Admin Assembly
See Also Send Feedback
This package provides generic RabbitMQ administrative support classes to provide an API for functionality contained in rabbitmqctl.bat

Namespaces

Namespace | Description
Spring.Messaging.Amqp.Rabbit.Admin | Core package of the RabbitMQ Admin support


$$GETTING_STARTED$$ - %%projecttitle%%

Spring.Messaging.Amqp.Rabbit.Admin
Getting Started
Send Feedback


%%ItemTitle%%

Spring.Messaging.Amqp.Rabbit.Admin
Spring.Messaging.Amqp.Rabbit.Admin Namespace
See Also Inheritance Hierarchy Send Feedback
Core package of the RabbitMQ Admin support

Classes

 | Class | Description
Class | RabbitBrokerAdmin | Rabbit broker administration implementation
Class | RabbitControlErlangConverter | Converter that understands the responses from the rabbit control module and related functionality.
Class | RabbitStatus |

Interfaces

 | Interface | Description
Interface | IRabbitBrokerOperations | Performs administration tasks for RabbitMQ broker administration.

See Also

Reference

Spring.Messaging.Amqp.Rabbit.Admin Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitBrokerAdmin Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitBrokerAdmin Class
Rabbit broker administration implementation

Object Model

Syntax

C#
public class RabbitBrokerAdmin : IRabbitBrokerOperations

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Admin.RabbitBrokerAdmin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitBrokerAdmin Members
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitBrokerAdmin Class Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitBrokerAdmin Class

The following tables list the members exposed by RabbitBrokerAdmin.

Public Constructors

 | Name | Description
Public Constructor | RabbitBrokerAdmin Constructor |
Top

Public Properties

 | Name | Description
Public Property | Status |
Top

See Also

Reference

RabbitBrokerAdmin Class
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitBrokerAdmin Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace > RabbitBrokerAdmin Class : RabbitBrokerAdmin Constructor
connectionFactory

Syntax

C#
public RabbitBrokerAdmin(
   CachingConnectionFactory connectionFactory
)

Parameters

connectionFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitBrokerAdmin Class
RabbitBrokerAdmin Members


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitBrokerAdmin Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitBrokerAdmin Class

For a list of all members of this type, see RabbitBrokerAdmin members.

Public Properties

 | Name | Description
Public Property | Status |
Top

See Also

Reference

RabbitBrokerAdmin Class
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
Status Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace > RabbitBrokerAdmin Class : Status Property

Syntax

C#
public RabbitStatus Status {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitBrokerAdmin Class
RabbitBrokerAdmin Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitControlErlangConverter Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitControlErlangConverter Class
Converter that understands the responses from the rabbit control module and related functionality.

Syntax

C#
public class RabbitControlErlangConverter : SimpleErlangConverter, IErlangConverter

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.Converter.SimpleErlangConverter
Spring.Messaging.Amqp.Rabbit.Admin.RabbitControlErlangConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitControlErlangConverter Members
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitControlErlangConverter Class Members
See Also Methods Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitControlErlangConverter Class

The following tables list the members exposed by RabbitControlErlangConverter.

Public Constructors

 | Name | Description
Public Constructor | RabbitControlErlangConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | FromErlang | Convert from an Erlang data type to a .NET data type. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Public Method | FromErlangRpc | The return value from executing the Erlang RPC. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Public Method | ToErlang | Convert a .NET object to a Erlang data type. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Top

See Also

Reference

RabbitControlErlangConverter Class
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitControlErlangConverter Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace > RabbitControlErlangConverter Class : RabbitControlErlangConverter Constructor

Syntax

C#
public RabbitControlErlangConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitControlErlangConverter Class
RabbitControlErlangConverter Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitStatus Class
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitStatus Class

Syntax

C#
public class RabbitStatus

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Admin.RabbitStatus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitStatus Members
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitStatus Class Members
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitStatus Class

The following tables list the members exposed by RabbitStatus.

Public Constructors

 | Name | Description
Public Constructor | RabbitStatus Constructor |
Top

See Also

Reference

RabbitStatus Class
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitStatus Constructor
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace > RabbitStatus Class : RabbitStatus Constructor

Syntax

C#
public RabbitStatus()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitStatus Class
RabbitStatus Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
IRabbitBrokerOperations Interface
Members See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : IRabbitBrokerOperations Interface
Performs administration tasks for RabbitMQ broker administration.

Syntax

C#
public interface IRabbitBrokerOperations

Remarks

Goal is to support full CRUD of Exchanges, Queues, Bindings, User, VHosts, etc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitBrokerOperations Members
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%% $$Members$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
IRabbitBrokerOperations Interface Members
See Also Properties Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : IRabbitBrokerOperations Interface

The following tables list the members exposed by IRabbitBrokerOperations.

Public Properties

 | Name | Description
Property | Status |
Top

See Also

Reference

IRabbitBrokerOperations Interface
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
IRabbitBrokerOperations Interface Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : IRabbitBrokerOperations Interface

For a list of all members of this type, see IRabbitBrokerOperations members.

Public Properties

 | Name | Description
Property | Status |
Top

See Also

Reference

IRabbitBrokerOperations Interface
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit.Admin
Status Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace > IRabbitBrokerOperations Interface : Status Property

Syntax

C#
RabbitStatus Status {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRabbitBrokerOperations Interface
IRabbitBrokerOperations Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Erlang
Spring.Erlang.Connection Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Erlang.Connection.ConnectionFactoryUtils
Spring.Erlang.Connection.SimpleConnectionFactory

See Also

Reference

Spring.Erlang Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Erlang
Spring.Erlang.Core Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Erlang.Core.Application
Spring.Erlang.Core.ErlangAccessor
Spring.Erlang.Core.ErlangTemplate
Spring.Erlang.Core.Node

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangBadRpcException Class Methods
See Also Send Feedback
Spring.Erlang Namespace : ErlangBadRpcException Class

For a list of all members of this type, see ErlangBadRpcException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangBadRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangErrorRpcException Class Methods
See Also Send Feedback
Spring.Erlang Namespace : ErlangErrorRpcException Class

For a list of all members of this type, see ErlangErrorRpcException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangErrorRpcException Class
Spring.Erlang Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
ErlangConversionException Class Methods
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : ErlangConversionException Class

For a list of all members of this type, see ErlangConversionException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangConversionException Class
Spring.Erlang.Support.Converter Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
ErlangConversionException Class Properties
See Also Send Feedback
Spring.Erlang.Support.Converter Namespace : ErlangConversionException Class

For a list of all members of this type, see ErlangConversionException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ErlangConversionException Class
Spring.Erlang.Support.Converter Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Erlang
Spring.Erlang.Support.Converter Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.Converter.SimpleErlangConverter
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.Support.Converter.ErlangConversionException

See Also

Reference

Spring.Erlang Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Erlang
Spring.Erlang.Support Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.ErlangUtils

See Also

Reference

Spring.Erlang Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Erlang
UncategorizedOtpException Class Methods
See Also Send Feedback
Spring.Erlang Namespace : UncategorizedOtpException Class

For a list of all members of this type, see UncategorizedOtpException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

UncategorizedOtpException Class
Spring.Erlang Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Erlang
UncategorizedOtpException Class Properties
See Also Send Feedback
Spring.Erlang Namespace : UncategorizedOtpException Class

For a list of all members of this type, see UncategorizedOtpException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

UncategorizedOtpException Class
Spring.Erlang Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Erlang
Spring.Erlang Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Exception
Erlang.NET.OtpException
Erlang.NET.OtpErlangException
Spring.Erlang.ErlangBadRpcException
Spring.Erlang.ErlangErrorRpcException
Spring.Erlang.UncategorizedOtpException

See Also

Reference

Spring.Erlang Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Qpid-0-8-0.6
Spring.Messaging.Amqp.Qpid.Core Namespace (Spring.Messaging.Amqp.Qpid-0-8-0.6) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.HeadersDictionary
Spring.Messaging.Amqp.Qpid.Core.MessageProperties

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-8-0.6 Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Clear Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Clear Method

Syntax

C#
public virtual void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Deadline Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Deadline Property

Syntax

C#
public DateTime Deadline {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
HasTimeout Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : HasTimeout Property

Syntax

C#
public bool HasTimeout {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
IsOpen Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : IsOpen Property

Syntax

C#
public bool IsOpen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Released Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Released Method

Syntax

C#
public void Released()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
Requested Method
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : Requested Method

Syntax

C#
public void Requested()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
RollbackOnly Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : RollbackOnly Property

Syntax

C#
public bool RollbackOnly {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
SynchronizedWithTransaction Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : SynchronizedWithTransaction Property

Syntax

C#
public bool SynchronizedWithTransaction {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
TimeoutInMillis Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : TimeoutInMillis Property

Syntax

C#
public long TimeoutInMillis {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
TimeoutInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : TimeoutInSeconds Property

Syntax

C#
public int TimeoutInSeconds {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
TimeToLiveInMilliseconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : TimeToLiveInMilliseconds Property

Syntax

C#
public double TimeToLiveInMilliseconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Qpid-0-10-06
TimeToLiveInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Qpid.Client Namespace > QpidResourceHolder Class : TimeToLiveInSeconds Property

Syntax

C#
public int TimeToLiveInSeconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QpidResourceHolder Class
QpidResourceHolder Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Client Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Client.ClientFactoryUtils
Spring.Messaging.Amqp.Qpid.Client.SimpleClientFactory
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Qpid.Client.QpidResourceHolder

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Core Namespace (Spring.Messaging.Amqp.Qpid-0-10-06) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Core.ConnectionParameters
Spring.Messaging.Amqp.Qpid.Core.MessageProperties
Spring.Messaging.Amqp.Qpid.Core.QpidAccessor
Spring.Messaging.Amqp.Qpid.Core.QpidTemplate

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Qpid-0-10-06
Spring.Messaging.Amqp.Qpid.Support Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Qpid.Support.QpidUtils

See Also

Reference

Spring.Messaging.Amqp.Qpid-0-10-06 Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit.Admin
RabbitControlErlangConverter Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Admin Namespace : RabbitControlErlangConverter Class

For a list of all members of this type, see RabbitControlErlangConverter members.

Public Methods

 | Name | Description
Public Method | FromErlang | Convert from an Erlang data type to a .NET data type. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Public Method | FromErlangRpc | The return value from executing the Erlang RPC. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Public Method | ToErlang | Convert a .NET object to a Erlang data type. (Inherited from Spring.Erlang.Support.Converter.SimpleErlangConverter)
Top

See Also

Reference

RabbitControlErlangConverter Class
Spring.Messaging.Amqp.Rabbit.Admin Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit.Admin
Spring.Messaging.Amqp.Rabbit.Admin Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Erlang.Support.Converter.SimpleErlangConverter
Spring.Messaging.Amqp.Rabbit.Admin.RabbitControlErlangConverter
Spring.Messaging.Amqp.Rabbit.Admin.RabbitBrokerAdmin
Spring.Messaging.Amqp.Rabbit.Admin.RabbitStatus

See Also

Reference

Spring.Messaging.Amqp.Rabbit.Admin Assembly


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Clear Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Clear Method

Syntax

C#
public virtual void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Deadline Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Deadline Property

Syntax

C#
public DateTime Deadline {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HasTimeout Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : HasTimeout Property

Syntax

C#
public bool HasTimeout {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsOpen Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : IsOpen Property

Syntax

C#
public bool IsOpen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Released Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Released Method

Syntax

C#
public void Released()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Requested Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : Requested Method

Syntax

C#
public void Requested()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RollbackOnly Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : RollbackOnly Property

Syntax

C#
public bool RollbackOnly {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SynchronizedWithTransaction Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : SynchronizedWithTransaction Property

Syntax

C#
public bool SynchronizedWithTransaction {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeoutInMillis Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : TimeoutInMillis Property

Syntax

C#
public long TimeoutInMillis {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeoutInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : TimeoutInSeconds Property

Syntax

C#
public int TimeoutInSeconds {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeToLiveInMilliseconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : TimeToLiveInMilliseconds Property

Syntax

C#
public double TimeToLiveInMilliseconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeToLiveInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Connection Namespace > RabbitResourceHolder Class : TimeToLiveInSeconds Property

Syntax

C#
public int TimeToLiveInSeconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RabbitResourceHolder Class
RabbitResourceHolder Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Connection Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Connection.CachedModel
Spring.Messaging.Amqp.Rabbit.Connection.CloseSuppressingConnection
Spring.Messaging.Amqp.Rabbit.Connection.ConnectionFactoryUtils
Spring.Messaging.Amqp.Rabbit.Connection.SingleConnectionFactory
Spring.Messaging.Amqp.Rabbit.Connection.CachingConnectionFactory
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Core.Support Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.Support.RabbitGatewaySupport

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Core Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Core.MessageProperties
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Core.RabbitTemplate
Spring.Messaging.Amqp.Rabbit.Core.RabbitAdmin
Spring.Messaging.Amqp.Rabbit.Core.RabbitMessagePropertiesFactory

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : ListenerExecutionFailedException Class

For a list of all members of this type, see ListenerExecutionFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ListenerExecutionFailedException Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
ListenerExecutionFailedException Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace : ListenerExecutionFailedException Class

For a list of all members of this type, see ListenerExecutionFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ListenerExecutionFailedException Class
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Listener.Adapter Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Listener.Adapter.MessageListenerAdapter
System.Exception
Spring.Messaging.Amqp.Rabbit.Listener.Adapter.ListenerExecutionFailedException

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumer Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : BlockingQueueConsumer Class

For a list of all members of this type, see BlockingQueueConsumer members.

Public Methods

 | Name | Description
Public Method | HandleBasicCancelOk | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleBasicConsumeOk | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleBasicDeliver | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | HandleModelShutdown | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Method | OnCancel | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Top

See Also

Reference

BlockingQueueConsumer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
BlockingQueueConsumer Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : BlockingQueueConsumer Class

For a list of all members of this type, see BlockingQueueConsumer members.

Public Properties

 | Name | Description
Public Property | ConsumerTag | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | IsRunning | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | Model | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Public Property | ShutdownReason | (Inherited from RabbitMQ.Client.DefaultBasicConsumer)
Top

See Also

Reference

BlockingQueueConsumer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ConsumerTag Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : ConsumerTag Property

Syntax

C#
public string ConsumerTag {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleBasicCancelOk Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : HandleBasicCancelOk Method
consumerTag

Syntax

C#
public virtual void HandleBasicCancelOk(
   string consumerTag
)

Parameters

consumerTag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleBasicConsumeOk Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : HandleBasicConsumeOk Method
consumerTag

Syntax

C#
public virtual void HandleBasicConsumeOk(
   string consumerTag
)

Parameters

consumerTag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleBasicDeliver Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : HandleBasicDeliver Method
consumerTag
deliveryTag
redelivered
exchange
routingKey
properties
body

Syntax

C#
public virtual void HandleBasicDeliver(
   string consumerTag,
   ulong deliveryTag,
   bool redelivered,
   string exchange,
   string routingKey,
   IBasicProperties properties,
   byte[] body
)

Parameters

consumerTag
deliveryTag
redelivered
exchange
routingKey
properties
body

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HandleModelShutdown Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : HandleModelShutdown Method
model
reason

Syntax

C#
public virtual void HandleModelShutdown(
   IModel model,
   ShutdownEventArgs reason
)

Parameters

model
reason

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsRunning Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : IsRunning Property

Syntax

C#
public bool IsRunning {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Model Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : Model Property

Syntax

C#
public IModel Model {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
OnCancel Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : OnCancel Method

Syntax

C#
public virtual void OnCancel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
ShutdownReason Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > BlockingQueueConsumer Class : ShutdownReason Property

Syntax

C#
public ShutdownEventArgs ShutdownReason {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BlockingQueueConsumer Class
BlockingQueueConsumer Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
LocallyExposedRabbitResourceHolder Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : LocallyExposedRabbitResourceHolder Class

For a list of all members of this type, see LocallyExposedRabbitResourceHolder members.

Public Methods

 | Name | Description
Public Method | AddChannel | Overloaded. (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | Clear | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | CloseAll | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | CommitAll | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | ContainsChannel | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Method | Released | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Method | Requested | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

LocallyExposedRabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
LocallyExposedRabbitResourceHolder Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : LocallyExposedRabbitResourceHolder Class

For a list of all members of this type, see LocallyExposedRabbitResourceHolder members.

Public Properties

 | Name | Description
Public Property | Channel | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | Connection | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | Deadline | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | Frozen | (Inherited from Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder)
Public Property | HasTimeout | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | IsOpen | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | RollbackOnly | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | SynchronizedWithTransaction | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInMillis | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeoutInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInMilliseconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Public Property | TimeToLiveInSeconds | (Inherited from Spring.Transaction.Support.ResourceHolderSupport)
Top

See Also

Reference

LocallyExposedRabbitResourceHolder Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Clear Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : Clear Method

Syntax

C#
public virtual void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Deadline Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : Deadline Property

Syntax

C#
public DateTime Deadline {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
HasTimeout Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : HasTimeout Property

Syntax

C#
public bool HasTimeout {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
IsOpen Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : IsOpen Property

Syntax

C#
public bool IsOpen {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Released Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : Released Method

Syntax

C#
public void Released()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
Requested Method
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : Requested Method

Syntax

C#
public void Requested()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
RollbackOnly Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : RollbackOnly Property

Syntax

C#
public bool RollbackOnly {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
SynchronizedWithTransaction Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : SynchronizedWithTransaction Property

Syntax

C#
public bool SynchronizedWithTransaction {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeoutInMillis Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : TimeoutInMillis Property

Syntax

C#
public long TimeoutInMillis {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeoutInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : TimeoutInSeconds Property

Syntax

C#
public int TimeoutInSeconds {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeToLiveInMilliseconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : TimeToLiveInMilliseconds Property

Syntax

C#
public double TimeToLiveInMilliseconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%%

[image]
Spring.Messaging.Amqp.Rabbit
TimeToLiveInSeconds Property
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace > LocallyExposedRabbitResourceHolder Class : TimeToLiveInSeconds Property

Syntax

C#
public int TimeToLiveInSeconds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LocallyExposedRabbitResourceHolder Class
LocallyExposedRabbitResourceHolder Members


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionNotInitializedException Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SharedConnectionNotInitializedException Class

For a list of all members of this type, see SharedConnectionNotInitializedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SharedConnectionNotInitializedException Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp.Rabbit
SharedConnectionNotInitializedException Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SharedConnectionNotInitializedException Class

For a list of all members of this type, see SharedConnectionNotInitializedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

SharedConnectionNotInitializedException Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp.Rabbit
SimpleMessageListenerContainer Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Rabbit.Listener Namespace : SimpleMessageListenerContainer Class

For a list of all members of this type, see SimpleMessageListenerContainer members.

Protected Fields

 | Name | Description
Protected Field | autoAck | (Inherited from AbstractMessageListenerContainer)
Protected Field | lifecycleMonitor | (Inherited from AbstractRabbitListeningContainer)
Top

See Also

Reference

SimpleMessageListenerContainer Class
Spring.Messaging.Amqp.Rabbit.Listener Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Listener Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
RabbitMQ.Client.DefaultBasicConsumer
Spring.Messaging.Amqp.Rabbit.Listener.BlockingQueueConsumer
Spring.Messaging.Amqp.Rabbit.Core.RabbitAccessor
Spring.Messaging.Amqp.Rabbit.Listener.AbstractRabbitListeningContainer
Spring.Messaging.Amqp.Rabbit.Listener.AbstractMessageListenerContainer
Spring.Messaging.Amqp.Rabbit.Listener.SimpleMessageListenerContainer
Spring.Messaging.Amqp.Rabbit.Listener.AsyncMessageProcessingConsumer
Spring.Transaction.Support.ResourceHolderSupport
Spring.Messaging.Amqp.Rabbit.Connection.RabbitResourceHolder
Spring.Messaging.Amqp.Rabbit.Listener.LocallyExposedRabbitResourceHolder
System.Exception
Spring.Messaging.Amqp.Rabbit.Listener.SharedConnectionNotInitializedException

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp.Rabbit
Spring.Messaging.Amqp.Rabbit.Support Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Rabbit.Support.RabbitUtils

See Also

Reference

Spring.Messaging.Amqp.Rabbit Assembly


%%PageItemTitle%% $$Fields$$

[image]
Spring.Messaging.Amqp
BindingBuilder.DirectExchangeRoutingKeyConfigurer Class Fields
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : BindingBuilder.DirectExchangeRoutingKeyConfigurer Class

For a list of all members of this type, see BindingBuilder.DirectExchangeRoutingKeyConfigurer members.

Protected Fields

 | Name | Description
Protected Field | exchange | (Inherited from BindingBuilder.RoutingKeyConfigurer)
Protected Field | queue | (Inherited from BindingBuilder.RoutingKeyConfigurer)
Top

See Also

Reference

BindingBuilder.DirectExchangeRoutingKeyConfigurer Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
DirectExchange Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : DirectExchange Class

For a list of all members of this type, see DirectExchange members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

DirectExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
FanoutExchange Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : FanoutExchange Class

For a list of all members of this type, see FanoutExchange members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

FanoutExchange Class
Spring.Messaging.Amqp.Core Namespace


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
TopicExchange Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Core Namespace : TopicExchange Class

For a list of all members of this type, see TopicExchange members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from AbstractExchange)
Top

See Also

Reference

TopicExchange Class
Spring.Messaging.Amqp.Core Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp
Spring.Messaging.Amqp.Core Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Core.AbstractExchange
Spring.Messaging.Amqp.Core.DirectExchange
Spring.Messaging.Amqp.Core.FanoutExchange
Spring.Messaging.Amqp.Core.TopicExchange
Spring.Messaging.Amqp.Core.Address
Spring.Messaging.Amqp.Core.Binding
Spring.Messaging.Amqp.Core.BindingBuilder
Spring.Messaging.Amqp.Core.BindingBuilder.ExchangeConfigurer
Spring.Messaging.Amqp.Core.BindingBuilder.RoutingKeyConfigurer
Spring.Messaging.Amqp.Core.BindingBuilder.DirectExchangeRoutingKeyConfigurer
Spring.Messaging.Amqp.Core.ContentType
Spring.Messaging.Amqp.Core.Message
Spring.Messaging.Amqp.Core.Queue

See Also

Reference

Spring.Messaging.Amqp Assembly


%%PageItemTitle%% $$Methods$$

[image]
Spring.Messaging.Amqp
MessageConversionException Class Methods
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : MessageConversionException Class

For a list of all members of this type, see MessageConversionException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

MessageConversionException Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%PageItemTitle%% $$Properties$$

[image]
Spring.Messaging.Amqp
MessageConversionException Class Properties
See Also Send Feedback
Spring.Messaging.Amqp.Support.Converter Namespace : MessageConversionException Class

For a list of all members of this type, see MessageConversionException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

MessageConversionException Class
Spring.Messaging.Amqp.Support.Converter Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Spring.Messaging.Amqp
Spring.Messaging.Amqp.Support.Converter Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Spring.Messaging.Amqp.Support.Converter.JsonMessageConverter
Spring.Messaging.Amqp.Support.Converter.SimpleMessageConverter
Spring.Messaging.Amqp.Support.Converter.TypeMapper
System.Exception
Spring.Messaging.Amqp.Support.Converter.MessageConversionException

See Also

Reference

Spring.Messaging.Amqp Assembly