Introduction

Spring GemFire Integration focuses on integrating Spring Framework's powerful, non-invasive programming model and concepts with Gemstone's GemFire Enterprise Fabric, providing easier configuration, use and high-level abstractions.

Please refer to the reference documentation for additional information.

Send comments on this topic.

© SpringSource 2010 All Rights Reserved.


Spring.Data.GemFire

Spring GemFire 1.0 M1 API Reference

Spring.Data.GemFire Assembly

Referenced Assemblies

Assembly Reference | Description
Common.Logging |
GemStone.GemFire.Cache |
mscorlib |
mscorlib |
Spring.Core |
Spring.Data |
System |

Namespaces

Namespace | Description
Spring.Data.GemFire | This namespace contains all core classes making up the Spring GemFire project.

Classes

Class | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
CacheFactoryObject | Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.
GemFireCacheUtils | Helper class featuring methods for GemFire Cache or Region handling.
GemFireSystemException GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete
Spring.Data.Dao
exceptions.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
RegexInterest | Cache interest based on regular expression rather then individual key types.
RegionFactoryObject | FactoryBean for creating generic Gemfire {@link Region}s. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.

Interfaces

Interface | Description
IInterest | Basic holder interface for registering an interest in cached data.

Enumerations

Enumeration | Description
InterestResultPolicy | Enumeration for the policy of what to load on region initialization when registering for interest in cached data

Send comments on this topic.

© SpringSource 2010. All Rights Reserved.

Generated from assembly Spring.Data.GemFire [1.0.0.3867] by NDoc3


Spring.Data.GemFire

Spring GemFire 1.0 M1 API Reference

Spring.Data.GemFire Namespace

This namespace contains all core classes making up the Spring GemFire project.

Namespace Hierarchy

Classes

Class | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
CacheFactoryObject | Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.
GemFireCacheUtils | Helper class featuring methods for GemFire Cache or Region handling.
GemFireSystemException GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete
Spring.Data.Dao
exceptions.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
RegexInterest | Cache interest based on regular expression rather then individual key types.
RegionFactoryObject | FactoryBean for creating generic Gemfire {@link Region}s. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.

Interfaces

Interface | Description
IInterest | Basic holder interface for registering an interest in cached data.

Enumerations

Enumeration | Description
InterestResultPolicy | Enumeration for the policy of what to load on region initialization when registering for interest in cached data


AllKeysInterest Class

Basic holder class for registering an all-key based interest in cached data.

For a list of all members of this type, see AllKeysInterest Members .

System.Object
AllKeysInterest
KeyInterest
RegexInterest

[Visual Basic]
Public Class AllKeysInterest
Implements IInterest
[C#]
public class AllKeysInterest : IInterest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

AllKeysInterest Members | Spring.Data.GemFire Namespace


AllKeysInterest Members

AllKeysInterest overview

Public Instance Constructors

AllKeysInterest Overloaded. Initializes a new instance of the AllKeysInterest class.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

Overload List

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest()

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(InterestResultPolicy)

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(InterestResultPolicy,bool)

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(bool)

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
AllKeysInterest();

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal durable As Boolean _
)
[C#]
AllKeysInterest(
bool durable
);

Parameters

durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal policy As InterestResultPolicy _
)
[C#]
AllKeysInterest(
InterestResultPolicy policy
);

Parameters

policy
The policy.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
AllKeysInterest(
InterestResultPolicy policy,
bool durable
);

Parameters

policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Fields

The fields of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Protected Instance Fields

durable | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


Durable Property

Spring GemFire 1.0 M1 API Reference

AllKeysInterest.Durable Property

Gets or sets a value indicating whether this AllKeysInterest is durable.

[Visual Basic]
Public NotOverridable Property Durable() As Boolean _
Implements IInterest.Durable

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Durable { public get; public set; }

Property Value

true if durable; otherwise, false.

Implements

IInterest.Durable

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


Policy Property

Spring GemFire 1.0 M1 API Reference

AllKeysInterest.Policy Property

Gets or sets the policy.

[Visual Basic]
Public NotOverridable Property Policy() As InterestResultPolicy _
Implements IInterest.Policy

Public Get
End Get
Public Set
End Set
End Property
[C#]
public InterestResultPolicy Policy { public get; public set; }

Property Value

The policy.

Implements

IInterest.Policy

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Properties

The properties of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Methods

The methods of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


CacheFactoryObject Class

Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.

For a list of all members of this type, see CacheFactoryObject Members .

System.Object
CacheFactoryObject

[Visual Basic]
Public Class CacheFactoryObject
Implements IDisposable, IInitializingObject, IObjectNameAware, IFactoryObject, IPersistenceExceptionTranslator
[C#]
public class CacheFactoryObject : IDisposable, IInitializingObject, IObjectNameAware, IFactoryObject, IPersistenceExceptionTranslator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

CacheFactoryObject Members | Spring.Data.GemFire Namespace


CacheFactoryObject Members

CacheFactoryObject overview

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

Public Instance Constructors

CacheFactoryObject Constructor Initializes a new instance of the CacheFactoryObject class.

Public Instance Properties

CacheXml | Sets the name of the cache XML that can be used to configure the cache.
DisconnectOnClose | Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a but in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.
DistributedSystemName | Sets the name of the distributed system.
IsSingleton | Returns true
ObjectName | Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.
ObjectType | Returns Gemstone.GemFire.Cache.Cache
Properties | Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

Public Instance Methods

AfterPropertiesSet | Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.
Dispose | Closes the cache and disconnects from the distributed system.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Returns the cache object
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateExceptionIfPossible | Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Constructor

Initializes a new instance of the CacheFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
CacheFactoryObject();

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Fields

The fields of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.log Field

Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

[Visual Basic]
Protected Shared ReadOnly log As ILog
[C#]
protected static readonly ILog log;

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Properties

The properties of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Public Instance Properties

CacheXml | Sets the name of the cache XML that can be used to configure the cache.
DisconnectOnClose | Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a but in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.
DistributedSystemName | Sets the name of the distributed system.
IsSingleton | Returns true
ObjectName | Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.
ObjectType | Returns Gemstone.GemFire.Cache.Cache
Properties | Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheXml Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.CacheXml Property

Sets the name of the cache XML that can be used to configure the cache.

[Visual Basic]
Public WriteOnly Property CacheXml() As String
Public Set
End Set
End Property
[C#]
public string CacheXml { public set; }

Property Value

The cache XML.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


DisconnectOnClose Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.DisconnectOnClose Property

Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a but in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.

[Visual Basic]
Public WriteOnly Property DisconnectOnClose() As Boolean
Public Set
End Set
End Property
[C#]
public bool DisconnectOnClose { public set; }

Property Value

true to call DistributedSystem.Disconnect when this object is dispose; otherwise, false.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


DistributedSystemName Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.DistributedSystemName Property

Sets the name of the distributed system.

[Visual Basic]
Public WriteOnly Property DistributedSystemName() As String
Public Set
End Set
End Property
[C#]
public string DistributedSystemName { public set; }

Property Value

The name of the distributed system.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.IsSingleton Property

Returns true

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


ObjectName Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.ObjectName Property

Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectName() As String _
Implements IObjectNameAware.ObjectName

Public Set
End Set
End Property
[C#]
public string ObjectName { public set; }

Implements

IObjectNameAware.ObjectName

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.ObjectType Property

Returns Gemstone.GemFire.Cache.Cache

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


Properties Property

Spring GemFire 1.0 M1 API Reference

CacheFactoryObject.Properties Property

Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

[Visual Basic]
Public WriteOnly Property Properties() As NameValueCollection
Public Set
End Set
End Property
[C#]
public NameValueCollection Properties { public set; }

Property Value

The properties used to configure the cache..

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Methods

The methods of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.
Dispose | Closes the cache and disconnects from the distributed system.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Returns the cache object
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateExceptionIfPossible | Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.AfterPropertiesSet Method

Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.Dispose Method

Closes the cache and disconnects from the distributed system.

[Visual Basic]
Public NotOverridable Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.GetObject Method

Returns the cache object

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Return Value

The cache object

Implements

IFactoryObject.GetObject

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.TranslateExceptionIfPossible Method

Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

[Visual Basic]
Public NotOverridable Sub TranslateExceptionIfPossible( _
ByVal ex As Exception _
) _
Implements IPersistenceExceptionTranslator.TranslateExceptionIfPossible
[C#]
public DataAccessException TranslateExceptionIfPossible(
Exception ex
);

Parameters

ex
The exception thrown.

Return Value

the corresponding DataAccessException (or

null
if the exception could not be translated, as in this case it may result from user code rather than an actual persistence problem)

Implements

IPersistenceExceptionTranslator.TranslateExceptionIfPossible

Remarks

Do not translate exceptions that are not understand by this translator: for example, if coming from another persistence framework, or resulting from user code and unrelated to persistence.

Of particular importance is the correct translation to DataIntegrityViolationException for example on constraint violation. Implementations may use Spring ADO.NET Framework's sophisticated exception translation to provide further information in the event of SQLException as a root cause.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace | DataIntegrityViolationException | ErrorCodeExceptionTranslator


GemFireCacheUtils Class

Helper class featuring methods for GemFire Cache or Region handling.

For a list of all members of this type, see GemFireCacheUtils Members .

System.Object
GemFireCacheUtils

[Visual Basic]
Public MustInherit Class GemFireCacheUtils
[C#]
public abstract class GemFireCacheUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemFireCacheUtils Members | Spring.Data.GemFire Namespace


GemFireCacheUtils Members

GemFireCacheUtils overview

Public Static (Shared) Methods

ConvertGemFireAccessException Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

GemFireCacheUtils Constructor Initializes a new instance of the GemFireCacheUtils class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils Constructor

Initializes a new instance of the GemFireCacheUtils class.

[Visual Basic]
Protected Sub New()
[C#]
GemFireCacheUtils();

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils Methods

The methods of the GemFireCacheUtils class are listed below. For a complete list of GemFireCacheUtils class members, see the GemFireCacheUtils Members topic.

Public Static (Shared) Methods

ConvertGemFireAccessException Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils.ConvertGemFireAccessException Method

Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

[Visual Basic]
Public Shared Sub ConvertGemFireAccessException( _
ByVal ex As GemFireException _
)
[C#]
public static DataAccessException ConvertGemFireAccessException(
GemFireException ex
);

Parameters

ex
The GemFire exception.

Return Value

A Spring DataAccessException

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireSystemException Class

GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete

Spring.Data.Dao
exceptions.

For a list of all members of this type, see GemFireSystemException Members .

System.Object
Exception
DataAccessException
NonTransientDataAccessException
UncategorizedDataAccessException
GemFireSystemException

[Visual Basic]
Public Class GemFireSystemException
Inherits UncategorizedDataAccessException
[C#]
public class GemFireSystemException : UncategorizedDataAccessException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemFireSystemException Members | Spring.Data.GemFire Namespace


GemFireSystemException Members

GemFireSystemException overview

Public Instance Constructors

GemFireSystemException Overloaded. Initializes a new instance of the GemFireSystemException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

GemFireSystemException Overloaded. Initializes a new instance of the GemFireSystemException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

Overload List

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException()

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException(GemFireException)

Creates a new instance of the GemFireSystemException class.

protected GemFireSystemException(SerializationInfo,StreamingContext)

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException(string)

Creates a new instance of the GemFireSystemException class with the specified message and root cause.

public GemFireSystemException(string,Exception)

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New()
[C#]
GemFireSystemException();

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String _
)
[C#]
GemFireSystemException(
string message
);

Parameters

message
The message.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Creates a new instance of the GemFireSystemException class with the specified message and root cause.

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String, _
ByVal rootCause As Exception _
)
[C#]
GemFireSystemException(
string message,
Exception rootCause
);

Parameters

message
A message about the exception.
rootCause
The root exception that is being wrapped.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New( _
ByVal cause As GemFireException _
)
[C#]
GemFireSystemException(
GemFireException cause
);

Parameters

cause
The cause.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Creates a new instance of the GemFireSystemException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
GemFireSystemException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


IInterest Interface

Basic holder interface for registering an interest in cached data.

For a list of all members of this type, see IInterest Members .

[Visual Basic]
Public Interface IInterest
[C#]
public interface IInterest

Types that implement IInterest

Type | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
RegexInterest | Cache interest based on regular expression rather then individual key types.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

IInterest Members | Spring.Data.GemFire Namespace


IInterest Members

IInterest overview

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


IInterest Properties

The properties of the IInterest interface are listed below. For a complete list of IInterest interface members, see the IInterest Members topic.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


Durable Property

Spring GemFire 1.0 M1 API Reference

IInterest.Durable Property

Gets or sets a value indicating whether this AllKeysInterest is durable.

[Visual Basic]
Public MustOverride Property Durable() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Durable { public get; public set; }

Property Value

true if durable; otherwise, false.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


Policy Property

Spring GemFire 1.0 M1 API Reference

IInterest.Policy Property

Gets or sets the policy.

[Visual Basic]
Public MustOverride Property Policy() As InterestResultPolicy
Public Get
End Get
Public Set
End Set
End Property
[C#]
public InterestResultPolicy Policy { public get; public set; }

Property Value

The policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


InterestResultPolicy Enumeration

Enumeration for the policy of what to load on region initialization when registering for interest in cached data

[Visual Basic]
Public Enum InterestResultPolicy
[C#]
public enum InterestResultPolicy

Members

Member Name | Description
KeysAndValues | The client receives a bulk load of all available keys and values matching the interest registration criteria. This is the default interest result policy.
Keys | The client receives a bulk load of all available keys matching the interest registration criteria.
None | The client does not receive any immediate bulk loading.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

Spring.Data.GemFire Namespace


KeyInterest Class

Basic holder class for registering a keys based interest in cached data.

For a list of all members of this type, see KeyInterest Members .

System.Object
AllKeysInterest
KeyInterest

[Visual Basic]
Public Class KeyInterest
Inherits AllKeysInterest
Implements IInitializingObject
[C#]
public class KeyInterest : AllKeysInterest, IInitializingObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

KeyInterest Members | Spring.Data.GemFire Namespace


KeyInterest Members

KeyInterest overview

Public Instance Constructors

KeyInterest Overloaded. Initializes a new instance of the KeyInterest class.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Keys | Gets or sets the keys.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

Overload List

Initializes a new instance of the KeyInterest class.

public KeyInterest()

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[])

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],InterestResultPolicy)

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],InterestResultPolicy,bool)

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],bool)

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
KeyInterest();

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey _
)
[C#]
KeyInterest(
ICacheableKey[] keys
);

Parameters

keys
The keys.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal durable As Boolean _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
bool durable
);

Parameters

keys
The keys.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal policy As InterestResultPolicy _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
InterestResultPolicy policy
);

Parameters

keys
The keys.
policy
The policy.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
InterestResultPolicy policy,
bool durable
);

Parameters

keys
The keys.
policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Properties

The properties of the KeyInterest class are listed below. For a complete list of KeyInterest class members, see the KeyInterest Members topic.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Keys | Gets or sets the keys.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


Keys Property

Spring GemFire 1.0 M1 API Reference

KeyInterest.Keys Property

Gets or sets the keys.

[Visual Basic]
Public Property Keys() As ICacheableKey
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ICacheableKey[] Keys { public get; public set; }

Property Value

The keys.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Methods

The methods of the KeyInterest class are listed below. For a complete list of KeyInterest class members, see the KeyInterest Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet

[Visual Basic]
Public Overridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public virtual void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


RegexInterest Class

Cache interest based on regular expression rather then individual key types.

For a list of all members of this type, see RegexInterest Members .

System.Object
AllKeysInterest
RegexInterest

[Visual Basic]
Public Class RegexInterest
Inherits AllKeysInterest
Implements IInitializingObject
[C#]
public class RegexInterest : AllKeysInterest, IInitializingObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

RegexInterest Members | Spring.Data.GemFire Namespace


RegexInterest Members

RegexInterest overview

Public Instance Constructors

RegexInterest Overloaded. Initializes a new instance of the RegexInterest class.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.
Regex | Gets the regex backing this interest

Public Instance Methods

AfterPropertiesSet | Ensures the regex property has been set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

Overload List

Initializes a new instance of the RegexInterest class.

public RegexInterest()

Initializes a new instance of the RegexInterest class.

public RegexInterest(string)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,InterestResultPolicy)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,InterestResultPolicy,bool)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,bool)

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
RegexInterest();

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String _
)
[C#]
RegexInterest(
string regex
);

Parameters

regex
The regex.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal durable As Boolean _
)
[C#]
RegexInterest(
string regex,
bool durable
);

Parameters

regex
The regex.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal policy As InterestResultPolicy _
)
[C#]
RegexInterest(
string regex,
InterestResultPolicy policy
);

Parameters

regex
The regex.
policy
The policy.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
RegexInterest(
string regex,
InterestResultPolicy policy,
bool durable
);

Parameters

regex
The regex.
policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Properties

The properties of the RegexInterest class are listed below. For a complete list of RegexInterest class members, see the RegexInterest Members topic.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.
Regex | Gets the regex backing this interest

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


Regex Property

Spring GemFire 1.0 M1 API Reference

RegexInterest.Regex Property

Gets the regex backing this interest

[Visual Basic]
Public Property Regex() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Regex { public get; public set; }

Property Value

The regex.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Methods

The methods of the RegexInterest class are listed below. For a complete list of RegexInterest class members, see the RegexInterest Members topic.

Public Instance Methods

AfterPropertiesSet | Ensures the regex property has been set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest.AfterPropertiesSet Method

Ensures the regex property has been set.

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegionFactoryObject Class

FactoryBean for creating generic Gemfire {@link Region}s. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.

For a list of all members of this type, see RegionFactoryObject Members .

System.Object
RegionFactoryObject

[Visual Basic]
Public Class RegionFactoryObject
Implements IDisposable, IFactoryObject, IInitializingObject, IObjectNameAware
[C#]
public class RegionFactoryObject : IDisposable, IFactoryObject, IInitializingObject, IObjectNameAware

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

RegionFactoryObject Members | Spring.Data.GemFire Namespace


RegionFactoryObject Members

RegionFactoryObject overview

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.RegionFactoryObject.log

Public Instance Constructors

RegionFactoryObject Constructor Initializes a new instance of the RegionFactoryObject class.

Public Instance Properties

Attributes | Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.
Cache | Sets the cache used for creating the region
CacheListener | Gets or sets the cache listener.
CacheLoader | Sets the cache loader.
CacheWriter | Gets or sets the cache writer.
CachingEnabled | Sets the caching enabled flag for this region.
ClientNotification | Sets the client notification to be enabled/disabled.
ConcurrencyLevel | Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.
Destroy | Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)
DiskPolicy | Sets the disk policy. Only used when a new region is created.
Endpoints | Sets the endpoints for a client region. It is a comma separated list of host:port pairs.
EntryIdleTimeout | Sets the entry idle timeout in seconds
EntryIdleTimeoutAction | Sets the entry idle timeout expiration action.
EntryTimeToLive | Sets the entry time to live in seconds
EntryTimeToLiveAction | Sets the entry time to live expiration action.
InitialCapacity | Sets the initial capacity of the map used for storing the entries. Default is 16
Interests | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.Interests
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.IsSingleton
LoadFactor | Sets the load factor of the map used for storing the entries. Default 0.75
LocalScope | Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.
LruEntriesLimit | Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.
Name | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectType
PoolName | Sets the name of the pool for a client region
RegionIdleTimeout | Sets the region idle timeout in seconds
RegionIdleTimeoutAction | Sets the region idle timeout expiration action.
RegionTimeToLive | Sets the region time to live in seconds for the region as a whole
RegionTimeToLiveAction | Sets the region time to live expiration action.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostProcess | Subclasses can override this method to further customize the Region configuration.
PostProcessAttributes | Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the RegionFactoryObject.
RegisterInterests | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.RegisterInterests
SetCallbacks | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)
SetDistributionProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)
SetExpirationProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)
SetStorageProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject Constructor

Initializes a new instance of the RegionFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
RegionFactoryObject();

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject Fields

The fields of the RegionFactoryObject class are listed below. For a complete list of RegionFactoryObject class members, see the RegionFactoryObject Members topic.

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.RegionFactoryObject.log

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.log Field

Missing <summary> documentation for F:Spring.Data.GemFire.RegionFactoryObject.log

[Visual Basic]
Protected Shared ReadOnly log As ILog
[C#]
protected static readonly ILog log;

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject Properties

The properties of the RegionFactoryObject class are listed below. For a complete list of RegionFactoryObject class members, see the RegionFactoryObject Members topic.

Public Instance Properties

Attributes | Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.
Cache | Sets the cache used for creating the region
CacheListener | Gets or sets the cache listener.
CacheLoader | Sets the cache loader.
CacheWriter | Gets or sets the cache writer.
CachingEnabled | Sets the caching enabled flag for this region.
ClientNotification | Sets the client notification to be enabled/disabled.
ConcurrencyLevel | Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.
Destroy | Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)
DiskPolicy | Sets the disk policy. Only used when a new region is created.
Endpoints | Sets the endpoints for a client region. It is a comma separated list of host:port pairs.
EntryIdleTimeout | Sets the entry idle timeout in seconds
EntryIdleTimeoutAction | Sets the entry idle timeout expiration action.
EntryTimeToLive | Sets the entry time to live in seconds
EntryTimeToLiveAction | Sets the entry time to live expiration action.
InitialCapacity | Sets the initial capacity of the map used for storing the entries. Default is 16
Interests | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.Interests
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.IsSingleton
LoadFactor | Sets the load factor of the map used for storing the entries. Default 0.75
LocalScope | Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.
LruEntriesLimit | Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.
Name | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectType
PoolName | Sets the name of the pool for a client region
RegionIdleTimeout | Sets the region idle timeout in seconds
RegionIdleTimeoutAction | Sets the region idle timeout expiration action.
RegionTimeToLive | Sets the region time to live in seconds for the region as a whole
RegionTimeToLiveAction | Sets the region time to live expiration action.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Attributes Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Attributes Property

Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.

[Visual Basic]
Public WriteOnly Property Attributes() As RegionAttributes
Public Set
End Set
End Property
[C#]
public RegionAttributes Attributes { public set; }

Property Value

The attributes.

Remarks

Used only when a new region is created.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Cache Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Cache Property

Sets the cache used for creating the region

[Visual Basic]
Public WriteOnly Property Cache() As Cache
Public Set
End Set
End Property
[C#]
public Cache Cache { public set; }

Property Value

The cache to set

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheListener Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.CacheListener Property

Gets or sets the cache listener.

[Visual Basic]
Public WriteOnly Property CacheListener() As ICacheListener
Public Set
End Set
End Property
[C#]
public ICacheListener CacheListener { public set; }

Property Value

The cache listener.

Remarks

Sets the cache listeners used for the region used by this factory. Used only when a new region is created.Overrides the settings specified through Attributes

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheLoader Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.CacheLoader Property

Sets the cache loader.

[Visual Basic]
Public WriteOnly Property CacheLoader() As ICacheLoader
Public Set
End Set
End Property
[C#]
public ICacheLoader CacheLoader { public set; }

Property Value

The cache loader to set on a newly created region

Remarks

Sets the cache loader used for the region used by this factory. Used only when a new region is created. Overrides the settings specified through Attributes

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheWriter Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.CacheWriter Property

Gets or sets the cache writer.

[Visual Basic]
Public WriteOnly Property CacheWriter() As ICacheWriter
Public Set
End Set
End Property
[C#]
public ICacheWriter CacheWriter { public set; }

Property Value

The cache writer to set on a newly created region

Remarks

Sets the cache writer used for the region used by this factory. Used only when a new region is created. Overrides the settings specified through Attributes

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


CachingEnabled Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.CachingEnabled Property

Sets the caching enabled flag for this region.

[Visual Basic]
Public WriteOnly Property CachingEnabled() As Nullable(Of Boolean)
Public Set
End Set
End Property
[C#]
public bool? CachingEnabled { public set; }

Property Value

The caching is enabled.

Remarks

If true, cache data for this region in this process. If set to false, then no data is stored in the local process, but events and distributions will still occur, and the region can still be used to put and remove, etc... The default if not set is 'true', 'false' is illegal for regions of ScopeType.Local scope. LocalScope

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientNotification Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.ClientNotification Property

Sets the client notification to be enabled/disabled.

[Visual Basic]
Public WriteOnly Property ClientNotification() As Nullable(Of Boolean)
Public Set
End Set
End Property
[C#]
public bool? ClientNotification { public set; }

Property Value

The client notification enabled.

Remarks

Ttrue if client notifications have to be enabled; false otherwise

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


ConcurrencyLevel Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.ConcurrencyLevel Property

Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.

[Visual Basic]
Public WriteOnly Property ConcurrencyLevel() As Integer
Public Set
End Set
End Property
[C#]
public int ConcurrencyLevel { public set; }

Property Value

The concurrency level.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Destroy Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Destroy Property

Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)

[Visual Basic]
Public WriteOnly Property Destroy() As Boolean
Public Set
End Set
End Property
[C#]
public bool Destroy { public set; }

Property Value

true if destroy region on shutdown; otherwise, false.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


DiskPolicy Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.DiskPolicy Property

Sets the disk policy. Only used when a new region is created.

[Visual Basic]
Public WriteOnly Property DiskPolicy() As DiskPolicyType
Public Set
End Set
End Property
[C#]
public DiskPolicyType DiskPolicy { public set; }

Property Value

The region disk policy.

Remarks

Overrides the settings specified through Attributes

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Endpoints Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Endpoints Property

Sets the endpoints for a client region. It is a comma separated list of host:port pairs.

[Visual Basic]
Public WriteOnly Property Endpoints() As String
Public Set
End Set
End Property
[C#]
public string Endpoints { public set; }

Property Value

The endpoints.

Remarks

If the endpoints are set then the region is taken to be a Thin-client region that interacts with the GemFire Java cacheserver.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


EntryIdleTimeout Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.EntryIdleTimeout Property

Sets the entry idle timeout in seconds

[Visual Basic]
Public WriteOnly Property EntryIdleTimeout() As UInt32
Public Set
End Set
End Property
[C#]
public uint EntryIdleTimeout { public set; }

Property Value

The entry idle timeout.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


EntryIdleTimeoutAction Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.EntryIdleTimeoutAction Property

Sets the entry idle timeout expiration action.

[Visual Basic]
Public WriteOnly Property EntryIdleTimeoutAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction EntryIdleTimeoutAction { public set; }

Property Value

The entry idle timeout action.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


EntryTimeToLive Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.EntryTimeToLive Property

Sets the entry time to live in seconds

[Visual Basic]
Public WriteOnly Property EntryTimeToLive() As UInt32
Public Set
End Set
End Property
[C#]
public uint EntryTimeToLive { public set; }

Property Value

The entry time to live.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


EntryTimeToLiveAction Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.EntryTimeToLiveAction Property

Sets the entry time to live expiration action.

[Visual Basic]
Public WriteOnly Property EntryTimeToLiveAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction EntryTimeToLiveAction { public set; }

Property Value

The entry time to live action.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


InitialCapacity Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.InitialCapacity Property

Sets the initial capacity of the map used for storing the entries. Default is 16

[Visual Basic]
Public WriteOnly Property InitialCapacity() As Integer
Public Set
End Set
End Property
[C#]
public int InitialCapacity { public set; }

Property Value

The initial capacity.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Interests Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Interests Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.Interests

[Visual Basic]
Public Property Interests() As IInterest
Public Get
End Get
Public Set
End Set
End Property
[C#]
public IInterest[] Interests { public get; public set; }

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.IsSingleton Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.IsSingleton

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


LoadFactor Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.LoadFactor Property

Sets the load factor of the map used for storing the entries. Default 0.75

[Visual Basic]
Public WriteOnly Property LoadFactor() As Single
Public Set
End Set
End Property
[C#]
public float LoadFactor { public set; }

Property Value

The load factor.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


LocalScope Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.LocalScope Property

Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.

[Visual Basic]
Public WriteOnly Property LocalScope() As Boolean
Public Set
End Set
End Property
[C#]
public bool LocalScope { public set; }

Property Value

true if creat a locally coped region; otherwise, false.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


LruEntriesLimit Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.LruEntriesLimit Property

Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.

[Visual Basic]
Public WriteOnly Property LruEntriesLimit() As Nullable(Of UInt32)
Public Set
End Set
End Property
[C#]
public uint? LruEntriesLimit { public set; }

Property Value

The limit of the number of entries before eviction starts. Defaults to 0, meaning no LRU actions will used.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Name Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.Name Property

Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.

[Visual Basic]
Public WriteOnly Property Name() As String
Public Set
End Set
End Property
[C#]
public string Name { public set; }

Property Value

The region name.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


ObjectName Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.ObjectName Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectName

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectName() As String _
Implements IObjectNameAware.ObjectName

Public Set
End Set
End Property
[C#]
public string ObjectName { public set; }

Implements

IObjectNameAware.ObjectName

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.ObjectType Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionFactoryObject.ObjectType

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


PoolName Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.PoolName Property

Sets the name of the pool for a client region

[Visual Basic]
Public WriteOnly Property PoolName() As String
Public Set
End Set
End Property
[C#]
public string PoolName { public set; }

Property Value

The name of the pool to attach to this region.

Remarks

The pool with the name specified must be already created.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionIdleTimeout Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.RegionIdleTimeout Property

Sets the region idle timeout in seconds

[Visual Basic]
Public WriteOnly Property RegionIdleTimeout() As UInt32
Public Set
End Set
End Property
[C#]
public uint RegionIdleTimeout { public set; }

Property Value

The region idle timeout.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionIdleTimeoutAction Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.RegionIdleTimeoutAction Property

Sets the region idle timeout expiration action.

[Visual Basic]
Public WriteOnly Property RegionIdleTimeoutAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction RegionIdleTimeoutAction { public set; }

Property Value

The region idle timeout action.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionTimeToLive Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.RegionTimeToLive Property

Sets the region time to live in seconds for the region as a whole

[Visual Basic]
Public WriteOnly Property RegionTimeToLive() As UInt32
Public Set
End Set
End Property
[C#]
public uint RegionTimeToLive { public set; }

Property Value

The region time to live.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionTimeToLiveAction Property

Spring GemFire 1.0 M1 API Reference

RegionFactoryObject.RegionTimeToLiveAction Property

Sets the region time to live expiration action.

[Visual Basic]
Public WriteOnly Property RegionTimeToLiveAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction RegionTimeToLiveAction { public set; }

Property Value

The region time to live action.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject Methods

The methods of the RegionFactoryObject class are listed below. For a complete list of RegionFactoryObject class members, see the RegionFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostProcess | Subclasses can override this method to further customize the Region configuration.
PostProcessAttributes | Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the RegionFactoryObject.
RegisterInterests | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.RegisterInterests
SetCallbacks | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)
SetDistributionProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)
SetExpirationProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)
SetStorageProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.AfterPropertiesSet

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.Dispose Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.Dispose

[Visual Basic]
Public NotOverridable Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.GetObject Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.GetObject

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Implements

IFactoryObject.GetObject

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.PostProcess Method

Subclasses can override this method to further customize the Region configuration.

[Visual Basic]
Protected Overridable Sub PostProcess( _
ByVal region As Region _
)
[C#]
protected virtual void PostProcess(
Region region
);

Parameters

region
The region.

Remarks

Post-process the region object for this factory bean during the initialization process. The object is already initialized and configured by the factory object before this method is invoked.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.PostProcessAttributes Method

Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the RegionFactoryObject.

[Visual Basic]
Protected Overridable Sub PostProcessAttributes( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void PostProcessAttributes(
AttributesFactory attributesFactory
);

Parameters

attributesFactory
The attributes factory.

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.RegisterInterests Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.RegisterInterests

[Visual Basic]
Protected Overridable Sub RegisterInterests()
[C#]
protected virtual void RegisterInterests();

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.SetCallbacks Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetCallbacks( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetCallbacks(
AttributesFactory attributesFactory
);

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.SetDistributionProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetDistributionProperties( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetDistributionProperties(
AttributesFactory attributesFactory
);

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.SetExpirationProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetExpirationProperties( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetExpirationProperties(
AttributesFactory attributesFactory
);

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


RegionFactoryObject.SetStorageProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetStorageProperties( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetStorageProperties(
AttributesFactory attributesFactory
);

See Also

RegionFactoryObject Class | Spring.Data.GemFire Namespace


Spring.Data.GemFireHierarchy

Spring GemFire 1.0 M1 API Reference

Spring.Data.GemFire Hierarchy

Object
AllKeysInterest ---- IInterest
KeyInterest ---- IInitializingObject
RegexInterest ---- IInitializingObject
CacheFactoryObject ---- IPersistenceExceptionTranslator, IFactoryObject, IInitializingObject, IObjectNameAware, IDisposable
GemFireCacheUtils
IInterest
RegionFactoryObject ---- IFactoryObject, IInitializingObject, IObjectNameAware, IDisposable
Exception ---- ISerializable
DataAccessException
NonTransientDataAccessException
UncategorizedDataAccessException
GemFireSystemException
ValueType
Enum ---- IComparable, IConvertible, IFormattable
InterestResultPolicy

See Also

Spring.Data.GemFire Namespace