Introduction

Spring GemFire Integration focuses on integrating Spring Framework's powerful, non-invasive programming model and concepts with Gemstone's GemFire Enterprise Fabric, providing easier configuration, use and high-level abstractions.

Please refer to the reference documentation for additional information.

Send comments on this topic.

© SpringSource 2011 All Rights Reserved.


Spring.Data.GemFire

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire Assembly

Referenced Assemblies

Assembly Reference | Description
Common.Logging |
GemStone.GemFire.Cache |
mscorlib |
mscorlib |
Spring.Core |
Spring.Data |
System |
System.Xml |

Namespaces

Namespace | Description
Spring.Data.GemFire | This namespace contains all core classes making up the Spring GemFire project.
Spring.Data.GemFire.Caching | This namespace contains all core classes making up the Spring GemFire project.
Spring.Data.GemFire.Config | This namespace contains all classes providing Cache advice support for the Spring GemFire project.

Classes

Class | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
CacheFactoryObject | Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.
CacheParser | Parser for definitions.
ClientRegionFactoryObject | FactoryObject for creating generic Gemfire Region. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.
ClientRegionParser | Parser for definitions.
GemFireCache | Cache implementation for Gemfire
GemFireCacheUtils | Helper class featuring methods for GemFire Cache or Region handling.
GemfireNamespaceParser | Namespace parser for GemFire
GemFireSystemException GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete
Spring.Data.Dao
exceptions.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
LookupRegionParser | Parser for definitions.
PoolConnection | Simple holder class used for configuring servers or locators for GemFire pools.
PoolFactoryDefaults | Static value for default values of the Pool
PoolFactoryObject | Factory object for easy declaration and configuration of a GemFire pool.
PoolParser | Parser for definitions.
RegexInterest | Cache interest based on regular expression rather then individual key types.
RegionAttributesFactoryObject | Create a Gemstone.Gemfire.Cache.RegionsAttribute using standard .NET setter properties.
RegionLookupFactoryObject | Simple FactoryObject for retrieving generic GemFire Regions. If the region doesn't exist, an exception is thrown. For declaring and configuring new regions, see ClientRegionFactoryObject.

Interfaces

Interface | Description
IInterest | Basic holder interface for registering an interest in cached data.

Enumerations

Enumeration | Description
InterestResultPolicy | Enumeration for the policy of what to load on region initialization when registering for interest in cached data

Send comments on this topic.

© SpringSource 2011. All Rights Reserved.

Generated from assembly Spring.Data.GemFire [1.0.1.476] by NDoc3


Spring.Data.GemFire

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire Namespace

This namespace contains all core classes making up the Spring GemFire project.

Namespace Hierarchy

Classes

Class | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
CacheFactoryObject | Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.
ClientRegionFactoryObject | FactoryObject for creating generic Gemfire Region. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.
GemFireCacheUtils | Helper class featuring methods for GemFire Cache or Region handling.
GemFireSystemException GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete
Spring.Data.Dao
exceptions.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
PoolConnection | Simple holder class used for configuring servers or locators for GemFire pools.
PoolFactoryDefaults | Static value for default values of the Pool
PoolFactoryObject | Factory object for easy declaration and configuration of a GemFire pool.
RegexInterest | Cache interest based on regular expression rather then individual key types.
RegionAttributesFactoryObject | Create a Gemstone.Gemfire.Cache.RegionsAttribute using standard .NET setter properties.
RegionLookupFactoryObject | Simple FactoryObject for retrieving generic GemFire Regions. If the region doesn't exist, an exception is thrown. For declaring and configuring new regions, see ClientRegionFactoryObject.

Interfaces

Interface | Description
IInterest | Basic holder interface for registering an interest in cached data.

Enumerations

Enumeration | Description
InterestResultPolicy | Enumeration for the policy of what to load on region initialization when registering for interest in cached data


AllKeysInterest Class

Basic holder class for registering an all-key based interest in cached data.

For a list of all members of this type, see AllKeysInterest Members .

System.Object
AllKeysInterest
KeyInterest
RegexInterest

[Visual Basic]
Public Class AllKeysInterest
Implements IInterest
[C#]
public class AllKeysInterest : IInterest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

AllKeysInterest Members | Spring.Data.GemFire Namespace


AllKeysInterest Members

AllKeysInterest overview

Public Instance Constructors

AllKeysInterest Overloaded. Initializes a new instance of the AllKeysInterest class.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

Overload List

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest()

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(InterestResultPolicy)

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(InterestResultPolicy,bool)

Initializes a new instance of the AllKeysInterest class.

public AllKeysInterest(bool)

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
AllKeysInterest();

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal durable As Boolean _
)
[C#]
AllKeysInterest(
bool durable
);

Parameters

durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal policy As InterestResultPolicy _
)
[C#]
AllKeysInterest(
InterestResultPolicy policy
);

Parameters

policy
The policy.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Constructor

Initializes a new instance of the AllKeysInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
AllKeysInterest(
InterestResultPolicy policy,
bool durable
);

Parameters

policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace | AllKeysInterest Constructor Overload List


AllKeysInterest Fields

The fields of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Protected Instance Fields

durable | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


Durable Property

Spring GemFire 1.0.1 API Reference

AllKeysInterest.Durable Property

Gets or sets a value indicating whether this AllKeysInterest is durable.

[Visual Basic]
Public NotOverridable Property Durable() As Boolean _
Implements IInterest.Durable

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Durable { public get; public set; }

Property Value

true if durable; otherwise, false.

Implements

IInterest.Durable

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


Policy Property

Spring GemFire 1.0.1 API Reference

AllKeysInterest.Policy Property

Gets or sets the policy.

[Visual Basic]
Public NotOverridable Property Policy() As InterestResultPolicy _
Implements IInterest.Policy

Public Get
End Get
Public Set
End Set
End Property
[C#]
public InterestResultPolicy Policy { public get; public set; }

Property Value

The policy.

Implements

IInterest.Policy

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Properties

The properties of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest Methods

The methods of the AllKeysInterest class are listed below. For a complete list of AllKeysInterest class members, see the AllKeysInterest Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


AllKeysInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

AllKeysInterest Class | Spring.Data.GemFire Namespace


CacheFactoryObject Class

Factory used for configuring a Gemfire Cache manager. Allows either retrieval of an existing, opened cache or the creation of a new one.

For a list of all members of this type, see CacheFactoryObject Members .

System.Object
CacheFactoryObject

[Visual Basic]
Public Class CacheFactoryObject
Implements IDisposable, IInitializingObject, IObjectNameAware, IFactoryObject, IPersistenceExceptionTranslator
[C#]
public class CacheFactoryObject : IDisposable, IInitializingObject, IObjectNameAware, IFactoryObject, IPersistenceExceptionTranslator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class implements the IPersistenceExceptionTranslator interface, as auto-detected by Spring's PersistenceExceptionTranslationPostProcessor for AOP-based translation of native exceptions to Spring DataAccessExceptions. Hence, the presence of this class automatically enables a PersistenceExceptionTranslationPostProcessor to translate GemFire exceptions.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

CacheFactoryObject Members | Spring.Data.GemFire Namespace


CacheFactoryObject Members

CacheFactoryObject overview

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

Public Instance Constructors

CacheFactoryObject Constructor Initializes a new instance of the CacheFactoryObject class.

Public Instance Properties

CacheXml | Sets the name of the cache XML that can be used to configure the cache.
DisconnectOnClose | Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a bug in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.
DistributedSystemName | Sets the name of the distributed system.
IsSingleton | Returns true
KeepAliveOnClose | Sets a value indicating whether to call cache.close(keepalive) which determines whether to keep a durable client's queue alive.
ObjectName | Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.
ObjectType | Returns Gemstone.GemFire.Cache.Cache
Properties | Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

Public Instance Methods

AfterPropertiesSet | Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.
Dispose | Closes the cache and disconnects from the distributed system.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Returns the cache object
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateExceptionIfPossible | Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

Protected Instance Properties

IsDurableClient Missing <summary> documentation for P:Spring.Data.GemFire.CacheFactoryObject.IsDurableClient

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Constructor

Initializes a new instance of the CacheFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
CacheFactoryObject();

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Fields

The fields of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.log Field

Missing <summary> documentation for F:Spring.Data.GemFire.CacheFactoryObject.log

[Visual Basic]
Protected Shared ReadOnly log As ILog
[C#]
protected static readonly ILog log;

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Properties

The properties of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Public Instance Properties

CacheXml | Sets the name of the cache XML that can be used to configure the cache.
DisconnectOnClose | Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a bug in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.
DistributedSystemName | Sets the name of the distributed system.
IsSingleton | Returns true
KeepAliveOnClose | Sets a value indicating whether to call cache.close(keepalive) which determines whether to keep a durable client's queue alive.
ObjectName | Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.
ObjectType | Returns Gemstone.GemFire.Cache.Cache
Properties | Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

Protected Instance Properties

IsDurableClient Missing <summary> documentation for P:Spring.Data.GemFire.CacheFactoryObject.IsDurableClient

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheXml Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.CacheXml Property

Sets the name of the cache XML that can be used to configure the cache.

[Visual Basic]
Public WriteOnly Property CacheXml() As String
Public Set
End Set
End Property
[C#]
public string CacheXml { public set; }

Property Value

The cache XML.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


DisconnectOnClose Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.DisconnectOnClose Property

Sets a value indicating whether to call DistributedSystem.Disconnect when this object is disposed. There is a bug in the 3.0.0.9 client that may hang calls to close. The default is true, set to false if you experience a hang in the application.

[Visual Basic]
Public WriteOnly Property DisconnectOnClose() As Boolean
Public Set
End Set
End Property
[C#]
public bool DisconnectOnClose { public set; }

Property Value

true to call DistributedSystem.Disconnect when this object is dispose; otherwise, false.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


DistributedSystemName Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.DistributedSystemName Property

Sets the name of the distributed system.

[Visual Basic]
Public WriteOnly Property DistributedSystemName() As String
Public Set
End Set
End Property
[C#]
public string DistributedSystemName { public set; }

Property Value

The name of the distributed system.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


IsDurableClient Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.IsDurableClient Property

Missing <summary> documentation for P:Spring.Data.GemFire.CacheFactoryObject.IsDurableClient

[Visual Basic]
Protected ReadOnly Property IsDurableClient() As Boolean
Protected Get
End Get
End Property
[C#]
protected bool IsDurableClient { protected get; }

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.IsSingleton Property

Returns true

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


KeepAliveOnClose Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.KeepAliveOnClose Property

Sets a value indicating whether to call cache.close(keepalive) which determines whether to keep a durable client's queue alive.

[Visual Basic]
Public WriteOnly Property KeepAliveOnClose() As Boolean
Public Set
End Set
End Property
[C#]
public bool KeepAliveOnClose { public set; }

Property Value

true call keep alive on close; otherwise, false.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


ObjectName Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.ObjectName Property

Sets the name of the cache to the name of the Spring object definition. Can be overrided by specifying 'name' as the key in the Properties collection.

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectName() As String _
Implements IObjectNameAware.ObjectName

Public Set
End Set
End Property
[C#]
public string ObjectName { public set; }

Implements

IObjectNameAware.ObjectName

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.ObjectType Property

Returns Gemstone.GemFire.Cache.Cache

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


Properties Property

Spring GemFire 1.0.1 API Reference

CacheFactoryObject.Properties Property

Sets the properties used to configure the Gemfire Cache. These are copied into a GemStone.GemFire.Cache.Properties object and used to initialize the DistributedSystem.

[Visual Basic]
Public WriteOnly Property Properties() As NameValueCollection
Public Set
End Set
End Property
[C#]
public NameValueCollection Properties { public set; }

Property Value

The properties used to configure the cache..

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject Methods

The methods of the CacheFactoryObject class are listed below. For a complete list of CacheFactoryObject class members, see the CacheFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.
Dispose | Closes the cache and disconnects from the distributed system.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Returns the cache object
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateExceptionIfPossible | Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.AfterPropertiesSet Method

Initialization callback called by Spring. Responsible for connecting to the distributed system and creating the cache.

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.Dispose Method

Closes the cache and disconnects from the distributed system.

[Visual Basic]
Public NotOverridable Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.GetObject Method

Returns the cache object

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Return Value

The cache object

Implements

IFactoryObject.GetObject

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace


CacheFactoryObject.TranslateExceptionIfPossible Method

Translate the given exception thrown by a persistence framework to a corresponding exception from Spring's generic DataAccessException hierarchy, if possible.

[Visual Basic]
Public NotOverridable Sub TranslateExceptionIfPossible( _
ByVal ex As Exception _
) _
Implements IPersistenceExceptionTranslator.TranslateExceptionIfPossible
[C#]
public DataAccessException TranslateExceptionIfPossible(
Exception ex
);

Parameters

ex
The exception thrown.

Return Value

the corresponding DataAccessException (or

null
if the exception could not be translated, as in this case it may result from user code rather than an actual persistence problem)

Implements

IPersistenceExceptionTranslator.TranslateExceptionIfPossible

Remarks

Do not translate exceptions that are not understand by this translator: for example, if coming from another persistence framework, or resulting from user code and unrelated to persistence.

Of particular importance is the correct translation to DataIntegrityViolationException for example on constraint violation. Implementations may use Spring ADO.NET Framework's sophisticated exception translation to provide further information in the event of SQLException as a root cause.

See Also

CacheFactoryObject Class | Spring.Data.GemFire Namespace | DataIntegrityViolationException | ErrorCodeExceptionTranslator


ClientRegionFactoryObject Class

FactoryObject for creating generic Gemfire Region. Will try to first locate the region (by name) and, in case none if found, proceed to creating one using the given settings.

For a list of all members of this type, see ClientRegionFactoryObject Members .

System.Object
RegionLookupFactoryObject
ClientRegionFactoryObject

[Visual Basic]
Public Class ClientRegionFactoryObject
Inherits RegionLookupFactoryObject
Implements IDisposable, IObjectFactoryAware
[C#]
public class ClientRegionFactoryObject : RegionLookupFactoryObject, IDisposable, IObjectFactoryAware

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

ClientRegionFactoryObject Members | Spring.Data.GemFire Namespace


ClientRegionFactoryObject Members

ClientRegionFactoryObject overview

Public Instance Constructors

ClientRegionFactoryObject Constructor Initializes a new instance of the ClientRegionFactoryObject class.

Public Instance Properties

Attributes | Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.
Cache (inherited from RegionLookupFactoryObject) | Sets the cache used for creating the region
CacheListeners | Gets or sets the cache listener.
CacheLoader | Sets the cache loader.
CacheWriter | Gets or sets the cache writer.
Destroy | Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)
Endpoints | Sets the endpoints for a client region. It is a comma separated list of host:port pairs.
Interests | Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.Interests
IsSingleton (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.IsSingleton
Name (inherited from RegionLookupFactoryObject) | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectFactory | Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.ObjectFactory
ObjectName (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectName
ObjectType (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectType
PoolName | Sets the name of the pool for a client region

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

region (inherited from RegionLookupFactoryObject) Missing <summary> documentation for F:Spring.Data.GemFire.RegionLookupFactoryObject.region

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupFallback | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostProcess | Subclasses can override this method to further customize the Region configuration.
PostProcessAttributes | Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the ClientRegionFactoryObject.
RegisterInterests | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.RegisterInterests
SetCallbacks | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)
SetDistributionProperties | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject Constructor

Initializes a new instance of the ClientRegionFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
ClientRegionFactoryObject();

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject Properties

The properties of the ClientRegionFactoryObject class are listed below. For a complete list of ClientRegionFactoryObject class members, see the ClientRegionFactoryObject Members topic.

Public Instance Properties

Attributes | Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.
Cache (inherited from RegionLookupFactoryObject) | Sets the cache used for creating the region
CacheListeners | Gets or sets the cache listener.
CacheLoader | Sets the cache loader.
CacheWriter | Gets or sets the cache writer.
Destroy | Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)
Endpoints | Sets the endpoints for a client region. It is a comma separated list of host:port pairs.
Interests | Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.Interests
IsSingleton (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.IsSingleton
Name (inherited from RegionLookupFactoryObject) | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectFactory | Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.ObjectFactory
ObjectName (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectName
ObjectType (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectType
PoolName | Sets the name of the pool for a client region

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


Attributes Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.Attributes Property

Sets the region attributes used for the region by this factory. Allows maximum control in specifying the region settings.

[Visual Basic]
Public WriteOnly Property Attributes() As RegionAttributes
Public Set
End Set
End Property
[C#]
public RegionAttributes Attributes { public set; }

Property Value

The attributes.

Remarks

Used only when a new region is created.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheListeners Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.CacheListeners Property

Gets or sets the cache listener.

[Visual Basic]
Public WriteOnly Property CacheListeners() As ICacheListener
Public Set
End Set
End Property
[C#]
public ICacheListener[] CacheListeners { public set; }

Property Value

The cache listener.

Remarks

Sets the cache listeners used for the region used by this factory. Used only when a new region is created.Overrides the settings specified through Attributes

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheLoader Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.CacheLoader Property

Sets the cache loader.

[Visual Basic]
Public WriteOnly Property CacheLoader() As ICacheLoader
Public Set
End Set
End Property
[C#]
public ICacheLoader CacheLoader { public set; }

Property Value

The cache loader to set on a newly created region

Remarks

Sets the cache loader used for the region used by this factory. Used only when a new region is created. Overrides the settings specified through Attributes

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


CacheWriter Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.CacheWriter Property

Gets or sets the cache writer.

[Visual Basic]
Public WriteOnly Property CacheWriter() As ICacheWriter
Public Set
End Set
End Property
[C#]
public ICacheWriter CacheWriter { public set; }

Property Value

The cache writer to set on a newly created region

Remarks

Sets the cache writer used for the region used by this factory. Used only when a new region is created. Overrides the settings specified through Attributes

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


Destroy Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.Destroy Property

Sets a value indicating whether the region created by this factory object will be destroyed on shutdown (default false)

[Visual Basic]
Public WriteOnly Property Destroy() As Boolean
Public Set
End Set
End Property
[C#]
public bool Destroy { public set; }

Property Value

true if destroy region on shutdown; otherwise, false.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


Endpoints Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.Endpoints Property

Sets the endpoints for a client region. It is a comma separated list of host:port pairs.

[Visual Basic]
Public WriteOnly Property Endpoints() As String
Public Set
End Set
End Property
[C#]
public string Endpoints { public set; }

Property Value

The endpoints.

Remarks

If the endpoints are set then the region is taken to be a Thin-client region that interacts with the GemFire Java cacheserver.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


Interests Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.Interests Property

Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.Interests

[Visual Basic]
Public Property Interests() As IInterest
Public Get
End Get
Public Set
End Set
End Property
[C#]
public IInterest[] Interests { public get; public set; }

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ObjectFactory Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.ObjectFactory Property

Missing <summary> documentation for P:Spring.Data.GemFire.ClientRegionFactoryObject.ObjectFactory

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectFactory() As IObjectFactory _
Implements IObjectFactoryAware.ObjectFactory

Public Set
End Set
End Property
[C#]
public IObjectFactory ObjectFactory { public set; }

Implements

IObjectFactoryAware.ObjectFactory

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


PoolName Property

Spring GemFire 1.0.1 API Reference

ClientRegionFactoryObject.PoolName Property

Sets the name of the pool for a client region

[Visual Basic]
Public WriteOnly Property PoolName() As String
Public Set
End Set
End Property
[C#]
public string PoolName { public set; }

Property Value

The name of the pool to attach to this region.

Remarks

The pool with the name specified must be already created.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject Methods

The methods of the ClientRegionFactoryObject class are listed below. For a complete list of ClientRegionFactoryObject class members, see the ClientRegionFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject (inherited from RegionLookupFactoryObject) | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupFallback | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostProcess | Subclasses can override this method to further customize the Region configuration.
PostProcessAttributes | Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the ClientRegionFactoryObject.
RegisterInterests | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.RegisterInterests
SetCallbacks | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)
SetDistributionProperties | Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.AfterPropertiesSet

[Visual Basic]
Public Overrides Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public override void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.Dispose Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.Dispose

[Visual Basic]
Public NotOverridable Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.LookupFallback Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)

[Visual Basic]
Protected Overrides Sub LookupFallback( _
ByVal cacheObject As Cache, _
ByVal regionName As String _
)
[C#]
protected override Region LookupFallback(
Cache cacheObject,
string regionName
);

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.PostProcess Method

Subclasses can override this method to further customize the Region configuration.

[Visual Basic]
Protected Overridable Sub PostProcess( _
ByVal region As Region _
)
[C#]
protected virtual void PostProcess(
Region region
);

Parameters

region
The region.

Remarks

Post-process the region object for this factory object during the initialization process. The object is already initialized and configured by the factory object before this method is invoked.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.PostProcessAttributes Method

Indented for subclasses to override and provide additional configuration of the AttributesFactory, for example setting persistence manager option is not currenlty exposed as a public property on the ClientRegionFactoryObject.

[Visual Basic]
Protected Overridable Sub PostProcessAttributes( _
ByVal attrFactory As AttributesFactory _
)
[C#]
protected virtual void PostProcessAttributes(
AttributesFactory attrFactory
);

Parameters

attrFactory
The attributes factory.

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.RegisterInterests Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.RegisterInterests

[Visual Basic]
Protected Overridable Sub RegisterInterests()
[C#]
protected virtual void RegisterInterests();

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.SetCallbacks Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetCallbacks(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetCallbacks( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetCallbacks(
AttributesFactory attributesFactory
);

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


ClientRegionFactoryObject.SetDistributionProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.ClientRegionFactoryObject.SetDistributionProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetDistributionProperties( _
ByVal attributesFactory As AttributesFactory _
)
[C#]
protected virtual void SetDistributionProperties(
AttributesFactory attributesFactory
);

See Also

ClientRegionFactoryObject Class | Spring.Data.GemFire Namespace


GemFireCacheUtils Class

Helper class featuring methods for GemFire Cache or Region handling.

For a list of all members of this type, see GemFireCacheUtils Members .

System.Object
GemFireCacheUtils

[Visual Basic]
Public MustInherit Class GemFireCacheUtils
[C#]
public abstract class GemFireCacheUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemFireCacheUtils Members | Spring.Data.GemFire Namespace


GemFireCacheUtils Members

GemFireCacheUtils overview

Public Static (Shared) Methods

ConvertGemFireAccessException Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

GemFireCacheUtils Constructor Initializes a new instance of the GemFireCacheUtils class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils Constructor

Initializes a new instance of the GemFireCacheUtils class.

[Visual Basic]
Protected Sub New()
[C#]
GemFireCacheUtils();

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils Methods

The methods of the GemFireCacheUtils class are listed below. For a complete list of GemFireCacheUtils class members, see the GemFireCacheUtils Members topic.

Public Static (Shared) Methods

ConvertGemFireAccessException Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireCacheUtils.ConvertGemFireAccessException Method

Converts the GemFireException into an appropriate one from the Spring.Data.Dao hierarchy.

[Visual Basic]
Public Shared Sub ConvertGemFireAccessException( _
ByVal ex As GemFireException _
)
[C#]
public static DataAccessException ConvertGemFireAccessException(
GemFireException ex
);

Parameters

ex
The GemFire exception.

Return Value

A Spring DataAccessException

See Also

GemFireCacheUtils Class | Spring.Data.GemFire Namespace


GemFireSystemException Class

GemFire-specific subclass of UncategorizedDataAccessException, for GemFire system errors that do not match any concrete

Spring.Data.Dao
exceptions.

For a list of all members of this type, see GemFireSystemException Members .

System.Object
Exception
DataAccessException
NonTransientDataAccessException
UncategorizedDataAccessException
GemFireSystemException

[Visual Basic]
Public Class GemFireSystemException
Inherits UncategorizedDataAccessException
[C#]
public class GemFireSystemException : UncategorizedDataAccessException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemFireSystemException Members | Spring.Data.GemFire Namespace


GemFireSystemException Members

GemFireSystemException overview

Public Instance Constructors

GemFireSystemException Overloaded. Initializes a new instance of the GemFireSystemException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

GemFireSystemException Overloaded. Initializes a new instance of the GemFireSystemException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

Overload List

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException()

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException(GemFireException)

Creates a new instance of the GemFireSystemException class.

protected GemFireSystemException(SerializationInfo,StreamingContext)

Initializes a new instance of the GemFireSystemException class.

public GemFireSystemException(string)

Creates a new instance of the GemFireSystemException class with the specified message and root cause.

public GemFireSystemException(string,Exception)

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New()
[C#]
GemFireSystemException();

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String _
)
[C#]
GemFireSystemException(
string message
);

Parameters

message
The message.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Creates a new instance of the GemFireSystemException class with the specified message and root cause.

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String, _
ByVal rootCause As Exception _
)
[C#]
GemFireSystemException(
string message,
Exception rootCause
);

Parameters

message
A message about the exception.
rootCause
The root exception that is being wrapped.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Initializes a new instance of the GemFireSystemException class.

[Visual Basic]
Public Overloads Sub New( _
ByVal cause As GemFireException _
)
[C#]
GemFireSystemException(
GemFireException cause
);

Parameters

cause
The cause.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


GemFireSystemException Constructor

Creates a new instance of the GemFireSystemException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
GemFireSystemException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

GemFireSystemException Class | Spring.Data.GemFire Namespace | GemFireSystemException Constructor Overload List


IInterest Interface

Basic holder interface for registering an interest in cached data.

For a list of all members of this type, see IInterest Members .

[Visual Basic]
Public Interface IInterest
[C#]
public interface IInterest

Types that implement IInterest

Type | Description
AllKeysInterest | Basic holder class for registering an all-key based interest in cached data.
KeyInterest | Basic holder class for registering a keys based interest in cached data.
RegexInterest | Cache interest based on regular expression rather then individual key types.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

IInterest Members | Spring.Data.GemFire Namespace


IInterest Members

IInterest overview

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


IInterest Properties

The properties of the IInterest interface are listed below. For a complete list of IInterest interface members, see the IInterest Members topic.

Public Instance Properties

Durable | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy | Gets or sets the policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


Durable Property

Spring GemFire 1.0.1 API Reference

IInterest.Durable Property

Gets or sets a value indicating whether this AllKeysInterest is durable.

[Visual Basic]
Public MustOverride Property Durable() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Durable { public get; public set; }

Property Value

true if durable; otherwise, false.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


Policy Property

Spring GemFire 1.0.1 API Reference

IInterest.Policy Property

Gets or sets the policy.

[Visual Basic]
Public MustOverride Property Policy() As InterestResultPolicy
Public Get
End Get
Public Set
End Set
End Property
[C#]
public InterestResultPolicy Policy { public get; public set; }

Property Value

The policy.

See Also

IInterest Interface | Spring.Data.GemFire Namespace


InterestResultPolicy Enumeration

Enumeration for the policy of what to load on region initialization when registering for interest in cached data

[Visual Basic]
Public Enum InterestResultPolicy
[C#]
public enum InterestResultPolicy

Members

Member Name | Description
KeysAndValues | The client receives a bulk load of all available keys and values matching the interest registration criteria. This is the default interest result policy.
Keys | The client receives a bulk load of all available keys matching the interest registration criteria.
None | The client does not receive any immediate bulk loading.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

Spring.Data.GemFire Namespace


KeyInterest Class

Basic holder class for registering a keys based interest in cached data.

For a list of all members of this type, see KeyInterest Members .

System.Object
AllKeysInterest
KeyInterest

[Visual Basic]
Public Class KeyInterest
Inherits AllKeysInterest
Implements IInitializingObject
[C#]
public class KeyInterest : AllKeysInterest, IInitializingObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

KeyInterest Members | Spring.Data.GemFire Namespace


KeyInterest Members

KeyInterest overview

Public Instance Constructors

KeyInterest Overloaded. Initializes a new instance of the KeyInterest class.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Keys | Gets or sets the keys.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

Overload List

Initializes a new instance of the KeyInterest class.

public KeyInterest()

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[])

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],InterestResultPolicy)

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],InterestResultPolicy,bool)

Initializes a new instance of the KeyInterest class.

public KeyInterest(ICacheableKey[],bool)

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
KeyInterest();

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey _
)
[C#]
KeyInterest(
ICacheableKey[] keys
);

Parameters

keys
The keys.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal durable As Boolean _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
bool durable
);

Parameters

keys
The keys.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal policy As InterestResultPolicy _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
InterestResultPolicy policy
);

Parameters

keys
The keys.
policy
The policy.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Constructor

Initializes a new instance of the KeyInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal keys As ICacheableKey, _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
KeyInterest(
ICacheableKey[] keys,
InterestResultPolicy policy,
bool durable
);

Parameters

keys
The keys.
policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace | KeyInterest Constructor Overload List


KeyInterest Properties

The properties of the KeyInterest class are listed below. For a complete list of KeyInterest class members, see the KeyInterest Members topic.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Keys | Gets or sets the keys.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


Keys Property

Spring GemFire 1.0.1 API Reference

KeyInterest.Keys Property

Gets or sets the keys.

[Visual Basic]
Public Property Keys() As ICacheableKey
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ICacheableKey[] Keys { public get; public set; }

Property Value

The keys.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest Methods

The methods of the KeyInterest class are listed below. For a complete list of KeyInterest class members, see the KeyInterest Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.KeyInterest.AfterPropertiesSet

[Visual Basic]
Public Overridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public virtual void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


KeyInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

KeyInterest Class | Spring.Data.GemFire Namespace


PoolConnection Class

Simple holder class used for configuring servers or locators for GemFire pools.

For a list of all members of this type, see PoolConnection Members .

System.Object
PoolConnection

[Visual Basic]
Public Class PoolConnection
[C#]
public class PoolConnection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

PoolConnection Members | Spring.Data.GemFire Namespace


PoolConnection Members

PoolConnection overview

Public Instance Constructors

PoolConnection Constructor Initializes a new instance of the PoolConnection class.

Public Instance Properties

Host | Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Host
Port | Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Port

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PoolConnection Class | Spring.Data.GemFire Namespace


PoolConnection Constructor

Initializes a new instance of the PoolConnection class.

[Visual Basic]
Public Sub New()
[C#]
PoolConnection();

See Also

PoolConnection Class | Spring.Data.GemFire Namespace


PoolConnection Properties

The properties of the PoolConnection class are listed below. For a complete list of PoolConnection class members, see the PoolConnection Members topic.

Public Instance Properties

Host | Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Host
Port | Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Port

See Also

PoolConnection Class | Spring.Data.GemFire Namespace


Host Property

Spring GemFire 1.0.1 API Reference

PoolConnection.Host Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Host

[Visual Basic]
Public Property Host() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Host { public get; public set; }

See Also

PoolConnection Class | Spring.Data.GemFire Namespace


Port Property

Spring GemFire 1.0.1 API Reference

PoolConnection.Port Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolConnection.Port

[Visual Basic]
Public Property Port() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int Port { public get; public set; }

See Also

PoolConnection Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults Class

Static value for default values of the Pool

For a list of all members of this type, see PoolFactoryDefaults Members .

System.Object
PoolFactoryDefaults

[Visual Basic]
Public MustInherit Class PoolFactoryDefaults
[C#]
public abstract class PoolFactoryDefaults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

PoolFactoryDefaults Members | Spring.Data.GemFire Namespace


PoolFactoryDefaults Members

PoolFactoryDefaults overview

Public Static (Shared) Fields

DEFAULT_FREE_CONNECTION_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_FREE_CONNECTION_TIMEOUT
DEFAULT_IDLE_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_IDLE_TIMEOUT
DEFAULT_LOAD_CONDITIONING_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_LOAD_CONDITIONING_INTERVAL
DEFAULT_MAX_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MAX_CONNECTIONS
DEFAULT_MIN_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MIN_CONNECTIONS
DEFAULT_MULTIUSER_AUTHENTICATION | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MULTIUSER_AUTHENTICATION
DEFAULT_PING_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PING_INTERVAL
DEFAULT_PR_SINGLE_HOP_ENABLED | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PR_SINGLE_HOP_ENABLED
DEFAULT_READ_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_READ_TIMEOUT
DEFAULT_RETRY_ATTEMPTS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_RETRY_ATTEMPTS
DEFAULT_SERVER_GROUP | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SERVER_GROUP
DEFAULT_SOCKET_BUFFER_SIZE | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SOCKET_BUFFER_SIZE
DEFAULT_STATISTIC_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_STATISTIC_INTERVAL
DEFAULT_SUBSCRIPTION_ACK_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ACK_INTERVAL
DEFAULT_SUBSCRIPTION_ENABLED | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ENABLED
DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT
DEFAULT_SUBSCRIPTION_REDUNDANCY | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_REDUNDANCY
DEFAULT_THREAD_LOCAL_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_THREAD_LOCAL_CONNECTIONS

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PoolFactoryDefaults Constructor Initializes a new instance of the PoolFactoryDefaults class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults Constructor

Initializes a new instance of the PoolFactoryDefaults class.

[Visual Basic]
Protected Sub New()
[C#]
PoolFactoryDefaults();

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults Fields

The fields of the PoolFactoryDefaults class are listed below. For a complete list of PoolFactoryDefaults class members, see the PoolFactoryDefaults Members topic.

Public Static (Shared) Fields

DEFAULT_FREE_CONNECTION_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_FREE_CONNECTION_TIMEOUT
DEFAULT_IDLE_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_IDLE_TIMEOUT
DEFAULT_LOAD_CONDITIONING_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_LOAD_CONDITIONING_INTERVAL
DEFAULT_MAX_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MAX_CONNECTIONS
DEFAULT_MIN_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MIN_CONNECTIONS
DEFAULT_MULTIUSER_AUTHENTICATION | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MULTIUSER_AUTHENTICATION
DEFAULT_PING_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PING_INTERVAL
DEFAULT_PR_SINGLE_HOP_ENABLED | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PR_SINGLE_HOP_ENABLED
DEFAULT_READ_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_READ_TIMEOUT
DEFAULT_RETRY_ATTEMPTS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_RETRY_ATTEMPTS
DEFAULT_SERVER_GROUP | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SERVER_GROUP
DEFAULT_SOCKET_BUFFER_SIZE | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SOCKET_BUFFER_SIZE
DEFAULT_STATISTIC_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_STATISTIC_INTERVAL
DEFAULT_SUBSCRIPTION_ACK_INTERVAL | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ACK_INTERVAL
DEFAULT_SUBSCRIPTION_ENABLED | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ENABLED
DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT
DEFAULT_SUBSCRIPTION_REDUNDANCY | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_REDUNDANCY
DEFAULT_THREAD_LOCAL_CONNECTIONS | Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_THREAD_LOCAL_CONNECTIONS

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_FREE_CONNECTION_TIMEOUT Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_FREE_CONNECTION_TIMEOUT

[Visual Basic]
Public Shared DEFAULT_FREE_CONNECTION_TIMEOUT As Integer
[C#]
public static int DEFAULT_FREE_CONNECTION_TIMEOUT;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_IDLE_TIMEOUT Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_IDLE_TIMEOUT

[Visual Basic]
Public Shared DEFAULT_IDLE_TIMEOUT As Integer
[C#]
public static int DEFAULT_IDLE_TIMEOUT;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_LOAD_CONDITIONING_INTERVAL Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_LOAD_CONDITIONING_INTERVAL

[Visual Basic]
Public Shared DEFAULT_LOAD_CONDITIONING_INTERVAL As Integer
[C#]
public static int DEFAULT_LOAD_CONDITIONING_INTERVAL;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_MAX_CONNECTIONS Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MAX_CONNECTIONS

[Visual Basic]
Public Shared DEFAULT_MAX_CONNECTIONS As Integer
[C#]
public static int DEFAULT_MAX_CONNECTIONS;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_MIN_CONNECTIONS Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MIN_CONNECTIONS

[Visual Basic]
Public Shared DEFAULT_MIN_CONNECTIONS As Integer
[C#]
public static int DEFAULT_MIN_CONNECTIONS;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_MULTIUSER_AUTHENTICATION Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_MULTIUSER_AUTHENTICATION

[Visual Basic]
Public Shared DEFAULT_MULTIUSER_AUTHENTICATION As Boolean
[C#]
public static bool DEFAULT_MULTIUSER_AUTHENTICATION;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_PING_INTERVAL Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PING_INTERVAL

[Visual Basic]
Public Shared DEFAULT_PING_INTERVAL As Integer
[C#]
public static int DEFAULT_PING_INTERVAL;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_PR_SINGLE_HOP_ENABLED Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_PR_SINGLE_HOP_ENABLED

[Visual Basic]
Public Shared DEFAULT_PR_SINGLE_HOP_ENABLED As Boolean
[C#]
public static bool DEFAULT_PR_SINGLE_HOP_ENABLED;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_READ_TIMEOUT Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_READ_TIMEOUT

[Visual Basic]
Public Shared DEFAULT_READ_TIMEOUT As Integer
[C#]
public static int DEFAULT_READ_TIMEOUT;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_RETRY_ATTEMPTS Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_RETRY_ATTEMPTS

[Visual Basic]
Public Shared DEFAULT_RETRY_ATTEMPTS As Integer
[C#]
public static int DEFAULT_RETRY_ATTEMPTS;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SERVER_GROUP Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SERVER_GROUP

[Visual Basic]
Public Shared DEFAULT_SERVER_GROUP As String
[C#]
public static string DEFAULT_SERVER_GROUP;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SOCKET_BUFFER_SIZE Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SOCKET_BUFFER_SIZE

[Visual Basic]
Public Shared DEFAULT_SOCKET_BUFFER_SIZE As Integer
[C#]
public static int DEFAULT_SOCKET_BUFFER_SIZE;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_STATISTIC_INTERVAL Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_STATISTIC_INTERVAL

[Visual Basic]
Public Shared DEFAULT_STATISTIC_INTERVAL As Integer
[C#]
public static int DEFAULT_STATISTIC_INTERVAL;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ACK_INTERVAL Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ACK_INTERVAL

[Visual Basic]
Public Shared DEFAULT_SUBSCRIPTION_ACK_INTERVAL As Integer
[C#]
public static int DEFAULT_SUBSCRIPTION_ACK_INTERVAL;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ENABLED Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_ENABLED

[Visual Basic]
Public Shared DEFAULT_SUBSCRIPTION_ENABLED As Boolean
[C#]
public static bool DEFAULT_SUBSCRIPTION_ENABLED;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT

[Visual Basic]
Public Shared DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT As Integer
[C#]
public static int DEFAULT_SUBSCRIPTION_MESSAGE_TRACKING_TIMEOUT;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_REDUNDANCY Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_SUBSCRIPTION_REDUNDANCY

[Visual Basic]
Public Shared DEFAULT_SUBSCRIPTION_REDUNDANCY As Integer
[C#]
public static int DEFAULT_SUBSCRIPTION_REDUNDANCY;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryDefaults.DEFAULT_THREAD_LOCAL_CONNECTIONS Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryDefaults.DEFAULT_THREAD_LOCAL_CONNECTIONS

[Visual Basic]
Public Shared DEFAULT_THREAD_LOCAL_CONNECTIONS As Boolean
[C#]
public static bool DEFAULT_THREAD_LOCAL_CONNECTIONS;

See Also

PoolFactoryDefaults Class | Spring.Data.GemFire Namespace


PoolFactoryObject Class

Factory object for easy declaration and configuration of a GemFire pool.

For a list of all members of this type, see PoolFactoryObject Members .

System.Object
PoolFactoryObject

[Visual Basic]
Public Class PoolFactoryObject
Implements IDisposable, IFactoryObject, IInitializingObject, IObjectNameAware, IApplicationContextAware
[C#]
public class PoolFactoryObject : IDisposable, IFactoryObject, IInitializingObject, IObjectNameAware, IApplicationContextAware

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If a new pool is created, its life-cycle is bound to that of the declaring container.

Note that if the pool already exists, it will be returned as is, without any modifications and its life cycle untouched by this factory.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

PoolFactoryObject Members | Spring.Data.GemFire Namespace


PoolFactoryObject Members

PoolFactoryObject overview

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryObject.log

Public Instance Constructors

PoolFactoryObject Constructor Initializes a new instance of the PoolFactoryObject class.

Public Instance Properties

ApplicationContext | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ApplicationContext
FreeConnectionTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.FreeConnectionTimeout
IdleTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IdleTimeout
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IsSingleton
KeepAlive | Sets a value indicating whether to keep alive
LoadConditioningInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.LoadConditioningInterval
Locators | Sets the locators.
MaxConnections | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MaxConnections
MinConnections | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MinConnections
Name | Sets the name.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectType
PingInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.PingInterval
Pool | Sets the pool.
ReadTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ReadTimeout
RetryAttempts | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.RetryAttempts
ServerGroup | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ServerGroup
Servers | Sets the servers.
SocketBufferSize | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SocketBufferSize
StatisticInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.StatisticInterval
SubscriptionAckInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionAckInterval
SubscriptionEnabled | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionEnabled
SubscriptionMessageTrackingTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionMessageTrackingTimeout
SubscriptionRedundancy | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionRedundancy

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObject(T) | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject``1
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject Constructor

Initializes a new instance of the PoolFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
PoolFactoryObject();

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject Fields

The fields of the PoolFactoryObject class are listed below. For a complete list of PoolFactoryObject class members, see the PoolFactoryObject Members topic.

Protected Static (Shared) Fields

log Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryObject.log

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject.log Field

Missing <summary> documentation for F:Spring.Data.GemFire.PoolFactoryObject.log

[Visual Basic]
Protected Shared ReadOnly log As ILog
[C#]
protected static readonly ILog log;

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject Properties

The properties of the PoolFactoryObject class are listed below. For a complete list of PoolFactoryObject class members, see the PoolFactoryObject Members topic.

Public Instance Properties

ApplicationContext | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ApplicationContext
FreeConnectionTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.FreeConnectionTimeout
IdleTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IdleTimeout
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IsSingleton
KeepAlive | Sets a value indicating whether to keep alive
LoadConditioningInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.LoadConditioningInterval
Locators | Sets the locators.
MaxConnections | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MaxConnections
MinConnections | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MinConnections
Name | Sets the name.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectType
PingInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.PingInterval
Pool | Sets the pool.
ReadTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ReadTimeout
RetryAttempts | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.RetryAttempts
ServerGroup | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ServerGroup
Servers | Sets the servers.
SocketBufferSize | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SocketBufferSize
StatisticInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.StatisticInterval
SubscriptionAckInterval | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionAckInterval
SubscriptionEnabled | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionEnabled
SubscriptionMessageTrackingTimeout | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionMessageTrackingTimeout
SubscriptionRedundancy | Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionRedundancy

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


ApplicationContext Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.ApplicationContext Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ApplicationContext

[Visual Basic]
Public NotOverridable WriteOnly Property ApplicationContext() As IApplicationContext _
Implements IApplicationContextAware.ApplicationContext

Public Set
End Set
End Property
[C#]
public IApplicationContext ApplicationContext { public set; }

Implements

IApplicationContextAware.ApplicationContext

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


FreeConnectionTimeout Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.FreeConnectionTimeout Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.FreeConnectionTimeout

[Visual Basic]
Public WriteOnly Property FreeConnectionTimeout() As Integer
Public Set
End Set
End Property
[C#]
public int FreeConnectionTimeout { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


IdleTimeout Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.IdleTimeout Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IdleTimeout

[Visual Basic]
Public WriteOnly Property IdleTimeout() As Integer
Public Set
End Set
End Property
[C#]
public int IdleTimeout { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.IsSingleton Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.IsSingleton

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


KeepAlive Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.KeepAlive Property

Sets a value indicating whether to keep alive

[Visual Basic]
Public WriteOnly Property KeepAlive() As Boolean
Public Set
End Set
End Property
[C#]
public bool KeepAlive { public set; }

Property Value

true if keep alive; otherwise, false.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


LoadConditioningInterval Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.LoadConditioningInterval Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.LoadConditioningInterval

[Visual Basic]
Public WriteOnly Property LoadConditioningInterval() As Integer
Public Set
End Set
End Property
[C#]
public int LoadConditioningInterval { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


Locators Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.Locators Property

Sets the locators.

[Visual Basic]
Public WriteOnly Property Locators() As IList
Public Set
End Set
End Property
[C#]
public IList Locators { public set; }

Property Value

The locators.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


MaxConnections Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.MaxConnections Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MaxConnections

[Visual Basic]
Public WriteOnly Property MaxConnections() As Integer
Public Set
End Set
End Property
[C#]
public int MaxConnections { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


MinConnections Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.MinConnections Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.MinConnections

[Visual Basic]
Public WriteOnly Property MinConnections() As Integer
Public Set
End Set
End Property
[C#]
public int MinConnections { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


Name Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.Name Property

Sets the name.

[Visual Basic]
Public WriteOnly Property Name() As String
Public Set
End Set
End Property
[C#]
public string Name { public set; }

Property Value

The name.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


ObjectName Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.ObjectName Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectName

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectName() As String _
Implements IObjectNameAware.ObjectName

Public Set
End Set
End Property
[C#]
public string ObjectName { public set; }

Implements

IObjectNameAware.ObjectName

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.ObjectType Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ObjectType

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PingInterval Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.PingInterval Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.PingInterval

[Visual Basic]
Public WriteOnly Property PingInterval() As Integer
Public Set
End Set
End Property
[C#]
public int PingInterval { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


Pool Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.Pool Property

Sets the pool.

[Visual Basic]
Public WriteOnly Property Pool() As Pool
Public Set
End Set
End Property
[C#]
public Pool Pool { public set; }

Property Value

The pool.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


ReadTimeout Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.ReadTimeout Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ReadTimeout

[Visual Basic]
Public WriteOnly Property ReadTimeout() As Integer
Public Set
End Set
End Property
[C#]
public int ReadTimeout { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


RetryAttempts Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.RetryAttempts Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.RetryAttempts

[Visual Basic]
Public WriteOnly Property RetryAttempts() As Integer
Public Set
End Set
End Property
[C#]
public int RetryAttempts { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


ServerGroup Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.ServerGroup Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.ServerGroup

[Visual Basic]
Public WriteOnly Property ServerGroup() As String
Public Set
End Set
End Property
[C#]
public string ServerGroup { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


Servers Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.Servers Property

Sets the servers.

[Visual Basic]
Public WriteOnly Property Servers() As IList
Public Set
End Set
End Property
[C#]
public IList Servers { public set; }

Property Value

The servers.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


SocketBufferSize Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.SocketBufferSize Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SocketBufferSize

[Visual Basic]
Public WriteOnly Property SocketBufferSize() As Integer
Public Set
End Set
End Property
[C#]
public int SocketBufferSize { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


StatisticInterval Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.StatisticInterval Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.StatisticInterval

[Visual Basic]
Public WriteOnly Property StatisticInterval() As Integer
Public Set
End Set
End Property
[C#]
public int StatisticInterval { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


SubscriptionAckInterval Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.SubscriptionAckInterval Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionAckInterval

[Visual Basic]
Public WriteOnly Property SubscriptionAckInterval() As Integer
Public Set
End Set
End Property
[C#]
public int SubscriptionAckInterval { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


SubscriptionEnabled Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.SubscriptionEnabled Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionEnabled

[Visual Basic]
Public WriteOnly Property SubscriptionEnabled() As Boolean
Public Set
End Set
End Property
[C#]
public bool SubscriptionEnabled { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


SubscriptionMessageTrackingTimeout Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.SubscriptionMessageTrackingTimeout Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionMessageTrackingTimeout

[Visual Basic]
Public WriteOnly Property SubscriptionMessageTrackingTimeout() As Integer
Public Set
End Set
End Property
[C#]
public int SubscriptionMessageTrackingTimeout { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


SubscriptionRedundancy Property

Spring GemFire 1.0.1 API Reference

PoolFactoryObject.SubscriptionRedundancy Property

Missing <summary> documentation for P:Spring.Data.GemFire.PoolFactoryObject.SubscriptionRedundancy

[Visual Basic]
Public WriteOnly Property SubscriptionRedundancy() As Integer
Public Set
End Set
End Property
[C#]
public int SubscriptionRedundancy { public set; }

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject Methods

The methods of the PoolFactoryObject class are listed below. For a complete list of PoolFactoryObject class members, see the PoolFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.AfterPropertiesSet
Dispose | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.Dispose
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObject(T) | Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject``1
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.AfterPropertiesSet

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject.Dispose Method

Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.Dispose

[Visual Basic]
Public NotOverridable Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject.GetObject Method

Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Implements

IFactoryObject.GetObject

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


PoolFactoryObject.GetObject(T) Method

Missing <summary> documentation for M:Spring.Data.GemFire.PoolFactoryObject.GetObject``1

[Visual Basic]
Protected Sub GetObject(Of T)()
[C#]
protected T GetObject<T>();

See Also

PoolFactoryObject Class | Spring.Data.GemFire Namespace


RegexInterest Class

Cache interest based on regular expression rather then individual key types.

For a list of all members of this type, see RegexInterest Members .

System.Object
AllKeysInterest
RegexInterest

[Visual Basic]
Public Class RegexInterest
Inherits AllKeysInterest
Implements IInitializingObject
[C#]
public class RegexInterest : AllKeysInterest, IInitializingObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

RegexInterest Members | Spring.Data.GemFire Namespace


RegexInterest Members

RegexInterest overview

Public Instance Constructors

RegexInterest Overloaded. Initializes a new instance of the RegexInterest class.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.
Regex | Gets the regex backing this interest

Public Instance Methods

AfterPropertiesSet | Ensures the regex property has been set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Fields

durable (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.durable
policy (inherited from AllKeysInterest) | Missing <summary> documentation for F:Spring.Data.GemFire.AllKeysInterest.policy

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

Overload List

Initializes a new instance of the RegexInterest class.

public RegexInterest()

Initializes a new instance of the RegexInterest class.

public RegexInterest(string)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,InterestResultPolicy)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,InterestResultPolicy,bool)

Initializes a new instance of the RegexInterest class.

public RegexInterest(string,bool)

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New()
[C#]
RegexInterest();

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String _
)
[C#]
RegexInterest(
string regex
);

Parameters

regex
The regex.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal durable As Boolean _
)
[C#]
RegexInterest(
string regex,
bool durable
);

Parameters

regex
The regex.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal policy As InterestResultPolicy _
)
[C#]
RegexInterest(
string regex,
InterestResultPolicy policy
);

Parameters

regex
The regex.
policy
The policy.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Constructor

Initializes a new instance of the RegexInterest class.

[Visual Basic]
Public Overloads Sub New( _
ByVal regex As String, _
ByVal policy As InterestResultPolicy, _
ByVal durable As Boolean _
)
[C#]
RegexInterest(
string regex,
InterestResultPolicy policy,
bool durable
);

Parameters

regex
The regex.
policy
The policy.
durable
if set to true register durable interest.

Remarks

The client can register any of its interest lists and continuous queries as durable. Durable interest remains even if the client disconnects for a period of time. During the client’s down time, the server maintains its durable subscriptions and then, when the client reconnects, plays them back to the client.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace | RegexInterest Constructor Overload List


RegexInterest Properties

The properties of the RegexInterest class are listed below. For a complete list of RegexInterest class members, see the RegexInterest Members topic.

Public Instance Properties

Durable (inherited from AllKeysInterest) | Gets or sets a value indicating whether this AllKeysInterest is durable.
Policy (inherited from AllKeysInterest) | Gets or sets the policy.
Regex | Gets the regex backing this interest

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


Regex Property

Spring GemFire 1.0.1 API Reference

RegexInterest.Regex Property

Gets the regex backing this interest

[Visual Basic]
Public Property Regex() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Regex { public get; public set; }

Property Value

The regex.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest Methods

The methods of the RegexInterest class are listed below. For a complete list of RegexInterest class members, see the RegexInterest Members topic.

Public Instance Methods

AfterPropertiesSet | Ensures the regex property has been set.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest.AfterPropertiesSet Method

Ensures the regex property has been set.

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegexInterest.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

RegexInterest Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject Class

Create a Gemstone.Gemfire.Cache.RegionsAttribute using standard .NET setter properties.

For a list of all members of this type, see RegionAttributesFactoryObject Members .

System.Object
RegionAttributesFactoryObject

[Visual Basic]
Public Class RegionAttributesFactoryObject
Implements IFactoryObject, IInitializingObject
[C#]
public class RegionAttributesFactoryObject : IFactoryObject, IInitializingObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

RegionAttributesFactoryObject Members | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject Members

RegionAttributesFactoryObject overview

Public Instance Constructors

RegionAttributesFactoryObject Constructor Initializes a new instance of the RegionAttributesFactoryObject class.

Public Instance Properties

CachingEnabled | Sets the caching enabled flag for this region.
ClientNotification | Sets the client notification to be enabled/disabled.
CloningEnabled | Gets or sets the cloning enabled.
ConcurrencyLevel | Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.
DiskPolicy | Sets the disk policy. Only used when a new region is created.
EntryIdleTimeout | Sets the entry idle timeout in seconds
EntryIdleTimeoutAction | Sets the entry idle timeout expiration action.
EntryTimeToLive | Sets the entry time to live in seconds
EntryTimeToLiveAction | Sets the entry time to live expiration action.
InitialCapacity | Sets the initial capacity of the map used for storing the entries. Default is 16
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.IsSingleton
LoadFactor | Sets the load factor of the map used for storing the entries. Default 0.75
LocalScope | Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.
LruEntriesLimit | Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.ObjectType
RegionIdleTimeout | Sets the region idle timeout in seconds
RegionIdleTimeoutAction | Sets the region idle timeout expiration action.
RegionTimeToLive | Sets the region time to live in seconds for the region as a whole
RegionTimeToLiveAction | Sets the region time to live expiration action.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetExpirationProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)
SetStorageProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject Constructor

Initializes a new instance of the RegionAttributesFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
RegionAttributesFactoryObject();

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject Properties

The properties of the RegionAttributesFactoryObject class are listed below. For a complete list of RegionAttributesFactoryObject class members, see the RegionAttributesFactoryObject Members topic.

Public Instance Properties

CachingEnabled | Sets the caching enabled flag for this region.
ClientNotification | Sets the client notification to be enabled/disabled.
CloningEnabled | Gets or sets the cloning enabled.
ConcurrencyLevel | Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.
DiskPolicy | Sets the disk policy. Only used when a new region is created.
EntryIdleTimeout | Sets the entry idle timeout in seconds
EntryIdleTimeoutAction | Sets the entry idle timeout expiration action.
EntryTimeToLive | Sets the entry time to live in seconds
EntryTimeToLiveAction | Sets the entry time to live expiration action.
InitialCapacity | Sets the initial capacity of the map used for storing the entries. Default is 16
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.IsSingleton
LoadFactor | Sets the load factor of the map used for storing the entries. Default 0.75
LocalScope | Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.
LruEntriesLimit | Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.ObjectType
RegionIdleTimeout | Sets the region idle timeout in seconds
RegionIdleTimeoutAction | Sets the region idle timeout expiration action.
RegionTimeToLive | Sets the region time to live in seconds for the region as a whole
RegionTimeToLiveAction | Sets the region time to live expiration action.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


CachingEnabled Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.CachingEnabled Property

Sets the caching enabled flag for this region.

[Visual Basic]
Public WriteOnly Property CachingEnabled() As Nullable(Of Boolean)
Public Set
End Set
End Property
[C#]
public bool? CachingEnabled { public set; }

Property Value

The caching is enabled.

Remarks

If true, cache data for this region in this process. If set to false, then no data is stored in the local process, but events and distributions will still occur, and the region can still be used to put and remove, etc... The default if not set is 'true', 'false' is illegal for regions of ScopeType.Local scope. LocalScope

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


ClientNotification Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.ClientNotification Property

Sets the client notification to be enabled/disabled.

[Visual Basic]
Public WriteOnly Property ClientNotification() As Nullable(Of Boolean)
Public Set
End Set
End Property
[C#]
public bool? ClientNotification { public set; }

Property Value

The client notification enabled.

Remarks

Ttrue if client notifications have to be enabled; false otherwise

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


CloningEnabled Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.CloningEnabled Property

Gets or sets the cloning enabled.

[Visual Basic]
Public WriteOnly Property CloningEnabled() As Nullable(Of Boolean)
Public Set
End Set
End Property
[C#]
public bool? CloningEnabled { public set; }

Property Value

The cloning enabled.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


ConcurrencyLevel Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.ConcurrencyLevel Property

Sets the allowed concurrency among updates to values in the region is guided by the concurrencyLevel, which is used as a hint for internal sizing. Default 16.

[Visual Basic]
Public WriteOnly Property ConcurrencyLevel() As Integer
Public Set
End Set
End Property
[C#]
public int ConcurrencyLevel { public set; }

Property Value

The concurrency level.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


DiskPolicy Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.DiskPolicy Property

Sets the disk policy. Only used when a new region is created.

[Visual Basic]
Public WriteOnly Property DiskPolicy() As DiskPolicyType
Public Set
End Set
End Property
[C#]
public DiskPolicyType DiskPolicy { public set; }

Property Value

The region disk policy.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


EntryIdleTimeout Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.EntryIdleTimeout Property

Sets the entry idle timeout in seconds

[Visual Basic]
Public WriteOnly Property EntryIdleTimeout() As UInt32
Public Set
End Set
End Property
[C#]
public uint EntryIdleTimeout { public set; }

Property Value

The entry idle timeout.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


EntryIdleTimeoutAction Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.EntryIdleTimeoutAction Property

Sets the entry idle timeout expiration action.

[Visual Basic]
Public WriteOnly Property EntryIdleTimeoutAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction EntryIdleTimeoutAction { public set; }

Property Value

The entry idle timeout action.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


EntryTimeToLive Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.EntryTimeToLive Property

Sets the entry time to live in seconds

[Visual Basic]
Public WriteOnly Property EntryTimeToLive() As UInt32
Public Set
End Set
End Property
[C#]
public uint EntryTimeToLive { public set; }

Property Value

The entry time to live.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


EntryTimeToLiveAction Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.EntryTimeToLiveAction Property

Sets the entry time to live expiration action.

[Visual Basic]
Public WriteOnly Property EntryTimeToLiveAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction EntryTimeToLiveAction { public set; }

Property Value

The entry time to live action.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


InitialCapacity Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.InitialCapacity Property

Sets the initial capacity of the map used for storing the entries. Default is 16

[Visual Basic]
Public WriteOnly Property InitialCapacity() As Integer
Public Set
End Set
End Property
[C#]
public int InitialCapacity { public set; }

Property Value

The initial capacity.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.IsSingleton Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.IsSingleton

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


LoadFactor Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.LoadFactor Property

Sets the load factor of the map used for storing the entries. Default 0.75

[Visual Basic]
Public WriteOnly Property LoadFactor() As Single
Public Set
End Set
End Property
[C#]
public float LoadFactor { public set; }

Property Value

The load factor.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


LocalScope Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.LocalScope Property

Sets a value indicating whether the region should be local scope, creating a private data set in the memory area where this region residers, invisible to other client caches in the system.

[Visual Basic]
Public WriteOnly Property LocalScope() As Boolean
Public Set
End Set
End Property
[C#]
public bool LocalScope { public set; }

Property Value

true if create a locally coped region; otherwise, false.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


LruEntriesLimit Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.LruEntriesLimit Property

Sets a limit on the number of entries that will be held in the cache. If a new entry is added while at the limit, the cache will evict the least recently used entry.

[Visual Basic]
Public WriteOnly Property LruEntriesLimit() As Nullable(Of UInt32)
Public Set
End Set
End Property
[C#]
public uint? LruEntriesLimit { public set; }

Property Value

The limit of the number of entries before eviction starts. Defaults to 0, meaning no LRU actions will used.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.ObjectType Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionAttributesFactoryObject.ObjectType

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionIdleTimeout Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.RegionIdleTimeout Property

Sets the region idle timeout in seconds

[Visual Basic]
Public WriteOnly Property RegionIdleTimeout() As UInt32
Public Set
End Set
End Property
[C#]
public uint RegionIdleTimeout { public set; }

Property Value

The region idle timeout.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionIdleTimeoutAction Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.RegionIdleTimeoutAction Property

Sets the region idle timeout expiration action.

[Visual Basic]
Public WriteOnly Property RegionIdleTimeoutAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction RegionIdleTimeoutAction { public set; }

Property Value

The region idle timeout action.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionTimeToLive Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.RegionTimeToLive Property

Sets the region time to live in seconds for the region as a whole

[Visual Basic]
Public WriteOnly Property RegionTimeToLive() As UInt32
Public Set
End Set
End Property
[C#]
public uint RegionTimeToLive { public set; }

Property Value

The region time to live.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionTimeToLiveAction Property

Spring GemFire 1.0.1 API Reference

RegionAttributesFactoryObject.RegionTimeToLiveAction Property

Sets the region time to live expiration action.

[Visual Basic]
Public WriteOnly Property RegionTimeToLiveAction() As ExpirationAction
Public Set
End Set
End Property
[C#]
public ExpirationAction RegionTimeToLiveAction { public set; }

Property Value

The region time to live action.

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject Methods

The methods of the RegionAttributesFactoryObject class are listed below. For a complete list of RegionAttributesFactoryObject class members, see the RegionAttributesFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetExpirationProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)
SetStorageProperties | Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.AfterPropertiesSet

[Visual Basic]
Public NotOverridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject.GetObject Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.GetObject

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Implements

IFactoryObject.GetObject

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject.SetExpirationProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetExpirationProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetExpirationProperties( _
ByVal attrFactory As AttributesFactory _
)
[C#]
protected virtual void SetExpirationProperties(
AttributesFactory attrFactory
);

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionAttributesFactoryObject.SetStorageProperties Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionAttributesFactoryObject.SetStorageProperties(GemStone.GemFire.Cache.AttributesFactory)

[Visual Basic]
Protected Overridable Sub SetStorageProperties( _
ByVal attrFactory As AttributesFactory _
)
[C#]
protected virtual void SetStorageProperties(
AttributesFactory attrFactory
);

See Also

RegionAttributesFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Class

Simple FactoryObject for retrieving generic GemFire Regions. If the region doesn't exist, an exception is thrown. For declaring and configuring new regions, see ClientRegionFactoryObject.

For a list of all members of this type, see RegionLookupFactoryObject Members .

System.Object
RegionLookupFactoryObject
ClientRegionFactoryObject

[Visual Basic]
Public Class RegionLookupFactoryObject
Implements IFactoryObject, IInitializingObject, IObjectNameAware
[C#]
public class RegionLookupFactoryObject : IFactoryObject, IInitializingObject, IObjectNameAware

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

RegionLookupFactoryObject Members | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Members

RegionLookupFactoryObject overview

Public Instance Constructors

RegionLookupFactoryObject Constructor Initializes a new instance of the RegionLookupFactoryObject class.

Public Instance Properties

Cache | Sets the cache used for creating the region
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.IsSingleton
Name | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectType

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

region Missing <summary> documentation for F:Spring.Data.GemFire.RegionLookupFactoryObject.region

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupFallback | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Constructor

Initializes a new instance of the RegionLookupFactoryObject class.

[Visual Basic]
Public Sub New()
[C#]
RegionLookupFactoryObject();

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Fields

The fields of the RegionLookupFactoryObject class are listed below. For a complete list of RegionLookupFactoryObject class members, see the RegionLookupFactoryObject Members topic.

Protected Instance Fields

region Missing <summary> documentation for F:Spring.Data.GemFire.RegionLookupFactoryObject.region

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject.region Field

Missing <summary> documentation for F:Spring.Data.GemFire.RegionLookupFactoryObject.region

[Visual Basic]
Protected region As Region
[C#]
protected Region region;

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Properties

The properties of the RegionLookupFactoryObject class are listed below. For a complete list of RegionLookupFactoryObject class members, see the RegionLookupFactoryObject Members topic.

Public Instance Properties

Cache | Sets the cache used for creating the region
IsSingleton | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.IsSingleton
Name | Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.
ObjectName | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectName
ObjectType | Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectType

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


Cache Property

Spring GemFire 1.0.1 API Reference

RegionLookupFactoryObject.Cache Property

Sets the cache used for creating the region

[Visual Basic]
Public WriteOnly Property Cache() As Cache
Public Set
End Set
End Property
[C#]
public Cache Cache { public set; }

Property Value

The cache to set

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


IsSingleton Property

Spring GemFire 1.0.1 API Reference

RegionLookupFactoryObject.IsSingleton Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.IsSingleton

[Visual Basic]
Public NotOverridable ReadOnly Property IsSingleton() As Boolean _
Implements IFactoryObject.IsSingleton

Public Get
End Get
End Property
[C#]
public bool IsSingleton { public get; }

Implements

IFactoryObject.IsSingleton

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


Name Property

Spring GemFire 1.0.1 API Reference

RegionLookupFactoryObject.Name Property

Sets the name of the cache region. If no cache is found under the given name, a new one will be created. If no name is given, the objectName will be used.

[Visual Basic]
Public WriteOnly Property Name() As String
Public Set
End Set
End Property
[C#]
public string Name { public set; }

Property Value

The region name.

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


ObjectName Property

Spring GemFire 1.0.1 API Reference

RegionLookupFactoryObject.ObjectName Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectName

[Visual Basic]
Public NotOverridable WriteOnly Property ObjectName() As String _
Implements IObjectNameAware.ObjectName

Public Set
End Set
End Property
[C#]
public string ObjectName { public set; }

Implements

IObjectNameAware.ObjectName

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


ObjectType Property

Spring GemFire 1.0.1 API Reference

RegionLookupFactoryObject.ObjectType Property

Missing <summary> documentation for P:Spring.Data.GemFire.RegionLookupFactoryObject.ObjectType

[Visual Basic]
Public NotOverridable ReadOnly Property ObjectType() As Type _
Implements IFactoryObject.ObjectType

Public Get
End Get
End Property
[C#]
public Type ObjectType { public get; }

Implements

IFactoryObject.ObjectType

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject Methods

The methods of the RegionLookupFactoryObject class are listed below. For a complete list of RegionLookupFactoryObject class members, see the RegionLookupFactoryObject Members topic.

Public Instance Methods

AfterPropertiesSet | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.AfterPropertiesSet
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.GetObject
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupFallback | Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject.AfterPropertiesSet Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.AfterPropertiesSet

[Visual Basic]
Public Overridable Sub AfterPropertiesSet() _
Implements IInitializingObject.AfterPropertiesSet
[C#]
public virtual void AfterPropertiesSet();

Implements

IInitializingObject.AfterPropertiesSet

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject.GetObject Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.GetObject

[Visual Basic]
Public NotOverridable Sub GetObject() _
Implements IFactoryObject.GetObject
[C#]
public object GetObject();

Implements

IFactoryObject.GetObject

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


RegionLookupFactoryObject.LookupFallback Method

Missing <summary> documentation for M:Spring.Data.GemFire.RegionLookupFactoryObject.LookupFallback(GemStone.GemFire.Cache.Cache,System.String)

[Visual Basic]
Protected Overridable Sub LookupFallback( _
ByVal cacheObject As Cache, _
ByVal regionName As String _
)
[C#]
protected virtual Region LookupFallback(
Cache cacheObject,
string regionName
);

See Also

RegionLookupFactoryObject Class | Spring.Data.GemFire Namespace


Spring.Data.GemFire.Caching

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire.Caching Namespace

This namespace contains all core classes making up the Spring GemFire project.

Namespace Hierarchy

Classes

Class | Description
GemFireCache | Cache implementation for Gemfire


GemFireCache Class

Cache implementation for Gemfire

For a list of all members of this type, see GemFireCache Members .

System.Object
AbstractCache
GemFireCache

[Visual Basic]
Public Class GemFireCache
Inherits AbstractCache
[C#]
public class GemFireCache : AbstractCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Caching

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemFireCache Members | Spring.Data.GemFire.Caching Namespace


GemFireCache Members

GemFireCache overview

Public Instance Constructors

GemFireCache Constructor Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.#ctor(GemStone.GemFire.Cache.Region)

Public Instance Properties

Count (inherited from Spring.Caching.AbstractCache) |
EnforceTimeToLive (inherited from Spring.Caching.AbstractCache) |
Keys | Missing <summary> documentation for P:Spring.Data.GemFire.Caching.GemFireCache.Keys
TimeToLive (inherited from Spring.Caching.AbstractCache) |

Public Instance Methods

Clear (inherited from Spring.Caching.AbstractCache) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Get(System.Object)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Spring.Caching.AbstractCache) | Overloaded.
Remove | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Remove(System.Object)
RemoveAll (inherited from Spring.Caching.AbstractCache) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoInsert | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.DoInsert(System.Object,System.Object,System.TimeSpan)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache Constructor

Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.#ctor(GemStone.GemFire.Cache.Region)

[Visual Basic]
Public Sub New( _
ByVal region As Region _
)
[C#]
GemFireCache(
Region region
);

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache Properties

The properties of the GemFireCache class are listed below. For a complete list of GemFireCache class members, see the GemFireCache Members topic.

Public Instance Properties

Count (inherited from Spring.Caching.AbstractCache) |
EnforceTimeToLive (inherited from Spring.Caching.AbstractCache) |
Keys | Missing <summary> documentation for P:Spring.Data.GemFire.Caching.GemFireCache.Keys
TimeToLive (inherited from Spring.Caching.AbstractCache) |

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


Keys Property

Spring GemFire 1.0.1 API Reference

GemFireCache.Keys Property

Missing <summary> documentation for P:Spring.Data.GemFire.Caching.GemFireCache.Keys

[Visual Basic]
Public Overrides ReadOnly Property Keys() As ICollection _
Implements ICache.Keys

Public Get
End Get
End Property
[C#]
public override ICollection Keys { public get; }

Implements

ICache.Keys

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache Methods

The methods of the GemFireCache class are listed below. For a complete list of GemFireCache class members, see the GemFireCache Members topic.

Public Instance Methods

Clear (inherited from Spring.Caching.AbstractCache) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Get(System.Object)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Spring.Caching.AbstractCache) | Overloaded.
Remove | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Remove(System.Object)
RemoveAll (inherited from Spring.Caching.AbstractCache) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoInsert | Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.DoInsert(System.Object,System.Object,System.TimeSpan)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache.DoInsert Method

Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.DoInsert(System.Object,System.Object,System.TimeSpan)

[Visual Basic]
Protected Overrides Sub DoInsert( _
ByVal key As Object, _
ByVal value As Object, _
ByVal timeToLive As TimeSpan _
)
[C#]
protected override void DoInsert(
object key,
object value,
TimeSpan timeToLive
);

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache.Get Method

Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Get(System.Object)

[Visual Basic]
Public Overrides Sub Get( _
ByVal key As Object _
) _
Implements ICache.Get
[C#]
public override object Get(
object key
);

Implements

ICache.Get

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


GemFireCache.Remove Method

Missing <summary> documentation for M:Spring.Data.GemFire.Caching.GemFireCache.Remove(System.Object)

[Visual Basic]
Public Overrides Sub Remove( _
ByVal key As Object _
) _
Implements ICache.Remove
[C#]
public override void Remove(
object key
);

Implements

ICache.Remove

See Also

GemFireCache Class | Spring.Data.GemFire.Caching Namespace


Spring.Data.GemFire.Config

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire.Config Namespace

This namespace contains all classes providing Cache advice support for the Spring GemFire project.

Namespace Hierarchy

Classes

Class | Description
CacheParser | Parser for definitions.
ClientRegionParser | Parser for definitions.
GemfireNamespaceParser | Namespace parser for GemFire
LookupRegionParser | Parser for definitions.
PoolParser | Parser for definitions.


CacheParser Class

Parser for definitions.

For a list of all members of this type, see CacheParser Members .

System.Object
AbstractObjectDefinitionParser
AbstractSingleObjectDefinitionParser
CacheParser

[Visual Basic]
Public Class CacheParser
Inherits AbstractSingleObjectDefinitionParser
[C#]
public class CacheParser : AbstractSingleObjectDefinitionParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Config

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

CacheParser Members | Spring.Data.GemFire.Config Namespace


CacheParser Members

CacheParser overview

Public Instance Constructors

CacheParser Constructor Initializes a new instance of the CacheParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ShouldGenerateId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)
ShouldGenerateIdAsFallback (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId | Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


CacheParser Constructor

Initializes a new instance of the CacheParser class.

[Visual Basic]
Public Sub New()
[C#]
CacheParser();

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


CacheParser Methods

The methods of the CacheParser class are listed below. For a complete list of CacheParser class members, see the CacheParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId | Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


DoParse Method

Spring GemFire 1.0.1 API Reference

CacheParser.DoParse Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

Overload List

Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

protected override void DoParse(XmlElement,ObjectDefinitionBuilder)

Inherited from AbstractSingleObjectDefinitionParser.

protected virtual void DoParse(XmlElement,ParserContext,ObjectDefinitionBuilder)

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


CacheParser.DoParse(XmlElement, ObjectDefinitionBuilder) Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

[Visual Basic]
Protected Overrides Overloads Sub DoParse( _
ByVal element As XmlElement, _
ByVal builder As ObjectDefinitionBuilder _
)
[C#]
protected override void DoParse(
XmlElement element,
ObjectDefinitionBuilder builder
);

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace | CacheParser.DoParse Overload List


CacheParser.GetObjectType Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.GetObjectType(System.Xml.XmlElement)

[Visual Basic]
Protected Overrides Sub GetObjectType( _
ByVal element As XmlElement _
)
[C#]
protected override Type GetObjectType(
XmlElement element
);

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


CacheParser.ResolveId Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.CacheParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

[Visual Basic]
Protected Overrides Sub ResolveId( _
ByVal element As XmlElement, _
ByVal definition As AbstractObjectDefinition, _
ByVal parserContext As ParserContext _
)
[C#]
protected override string ResolveId(
XmlElement element,
AbstractObjectDefinition definition,
ParserContext parserContext
);

See Also

CacheParser Class | Spring.Data.GemFire.Config Namespace


ClientRegionParser Class

Parser for definitions.

For a list of all members of this type, see ClientRegionParser Members .

System.Object
AbstractObjectDefinitionParser
AbstractSingleObjectDefinitionParser
ClientRegionParser

[Visual Basic]
Public Class ClientRegionParser
Inherits AbstractSingleObjectDefinitionParser
[C#]
public class ClientRegionParser : AbstractSingleObjectDefinitionParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Config

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

ClientRegionParser Members | Spring.Data.GemFire.Config Namespace


ClientRegionParser Members

ClientRegionParser overview

Public Instance Constructors

ClientRegionParser Constructor Initializes a new instance of the ClientRegionParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ShouldGenerateId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)
ShouldGenerateIdAsFallback (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Xml.ParserContext,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace


ClientRegionParser Constructor

Initializes a new instance of the ClientRegionParser class.

[Visual Basic]
Public Sub New()
[C#]
ClientRegionParser();

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace


ClientRegionParser Methods

The methods of the ClientRegionParser class are listed below. For a complete list of ClientRegionParser class members, see the ClientRegionParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Xml.ParserContext,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace


DoParse Method

Spring GemFire 1.0.1 API Reference

ClientRegionParser.DoParse Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Xml.ParserContext,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

Overload List

Inherited from AbstractSingleObjectDefinitionParser.

protected virtual void DoParse(XmlElement,ObjectDefinitionBuilder)

Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Xml.ParserContext,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

protected override void DoParse(XmlElement,ParserContext,ObjectDefinitionBuilder)

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace


ClientRegionParser.DoParse(XmlElement, ParserContext, ObjectDefinitionBuilder) Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Xml.ParserContext,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

[Visual Basic]
Protected Overrides Overloads Sub DoParse( _
ByVal element As XmlElement, _
ByVal parserContext As ParserContext, _
ByVal builder As ObjectDefinitionBuilder _
)
[C#]
protected override void DoParse(
XmlElement element,
ParserContext parserContext,
ObjectDefinitionBuilder builder
);

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace | ClientRegionParser.DoParse Overload List


ClientRegionParser.GetObjectType Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.ClientRegionParser.GetObjectType(System.Xml.XmlElement)

[Visual Basic]
Protected Overrides Sub GetObjectType( _
ByVal element As XmlElement _
)
[C#]
protected override Type GetObjectType(
XmlElement element
);

See Also

ClientRegionParser Class | Spring.Data.GemFire.Config Namespace


GemfireNamespaceParser Class

Namespace parser for GemFire

For a list of all members of this type, see GemfireNamespaceParser Members .

System.Object
NamespaceParserSupport
GemfireNamespaceParser

[Visual Basic]
<NamespaceParser(Namespace:="http://www.springframework.net/gemfire", SchemaLocation:="/Spring.Data.GemFire.Config/spring-gemfire-1.0.xsd", SchemaLocationAssemblyHint:=Spring.Data.GemFire.Config.GemfireNamespaceParser)> _
Public Class GemfireNamespaceParser
Inherits NamespaceParserSupport
[C#]
[NamespaceParser(Namespace="http://www.springframework.net/gemfire", SchemaLocation="/Spring.Data.GemFire.Config/spring-gemfire-1.0.xsd", SchemaLocationAssemblyHint=Spring.Data.GemFire.Config.GemfireNamespaceParser)]
public class GemfireNamespaceParser : NamespaceParserSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Config

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

GemfireNamespaceParser Members | Spring.Data.GemFire.Config Namespace


GemfireNamespaceParser Members

GemfireNamespaceParser overview

Public Instance Constructors

GemfireNamespaceParser Constructor Initializes a new instance of the GemfireNamespaceParser class.

Public Instance Methods

Decorate (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Missing <summary> documentation for M:Spring.Data.GemFire.Config.GemfireNamespaceParser.Init
ParseElement (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RegisterObjectDefinitionParser (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |

See Also

GemfireNamespaceParser Class | Spring.Data.GemFire.Config Namespace


GemfireNamespaceParser Constructor

Initializes a new instance of the GemfireNamespaceParser class.

[Visual Basic]
Public Sub New()
[C#]
GemfireNamespaceParser();

See Also

GemfireNamespaceParser Class | Spring.Data.GemFire.Config Namespace


GemfireNamespaceParser Methods

The methods of the GemfireNamespaceParser class are listed below. For a complete list of GemfireNamespaceParser class members, see the GemfireNamespaceParser Members topic.

Public Instance Methods

Decorate (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Missing <summary> documentation for M:Spring.Data.GemFire.Config.GemfireNamespaceParser.Init
ParseElement (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RegisterObjectDefinitionParser (inherited from Spring.Objects.Factory.Xml.NamespaceParserSupport) |

See Also

GemfireNamespaceParser Class | Spring.Data.GemFire.Config Namespace


GemfireNamespaceParser.Init Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.GemfireNamespaceParser.Init

[Visual Basic]
Public Overrides Sub Init() _
Implements INamespaceParser.Init
[C#]
public override void Init();

Implements

INamespaceParser.Init

See Also

GemfireNamespaceParser Class | Spring.Data.GemFire.Config Namespace


LookupRegionParser Class

Parser for definitions.

For a list of all members of this type, see LookupRegionParser Members .

System.Object
AbstractObjectDefinitionParser
AbstractSingleObjectDefinitionParser
LookupRegionParser

[Visual Basic]
Public Class LookupRegionParser
Inherits AbstractSingleObjectDefinitionParser
[C#]
public class LookupRegionParser : AbstractSingleObjectDefinitionParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Config

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

LookupRegionParser Members | Spring.Data.GemFire.Config Namespace


LookupRegionParser Members

LookupRegionParser overview

Public Instance Constructors

LookupRegionParser Constructor Initializes a new instance of the LookupRegionParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ShouldGenerateId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)
ShouldGenerateIdAsFallback (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace


LookupRegionParser Constructor

Initializes a new instance of the LookupRegionParser class.

[Visual Basic]
Public Sub New()
[C#]
LookupRegionParser();

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace


LookupRegionParser Methods

The methods of the LookupRegionParser class are listed below. For a complete list of LookupRegionParser class members, see the LookupRegionParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace


DoParse Method

Spring GemFire 1.0.1 API Reference

LookupRegionParser.DoParse Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

Overload List

Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

protected override void DoParse(XmlElement,ObjectDefinitionBuilder)

Inherited from AbstractSingleObjectDefinitionParser.

protected virtual void DoParse(XmlElement,ParserContext,ObjectDefinitionBuilder)

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace


LookupRegionParser.DoParse(XmlElement, ObjectDefinitionBuilder) Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

[Visual Basic]
Protected Overrides Overloads Sub DoParse( _
ByVal element As XmlElement, _
ByVal builder As ObjectDefinitionBuilder _
)
[C#]
protected override void DoParse(
XmlElement element,
ObjectDefinitionBuilder builder
);

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace | LookupRegionParser.DoParse Overload List


LookupRegionParser.GetObjectType Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.LookupRegionParser.GetObjectType(System.Xml.XmlElement)

[Visual Basic]
Protected Overrides Sub GetObjectType( _
ByVal element As XmlElement _
)
[C#]
protected override Type GetObjectType(
XmlElement element
);

See Also

LookupRegionParser Class | Spring.Data.GemFire.Config Namespace


PoolParser Class

Parser for definitions.

For a list of all members of this type, see PoolParser Members .

System.Object
AbstractObjectDefinitionParser
AbstractSingleObjectDefinitionParser
AbstractSimpleObjectDefinitionParser
PoolParser

[Visual Basic]
Public Class PoolParser
Inherits AbstractSimpleObjectDefinitionParser
[C#]
public class PoolParser : AbstractSimpleObjectDefinitionParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Spring.Data.GemFire.Config

Assembly: Spring.Data.GemFire (in Spring.Data.GemFire.dll)

See Also

PoolParser Members | Spring.Data.GemFire.Config Namespace


PoolParser Members

PoolParser overview

Public Instance Constructors

PoolParser Constructor Initializes a new instance of the PoolParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ShouldGenerateId (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)
ShouldGenerateIdAsFallback (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser)

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId | Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


PoolParser Constructor

Initializes a new instance of the PoolParser class.

[Visual Basic]
Public Sub New()
[C#]
PoolParser();

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


PoolParser Methods

The methods of the PoolParser class are listed below. For a complete list of PoolParser class members, see the PoolParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseElement (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoParse | Overloaded. Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)
DoParse (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectType | Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.GetObjectType(System.Xml.XmlElement)
GetObjectTypeName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
GetParentName (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInternal (inherited from Spring.Objects.Factory.Xml.AbstractSingleObjectDefinitionParser) |
RegisterObjectDefinition (inherited from Spring.Objects.Factory.Xml.AbstractObjectDefinitionParser) |
ResolveId | Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


DoParse Method

Spring GemFire 1.0.1 API Reference

PoolParser.DoParse Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

Overload List

Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

protected override void DoParse(XmlElement,ObjectDefinitionBuilder)

Inherited from AbstractSingleObjectDefinitionParser.

protected virtual void DoParse(XmlElement,ParserContext,ObjectDefinitionBuilder)

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


PoolParser.DoParse(XmlElement, ObjectDefinitionBuilder) Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.DoParse(System.Xml.XmlElement,Spring.Objects.Factory.Support.ObjectDefinitionBuilder)

[Visual Basic]
Protected Overrides Overloads Sub DoParse( _
ByVal element As XmlElement, _
ByVal builder As ObjectDefinitionBuilder _
)
[C#]
protected override void DoParse(
XmlElement element,
ObjectDefinitionBuilder builder
);

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace | PoolParser.DoParse Overload List


PoolParser.GetObjectType Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.GetObjectType(System.Xml.XmlElement)

[Visual Basic]
Protected Overrides Sub GetObjectType( _
ByVal element As XmlElement _
)
[C#]
protected override Type GetObjectType(
XmlElement element
);

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


PoolParser.ResolveId Method

Missing <summary> documentation for M:Spring.Data.GemFire.Config.PoolParser.ResolveId(System.Xml.XmlElement,Spring.Objects.Factory.Support.AbstractObjectDefinition,Spring.Objects.Factory.Xml.ParserContext)

[Visual Basic]
Protected Overrides Sub ResolveId( _
ByVal element As XmlElement, _
ByVal definition As AbstractObjectDefinition, _
ByVal parserContext As ParserContext _
)
[C#]
protected override string ResolveId(
XmlElement element,
AbstractObjectDefinition definition,
ParserContext parserContext
);

See Also

PoolParser Class | Spring.Data.GemFire.Config Namespace


Spring.Data.GemFire.CachingHierarchy

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire.Caching Hierarchy

Object
AbstractCache ---- ICache
GemFireCache

See Also

Spring.Data.GemFire.Caching Namespace


Spring.Data.GemFire.ConfigHierarchy

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire.Config Hierarchy

Object
AbstractObjectDefinitionParser ---- IObjectDefinitionParser
AbstractSingleObjectDefinitionParser
CacheParser
ClientRegionParser
LookupRegionParser
AbstractSimpleObjectDefinitionParser
PoolParser
NamespaceParserSupport ---- INamespaceParser
GemfireNamespaceParser

See Also

Spring.Data.GemFire.Config Namespace


Spring.Data.GemFireHierarchy

Spring GemFire 1.0.1 API Reference

Spring.Data.GemFire Hierarchy

Object
AllKeysInterest ---- IInterest
KeyInterest ---- IInitializingObject
RegexInterest ---- IInitializingObject
CacheFactoryObject ---- IPersistenceExceptionTranslator, IFactoryObject, IInitializingObject, IObjectNameAware, IDisposable
GemFireCacheUtils
IInterest
PoolConnection
PoolFactoryDefaults
PoolFactoryObject ---- IApplicationContextAware, IFactoryObject, IInitializingObject, IObjectNameAware, IDisposable
RegionAttributesFactoryObject ---- IFactoryObject, IInitializingObject
RegionLookupFactoryObject ---- IFactoryObject, IInitializingObject, IObjectNameAware
ClientRegionFactoryObject ---- IObjectFactoryAware, IDisposable
Exception ---- ISerializable
DataAccessException
NonTransientDataAccessException
UncategorizedDataAccessException
GemFireSystemException
ValueType
Enum ---- IComparable, IConvertible, IFormattable
InterestResultPolicy

See Also

Spring.Data.GemFire Namespace