For the latest stable version, please use Spring Security 5.7.2!

Testing

This section describes the testing support provided by Spring Security.

To use the Spring Security test support, you must include spring-security-test-5.7.1.jar as a dependency of your project.

At a high level Spring Security’s test support provides integration for: